Ethernet clients disconnecting, "default gateway is not available"

Hey, I have this weird problem and it's driving me insane.
I'm using openWrt on a Netgear WAC124 (119MB RAM) for 1.5 months, and it worked fine at first.
Firmware version : OpenWrt 21.02.0 r16279-5cc0535800 / LuCI openwrt-21.02 branch git-21.231.26241-422c175
Kernel Version : 5.4.143

For a week or so I've had this problem : when I start downloading at a relative high speed (ex : 15 MB/s) my ethernet connection gets disconnected almost instantly.
Ways to trigger this : watching a stream on twitch, torrenting (linux distros), ...
Windows problem solver can restore my connection temporarily, it states that the problem is "De standaardgateway is niet beschikbaar" in Dutch, translated to English : "default gateway is not available"
Obviously this is not a solution to the problem, as just resuming a download will disable my connection again.

This only happens on clients connected with ethernet, clients connected with wifi don't have this problem.
The disconnects happen on multiple computers.
I have tried resetting with the "firstboot", but even without making any changes the problem still persists.

I have been trying to fix this for the past week, the router worked fine for over a month before.
I was using a snapshot at first, but tried the new release when this problem started occuring. (openwrt-ramips-mt7621-netgear_wac124-squashfs-factory)

What I've tried :

  • Rebooting (obviously).
  • Resetting to factory settings (firstboot command).
  • Reflashing openWrt multiple times (first the stock Netgear image and then openWrt, otherwise the file system is readonly for some reason).
  • Disabling IPv6 on lan : How to disable ipv6 on the router - #2 by vgaetera.
  • Checking Ram usage with "htop" through ssh while triggering a disconnect by starting a (linux distro) torrent. (idle 53/119 MB used, when disconnecting it's about the same)
  • Checking CPU usage with "htop" through ssh while triggering a disconnect by starting a (linux distro) torrent. (when disconnecting one core spikes to +-70%, the rest remains under 20%)
  • Disabling DHCP server stuff so the modem from my ISP assigned me a local IP.
  • Tested my physical cables with a Network Cable Tester.
  • Connecting ethernet cable to different LAN port on router
  • Some other things I'm probably forgetting right now ...

How I'm checking if I have internet :

  • Loading random webpages
  • "ping -t"
  • "ping -t" (ISP modem)
  • "ping -t" (openWrt router)
    (These pings just start printing "Request timed out" when the connection drops, so the cables are detected as plugged in on my computers.)

I searched this forum and the internet, but couldn't find a relevant topic anywhere, so I'm posting this here. I hope it's under the right category.

The factory image is supposed to be flashed on the device only the first time, over the vendor firmware.
After you have a working OpenWrt installation up and running, the sysupgrade image must be used.
Did you follow that order?


the .bin file to use sysupgrade bricked my router, so I flashed stock again with nmrpflash and then the updated openwrt image

This device was recently supported from 21.02. Did you flash some snapshot or release candidate version by any chance which could have caused the issue? Did you try the current 21.02?


It's currently running 21.02.0

Looks like it's fixed.

Upgraded to the most recent snapshot with sysupgrade.
I guess it's a bug with 21.02.0

New version :
Platform: ramips/mt7621
Version: SNAPSHOT (r17486-cdc646c032)
Date: 2021-09-08 04:13:07

Thanks for your replies Trendy! :smile:

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.