Error when installing on WR841N V13.0 via TFTP

Ok, so I was trying to install openwrt to my TP-Link TL-WR841N V13 through the Tftpd64 program but I always get this error on the log viewer tab:

Connection received from []( on port 3111 [02/02 21:22:54.247]
Read request for file <tp_recovery.bin>. Mode octet [02/02 21:22:54.247]
OACK: <timeout=1,> [02/02 21:22:54.247]
Using local port 60455 [02/02 21:22:54.247]
File <tp_recovery.bin> : error 10022 in system call send An invalid argument was supplied. [02/02 21:22:56.148]

I've tried everything that came to my mind, from disabling the Windows Firewall to using a different program or even trying to do this on a different port on the router, but nothing really worked. Any help would be appreciated!

I've tried to look this error up on the internet but I haven't found anything about it. If anyone is able to tell me what my problem here is, please do (I'm a bit desperate rn :sweat_smile:)

Did you read TL-WR841N v13 WiFi not stable?

Long thread, might be useful.