Error: Unknown error (NEGOTIATION_FAILED)

my wan can't connect to pppoe it did before but now it won't any help please

archer c7 v5
openWRT v21.02

I notice your WAN us set to eth2. Try setting it to WAN?
I had a similar connection failure error when I upgraded. The root cause was that I had failed to notice that the keep settings checkbox was checked by default and I had failed to unchecked it.
If you think that could be your issue try reflashing with setting erased

I tried but no use
the thing is yesterday it was working great i reflashed my openwrt and that happend

did you upgrade from 19 ?

In that case you should reset your settings, since swconfig was replaced by DSA.

i donot remember but i donot think so
i will give it a try since i have no other option

no it didn't work still the same error

Actuslly i see from yr screenshit that youre on 21..
Did you uncheck the save settings checbox hen you flashed it?
If you go to interfaces > wan > general setting
What options do you have under device?
You should have switch port wan (wan). If so select that and hit save

so PPPOE still didn't work so used DHCP
and changed my modem ip to and now I'm having full speed

on openwrt
your LAN IP should be
and your WAN IP should be based on your router (the one without openwrt) DHCP

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.