Error message when installing onto a BT Home Hub 5A

I am getting the following error message when running sysupgrade from the BTHOMEHUBV5A-installimage for a new install on to a BT Home Hub 5A:

	Cannot save config while running from ramdisk.
	killall: watchdog: no process killed
	Watchdog handover: fd=3
	- watchdog -
	Nand upgrade failed
	Command failed: Request timed out

I have tried restoring the BT firmware image and repeating the install procedure from the beginning. The error message is the same each time.

Both nanddump and restore work without any errors. This suggests the nand hardware in the router is OK. The length of the hh5a.nanddump file generated is 133,562,368 bytes, which looks like the entire device reads OK.

I have tried the "nand bad" command from the VR9 boot loader. This reports the flash device has 5 bad blocks:

Device 0 bad blocks:

I presume the file system will exclude these blocks from use and this is not the cause of my problem.

I am using lede-lantiq-xrx200-BTHOMEHUBV5A-installimage.bin downloaded from
This has the following sha256: 56384323940ca34572287ab8fe3e9367321e71fa3710063ed31bfebfc1f4d767

Is this is the most up to date version?

I have checked that the router can read the openwrt-18.06.5-lantiq-xrx200-bt_homehub-v5a-squashfs-sysupgrade.bin file from the USB drive. Running md5sum on it from the router displays the same value as md5sum produces on my PC on the original downloaded file.

Can anybody suggest what I should do to diagnose why the upgrade is failing? The install image code on appears to be stable for the past 2+ years. Surely I have not encountered a new problem with it ?

I think every HomeHub has some of those bad-blocks but it doesn't prevent you from installing OpenWrt. The procedure for this is rather straightforward but it does have issues sometimes.

I would suggest you to restore your stock dump through the install-image and then reboot the router and follow the instructions again. I remember having difficulties installing OpenWrt the first time on this router and I had to restore stock in order to make it work.

Have you tried running the sysupgrade command with the .bin file copied to /tmp folder instead of from USB flash drive? (See section 4.2 of the HH5A lede install guide)

Try the original v0.1 LEDE install image and uboot ASC files from 2016, but I doubt it will make any difference.

If you unlock uboot when restoring BT firmware, try loading LEDE install image from internal BT bootloader instead of from the custom uboot .ASC file. See section 2.5 of the install guide PDF.

You could try restoring nanddump from another HH5A.

Otherwise, you probably have a bad hub that doesn't want to play ball if all of the above fail.

Thank you both for your suggestions.

I copied the *sysupgrade.bin file to the /tmp directory as suggested and ran the sysupgrade on it from there. Amazingly it worked.

Perhaps there is an issue with my USB drive, maybe a timing problem.

So, thanks.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.