Error message when I try to to update (swconfig to DSA migration)

Hi everyone, I own a Xiaomi Mi 4A Gigabit Edition Route and have it running with OpenWRT for a while now. Today I tried to update my OpenWRT version for the first time but I am running into issues.

I get this error message when I try to flash to the new OpenWRT version (openwrt-21.02.0-ramips-mt7621-xiaomi_mi-router-4a-gigabit-squashfs-sysupgrade.bin)

This is my current OpenWRT System:

Please read the message in your screenshot, feel free to check the release notes for 21.02 as well - on top of that there is roughly a metric ton of virtually identical threads on this forum as well (which will be handily found via the forum search function).


Can you link some? The search function return this thread.

Also the current release notes state "An upgrade from OpenWrt 19.07 to OpenWrt 21.02 is supported in many cases, including preserving configuration. A configuration backup is advised nonetheless when upgrading from OpenWrt 19.0" which is a bit confusing.

@uzytkownik - what device are you trying to upgrade?

Some devices will properly upgrade with settings intact from 19.07, but others will not work properly due to major changes such as the migration from swconfig to DSA.

The safest approach is to upgrade and not keep settings. Then you can setup the device fresh and ensure the settings are appropriate for the new version. Make a backup of your config first, and you can always use that as a reference for recreating your settings.

1 Like

I saw this message same you.I was nervous about it.
After some minutes, I checked the 'Force upgrade' and the router work well until now.

The resan is the different configs between 19 and 21.

@psherman Point is moot as I bricked the device as I accidentally powered it off during update (tried to get the ethernet cable out). For whatever reason I was unable to connect to serial console via TTL.

But WRT1200AC.