Error after upgrading from 23.05.2 to 23.05.3


I tried to upgrade from version 24.05.2 using a custom image made with image builder for x86/64 as i always do and now i have an error on the staus page


can't convert undefined to object

I have no clue what might have made this, I've used this custom build for ages and always did an upgrade directly on the upgrade page with luci and choose to keep all configs and never had an issue.
Any ideas on how to solve this... apart from it it all seems to work fine! apparently.

Edit: I found the issue. Was a conflicting config file dns-proxy. Is there away these conflicting config files fix themselves after a package upgrade or sys upgrade ? It’s very annoying to try to debug what the hell went wrong tbh

Don’t save settings when upgrading.

The issue is if I do that and then restore restore a backup the same error happens.
In the meantime I foud out what the problem was … it was the config file from luci-dns proxy. I deleted the package and config and reinstalled and it fixed itself ! Fortunately was something easy to to reconfigure , either way this shouldn’t happen