Engenius EAP1750H (EasyWRT)

I bought an Engenius EAP1750H so I can place my wireless access in the center of my house. I was going to originally leave the original firmware until I found I might be able to install openwrt and utilize MQTT to help bring all the smart devices into Domoticz to control them from one place. I was going to do this with a router I bought separately, but I've had troubles getting firmware to flash on that device. After some searching, I couldn't find a firmware image on the site specifically for my access point. A Google search brought up EasyWRT which claimed they had created a firmware for this device. I downloaded and tried to test it out. The problem is in order to utilize it, it needs an activation code which they charge for. I tried flashing back to original factory firmware, but will not flash ever since I used their image. Out of frustration, I paid for the activation which seemed okay because they claimed they had a working firmware for it. The version the used is OpenWrt Chaos Calmer 15.05 / 3.18.21. While it seemed to work, I discovered a few issues. The first was dealing with opkg and trying to update it. It will not update and after searching I thought it might be the address it was searching. After finding what it was looking for through my browser, I corrected the URLs to match. It still doesn't work because after researching the error further, it seems it is not connecting to the internet through the LAN port. I've tried to fix this over the past couple days and I cannot figure it out. Please help. I don't even know what information to post.

Im sorry to hear what youve gone through.. chaos calmer is very old at this point now .

I dont see any page matching your device here

I am curious what easywrt gave you..

It is slightly off-topic to request for help in OpenWrt forum, for a device that it is not supported by OpenWrt. On the other hand you have paid for EasyWRT, so have you tried to ask for their support first?

1 Like

On the list from the link, the Engenius ESR1750 is almost identical to what is in the EAP1750H, at least from what I can tell. I know it is sad that they had such an outdated version, but when searching for this particular model they claimed it worked.

There have been versions for it before and yes I did attempt to contact them about the issues. They do not have a direct email to do so, only a web form to submit any problems to. I have not received any response from them since contacting them. I think it is also ridiculous that I cannot flash back to the original firmware from Engenius because of their firmware.

If thats the case and your willing to risk it you could try the debrick steps for the esr-1750


If that doesnt work, youll need a serial (again , this is assuming the eap-1750 is the same )

Feel free to keep updating this thread with how you get on.

I may consider attempting de-bricking it if I keep having no luck getting it to function. Technically it does function, it just won't ping an internet address (google.com for example) or update or install anything using opkg. From what I read, it appears the internet is turned off on the LAN port. I don't know exactly how to turn it on though. I can connect through SSH and look around at setting that way or through the web interface.

Here is the contents from /etc/config/network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr ''
        option netmask ''

config globals 'globals'
        option ula_prefix 'fd7c:5966:3c77::/48'

config interface 'lan'
        option ifname 'eth0'
        option force_link '1'
        option type 'bridge'
        option proto 'static'
        option ipaddr ''
        option netmask ''
        option ip6assign '60'

There doesn't appear to be a namserver configured in lan interface. Is that a mistake or is it configured already in /etc/resolv.conf ?

Can you ping directly an address like ?

Also regarding the switch_vlan part, The CPU port might need to be tagged.

Here is what is listed in /etc/resolv.conf

search lan

and here is what I get when I pink

root@OpenWrt:~# ping
PING ( 56 data bytes
ping: sendto: Network is unreachable

Unless youve got some special setup here, wouldnt you need to define a default gateway ?

From wireless client connected, can it ping ? (Do you have some other device acting as dhcp server).

This is the default configuration of OpenWrt for devices with a single Ethernet port. It exists mostly so you can log in and reconfigure.

There are two major ways to go with it:

  • a standard router where the Ethernet port becomes the WAN, and you log in and use the LAN over WiFi
  • a LAN device or "dumb AP" where the OpenWrt unit is part of a network with another router which provides a link to the Internet. A dumb AP works primarily as a converter to bring wireless users into a wired network.

To get the second one working, you need to do three things:

  • Change the LAN IP to something that is not the same as anything else in the network, but in the same subnet range.
  • Add lines in the lan section of /etc/config/network to make OpenWrt aware that there is a main router as the gateway to the Internet and the DNS server:
    option ipaddr ''   # This device (the dumb AP) IP address
    option gateway ''  # The main router
    option dns ''
  • Disable the LAN DHCP server. In /etc/config/dhcp, replace the whole LAN section with one line "option ignore 1" like the WAN has.

This solution seemed to fix it. I will do some testing to make sure. Thanks for the help. I am able to ping addresses like google.com now and I have an updated package list after changing downloads to archive in distfeeds.conf

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.