Enabling WMM causes issues

Hi. I have a Linksys WRT3200ACM LuCI running openwrt-18.06 and things have been running well except for one thing. All of my IOT devices stop working when WMM mode is enabled on the 2.4GHz SSID. My settings -

config wifi-device 'radio1'
	option type 'mac80211'
	option hwmode '11g'
	option path 'soc/soc:pcie/pci0000:00/0000:00:02.0/0000:02:00.0'
	option legacy_rates '1'
	option country 'AU'
	option channel '1'
	option bursting '1'
	option ff '1'
	option compression '1'
	option turbo '1'
	option htmode 'HT40'

config wifi-iface 'default_radio1'
	option device 'radio1'
	option network 'lan'
	option mode 'ap'
	option key '****'
	option ssid '****'
	option disassoc_low_ack '0'
	option encryption 'psk-mixed'
	option wmm '1'

I've tried tweaking several settings but not had success. The problem I have is when I disable WMM, my Android tablet stops working. Any ideas?

Create a second wireless network for IOT devices

Thanks for the suggestion. Interestingly enough, I just did that and I’m in the middle of rehoming all the devices. But I’d still like to understand root cause of the issue and more importantly a fix rather than a workaround.

does it work if your remove these? (and keep wmm on)

option bursting '1'
option ff '1'
option compression '1'
option turbo '1'

Tried taking those out but still no success.

I have the same exact issue, I was wondering if you managed to understand the cause of this issue. I first thought it was related to the WAP2 setting and rekeying interval, then the WMM but still eihter the IoT's connect well or my android connects well.

I got around it by creating two SSIDs
SSID1: WMM enabled. Used by all Android and 2.4GHz clients.
SSID2: WMM disabled. Used by all IOT devices.

I’ve also disabled broadcasting the second SSID so when any new clients try to connect, they only see one SSID for 2.4G and another one for 5G.

1 Like

I also have this issue with my Second Generation Nest Protect (CO/Smoke alarm.)

It connects to the WiFi but complains that it can't connect to the Internet. Disabling WMM on the 802.11bgn (2.4 GHz) guest network I setup for my IOT devices fixes the issue.

But why?

All of my other IOT devices connect to the 802.11acn (5 GHz) guest network and are unaffected. The second generation Nest Protect is a 2.4 GHZ only device.

I am running OpenWrt 19.07.3 on a Linksys WRT1900ACS.

This problem has been on for quite a while. I've tested other routers with OEM firmware and they all work fine. The OpenWrt one crashes the wifi on my Broadcom-based laptops, specifically the 2.4Ghz band. Tried all sorts of things, on both my laptops and router but nothing seems to fix the random crashes. Can't tell if this is a OpenWrt issue or wifi interface issue (OpenWrt is using an Atheros AR9287).

I hope someone can look at this issue.

My issue as follows:

I have WRT1900ASC (v23.05.0 r23497). I use 2.4G only (5G antenna is disabled). Laptop (Windows 10) working fine. All android devices are working fine with decent 40Mb speed. However my Desktop PC (Linux) has very poor connection or not having such connection at all (drops connections sometimes). I tried to connect my Desktop linux pc to other wifi networks - everything works fine as expected. I tried to use a different Wifi card on my PC, same issue.

After I disabled WMM, my desktop linux PC finally started working. Not the best speed as on Windows, but at least 10Mb and it's not disconnecting.

So I heard that WMM is useless, and maybe it should be disabled by default on OpenWRT. If not please have a look at that as I afraid the case has been forgotten.
I assume the same issue could be with WRT3200. Please do not kill OpenWRT reputation.


WiFi link speeds above 54 Mbps require WMM to be active IIRC... so WMM is not really useless.

Apparently the WiFi driver development was essentially halted:

hardly OpenWrt's fault...

1 Like

Indeed, WMM is a hard requirement for 802.11n/ac/ax/be (it's the reason to get faster speeds).

Your problems are not with WMM itself, but the abysmal hardware/ firmware/ driver quality of this Marvell WLAN chipset, which always had interoperability issues with other clients. Disabling WMM is indeed a known workaround to make mwlwifi more interoperable (without actually fixing it or becoming 'perfect' at that), more compatible, but it comes at a huge cost of limiting yourself to 802.11g speeds (<54 MBit/s), rather than benefiting from the full performance its 802.11ac radios 'should' give your (~400 MBit/s on 5 GHz, ~120 MBit/s on 2.4 GHz).

This particular issue is mwlwifi-only, mt76 (rt3200) should not have any issues with WMM and get full speed (700-800 MBit/s) over the ether.

1 Like