Enabling WMM causes issues

Hi. I have a Linksys WRT3200ACM LuCI running openwrt-18.06 and things have been running well except for one thing. All of my IOT devices stop working when WMM mode is enabled on the 2.4GHz SSID. My settings -

config wifi-device 'radio1'
	option type 'mac80211'
	option hwmode '11g'
	option path 'soc/soc:pcie/pci0000:00/0000:00:02.0/0000:02:00.0'
	option legacy_rates '1'
	option country 'AU'
	option channel '1'
	option bursting '1'
	option ff '1'
	option compression '1'
	option turbo '1'
	option htmode 'HT40'

config wifi-iface 'default_radio1'
	option device 'radio1'
	option network 'lan'
	option mode 'ap'
	option key '****'
	option ssid '****'
	option disassoc_low_ack '0'
	option encryption 'psk-mixed'
	option wmm '1'

I've tried tweaking several settings but not had success. The problem I have is when I disable WMM, my Android tablet stops working. Any ideas?

Create a second wireless network for IOT devices

Thanks for the suggestion. Interestingly enough, I just did that and I’m in the middle of rehoming all the devices. But I’d still like to understand root cause of the issue and more importantly a fix rather than a workaround.

does it work if your remove these? (and keep wmm on)

option bursting '1'
option ff '1'
option compression '1'
option turbo '1'

Tried taking those out but still no success.

I have the same exact issue, I was wondering if you managed to understand the cause of this issue. I first thought it was related to the WAP2 setting and rekeying interval, then the WMM but still eihter the IoT's connect well or my android connects well.

I got around it by creating two SSIDs
SSID1: WMM enabled. Used by all Android and 2.4GHz clients.
SSID2: WMM disabled. Used by all IOT devices.

I’ve also disabled broadcasting the second SSID so when any new clients try to connect, they only see one SSID for 2.4G and another one for 5G.

1 Like

I also have this issue with my Second Generation Nest Protect (CO/Smoke alarm.)

It connects to the WiFi but complains that it can't connect to the Internet. Disabling WMM on the 802.11bgn (2.4 GHz) guest network I setup for my IOT devices fixes the issue.

But why?

All of my other IOT devices connect to the 802.11acn (5 GHz) guest network and are unaffected. The second generation Nest Protect is a 2.4 GHZ only device.

I am running OpenWrt 19.07.3 on a Linksys WRT1900ACS.