Enabling VLAN for 32X using Dc502 latest firmware

Hi everyone. A pretty novice user here trying his way to enable VLAN as my ISP requires it for Internet and IPTV to work.

I have found out what are the settings required for VLAN to work,
Internet VLAN ID: 10
Priority: 0
Wired Ports 1, 2, 3
Wireless 2.4G and 5Ghz

Priority: 4
Wired Port 4

However in the OpenWRT menu, "Network", "Switch", I only see CPU eth0, eth1(not sure to tagged or untagged or off), LAN 1-4 and WAN.
Afaik and gather, the priority setting is extremely important to get things right and running. Any idea how I should go about it? Thank you!

Typically you will have 2 VLANs in the default configuration: one for LAN and one for WAN.

You will leave the WAN (the one that will have the WAN port untagged) as it's.

Now for the LAN, you need to change the ID to 10, and change LAN port 4 to off.

Then you create another VLAN with ID 20, make CPU tagged (same CPU suite one used for VLAN 10) and set LAN port 4 as untagged.

If priority is really required, then check this

I am using the exact same ISP as the man u linked. Seems like he didn't manage as well sigh..

I tried using this

But no signal for Internet and IPTV

Linksys has it's own guide below, on how to setup VLAN for my ISP, but 32X default has no such functions -_-

Any help would be appreciated, thank you.

You should remove VLAN 1

Then turn OFF CPU (eth1) and WAN for both VLAN 10 and 20.

If that doesn't work then look at the priority thing