Enable WOL from WAN on LEDE

I'm new to LEDE, and I'm having a bit of a problem. I'm trying to set up WOL on my network in such a way to allow packets from WAN.

On the stock Asus FW or DDWRT I would do this by issuing the following command:

arp -i br0 -s 192.168.1.254 FF:FF:FF:FF:FF:FF

As an alternative, DDWRT Wiki suggests the following commands:

ip neigh change 192.168.1.254 lladdr ff:ff:ff:ff:ff:ff nud permanent dev br0
ip neigh add 192.168.1.254 lladdr ff:ff:ff:ff:ff:ff nud permanent dev br0

After that I'd create a port-forwarding rule for UDP port 9 to IP 192.168.1.254, and due to the above commands, a WOL packet would get broadcast and subsequently wake the target PC up.

Unfortunately, it seems in LEDE neither of these commands work as expected. The ARP command just displayed the current ARP tables (it doesn't seem like it takes any parameters), while ip doesn't seem to support the ip neigh change (if I'm reading it right, it only supports ip neigh show or ip neigh flush.

How could I set LEDE to allow WOL packets from the internet?

Someone else may have the solution for you (I do not). I do have a work-around:

  1. Enable ssh access to the router.
  2. Execute wol the router to wake the target machine.

If I could get that static ARP entry to work, then I can send a WOL signal with a touch of a button on my smartphone. With the solution you're suggesting I'd need to do much, much more. :disappointed_relieved:

Just install opkg update; opkg install ip-tiny; /sbin/ip n add ....
My guess you can do all you need throug luci (web) interface.... You do not need theese commands....

1 Like

Awesome! That works, thanks!

I DID try to find a place to set this up in luci, but... well, I failed. That said, I haven't yet seen a router having this type of setting "out of the box" via the web-GUI.

A post was split to a new topic: Enable WOL from LAN