Enable MT7621 ipv6 hardware offload

You could try this patch and select ipt-offload.Also enable hardware offload in firewall.
There is no cpu usage during ipv6 speed test.


Turn off the problematic hardware flow offloading on MT7621.

For solve your problems, you just discard problems?

Hi @MeIsReallyBa , which kernel version is suitable for this patch?

Hi @MeIsReallyBa! Why not issue a pull request?

I have used hardware offload for a long time,no problem here.

I have not tested ipv6 hw offload for enough time.

linux 5.4.124

1 Like

It's possible issue a pull request and request testers. "RFT" -> pull request ready for testing

There is no "hardware offload" option available applying this patch ?

There should be hardware flow offload option in firewall setting even if u didn't apply this patch.

This option depends on your actual MT7621 device ?

I do not have tried stock rc3 and re-built again

Model Ubiquiti EdgeRouter X

Hardware offload option will appear when you select software flow offload first.


ah, ok, i see...... my bad,

thank you

i want to use batman-adv over Ethernet next

1 Like

I tried to build at branch 21.02 with commit https://github.com/openwrt/openwrt/commit/b55d3d69044ae872c96b4b287b43a57c8e96e7cd , but I cannot represent a nearly 0% usage of CPU like yours. Device is MikroTik Rb750Gr3. Can we talk about this deeper?