Enable both DHCP and DHCPv6 on wireless interface

According to OpenWrt Wi-Fi guide, under the config wifi-iface there is an option named network with data type string. For some reason I am able to make it work with a list of interfaces like this:

**/etc/config/network**

config interface 'phy0_sta'
	option proto 'dhcp'

config interface 'phy0_sta_ipv6'
	option proto 'dhcpv6'


**/etc/config/wireless**

config wifi-iface 'radio0_sta'
	option device 'radio0'
	list network 'phy0_sta'
	list network 'phy0_sta_ipv6'
	option mode 'sta'
	option ssid 'OpenWrt'
	option encryption 'none'

Is it okay to configure it like that, or should I use this instead:

**/etc/config/network**

config interface 'phy1_sta'
	option proto 'dhcp'

config interface 'phy1_sta_ipv6'
	option device '@phy1_sta'
	option proto 'dhcpv6'


**/etc/config/wireless**

config wifi-iface 'radio1_sta'
	option device 'radio1'
	option network 'phy1_sta'
	option mode 'sta'
	option ssid 'OpenWrt'
	option encryption 'none'

When I use both of the samples above, it looks a little weird on LuCI, which reads no interfaces attached on phy0_sta and phy0_sta_ipv6, while phy1_sta is Wireless Network: Client and phy1_sta_ipv6 is Alias interface.

image

Both work apparently. Are there any differences between them?