Edit vi exit text mode

I want to modify a text, I can modify it, but I can't get out of text mode. I try with the ESC letter, but it doesn't work to enter the save command.
I have searched a lot but I can't find the solution.

there's no ESC letter, just the ESC key.


use winscp

Might be easier to use the "nano" editor than the old vi.
Just install it with opkg.


I tend to always install the nano editor on OpenWrt (opkg update ; opkg install nano), as it shows its own keyboard shortcuts at the bottom it is friendlier for occasional use than one of the vis...


Thank you for the answers, I solved it with winspc

1 Like

Gui solution is usually the easiest solution.

remember to mark it as solved.

1 Like


sorry to be pessimistic on this topic, but ...

we are talking about devices with very tight flash AND advanced things like uart console/ssh/config edits etc...

it is perfectly normal in this world of advanced tinkering that at least everyone know how to handle basic things, including VI editor, without fancy stuff and using win10/scp to edit linux configs :frowning: :frowning:

... only my opinion

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.