Edimax 3g-6200n - factory firmware

I see that this device is supported.

I've noted the limitations, but that won't matter for me because it will only be used occasionally at a rural location, from 12V.

Factory firmware is not listed for this device and there are no instructions for using "..intramfs-kernel.bin". Is there a way of installing LEDE over the OEM firmware that I have flashed up to release 2.21b ?

Did you find out how to flash the Edimax 6200n with LEDE? If not, I may can help you. Even if it's half a year later...

Today I run into the same problem like you. How to flash LEDE to the router without factory.bin?

Because you are mentioning the Edimax stock FW version 2.21b I assume you tried to follow the 6200n OpenWRT installation notes as well.

Based onto the OpenWRT notes there I could flash LEDE onto the 6200n. Unfortunatelly it was a little bit trickey because of the outdated Dropbox links mentioned there. First I couldn't find the old 2.21B Telnet stock FW somewhere online. But I could find it within my own backups, luckily.

Finding a source for the MTD.static command file was a little bit more trickey. But after a not so short while I found a replacement at this internet forum.

Thus I could follow the OpenWRT installation instructions for the 6200n, but used the LEDE sysupgrade.bin instead.

I would like to add a warning for other readers. Don't spend time on this device. Almost immediatly it becomes unusable if there is heavy load (speedtest) at the wifi interface running as a RELAYD client.

It is caused by the buggy rt2x00 wifi drivers, not LEDE/WRT. I hoped there might have been some driver improvement because of the Git changes concerning rt2x00 over the last months (would have been a miracel after all these years for this old hardware). Tried with LEDE 17.01.04 and relayd, Edimax 6200n, JCG JHR-N926R, both Ramips RT3052.

ieee80211 phy0: rt2x00queue_write_tx_frame: Error - Dropping frame due to full tx queue 2

I doubt that those changes have made to stable release.
Try using snapshot


I own such an ancient Edimax 3g-6200n and wondering if any of you can help me with a mtd bin that I could execute on it.
Just flashed the latest stock firmware 2.29 and learned that I can access the syscmd.asp menu and could enable telnet. It wasn't available with the original 2.12 firmware.
Unfortunately, the dropbox links mentioned here are broken:

Is there any other flash method that works? I could rename the OpenWrt image and feed it to the stock firmware upgrade procedure (GUI), but apparently there is no factory.bin available. Well, there is one for Chaos Calmer:
I could use that one to start with and then (sys)upgrade to the available 18.06.8 - 3g-6200n-squashfs-sysupgrade.bin from here:
that I'd like to test and hope that it contains all the fixes discussed in the toh page from above (they look fixed in LEDE already).

Thanks in advance!