Edgerouter-X SSH and Luci inaccesible after upgrade, port lights still work

Bought an Edgerouter-X to put OpenWRT on, and followed the procedure to upgrade to intermediate custom firmware first, then to the full firmware. On the first upgrade, I had no problem going to the Edge-OS web interface, putting the tarball in and upgrading, although I could only access the device via SSH on eth4 with static IP assignment. I then used scp to upgrade to the next version, and it seemed to work and even connect my device to the WAN...


After a few minutes, my SSH session failed and I could no longer access the device either via DHCP or static, with or without WAN on eth0. I also couldn't access LUCI at any point.

There is port activity on the lights, but I don't know exactly what's going on. I can ping the Edgerouter-X from eth4 but that's it.

Does anyone have any suggestions on how to get past this? Thanks in advance.

@owl, welcome to the community!

  • IPv4 - Try to static address your client and see if you can then reach the router
  • IPv6 - See if you can sniff the interface and identify the IPv6 neighbor packets announced from the router - then you can try connecting to the the IPv6 address instead

What's the IP?

Do you get "connection refused" when trying to SSH or does it just hang?

I think port 0 is the WAN on an OpenWrt install, ports 1-4 are LAN. Do not plug a non-PoE device into port 4 until you are sure the GPIO pin has been set to turn the PoE out off.

It's also possible there are two devices with conflicting IP on your network. Connect the router only to the PC when first setting up.

1 Like

Thanks for the warm welcome!

It turns out that the ER-X with the updated firmware assigns an address fine via DHCP ( in my case). Wireshark shows the traffic just fine.

Thing is, the web interface at 1.1 is still down and I get connection refused messages when I attempt to SSH to the ER-X.

I can't really use the box without administrator access so how do I get in and/or how do I reflash to stock f/w? I just bought this so I don't want to get too dirty with a USB-TTL converter and crack it open yet.

Are you plugging the router (port 1, 2 or 3, not 0 or 4) directly to your PC with no other network involved?

Confirming Port 3, non-PoE only to my PC. Nothing connected to any other port.

Did you flash a snapshot version (with no web GUI)?

As my original post says, I flashed an intermediate and then a final firmware, but even without the web interface I still get connection refusal on SSH attempts. I'd like to know why and/or how to recover to something I can manage my router with.

That didn't answer my question, or maybe you don't understand that I'm referencing the OpenWrt interface. I understand you never accessed LuCI; but I want to know if you ever installed it in the first place. Perhaps you can show us the link to the "next version" firmware you flashed the second time?


  • Did you ever see any IPv6 responses?

If you won't provide other information (which may not help anyways), serial may be the only answer. It can't be determined from your information if you ever flashed an OpenWrt with a web GUI; and SSH should be working.

To be clear, you have to connect on "LAN".

But it does serve you a DHCP address like it should. That means you are connected to a LAN port.

"No other network" means turn off the WiFi in the PC as well. You may still be trying to access another device at

1 Like

I disabled all other interfaces including Wi-Fi. I'm certain of that.


A few points:

  1. I followed the guide located here with the intermediate firmware build installed first: Ubiquiti EdgeRouter X, Loading OpenWrt and performance numbers

  2. I can see IPv6 of the DNS on the router (running ipconfig /all in Windows it's assigned ) but the SSH connection on IPv4 and IPv6 using Putty to the same address is refused each time. I can ping any IPv4 and IPv6 router addresses without issue; however, the IPv6 gateway address is not shown - only the IPv4 which is the usual I'm thinking this is a clue to something, but what?

  3. I am connected only on LAN. All other interfaces are disabled.

  • I guess that means you installed 18.06.1??? (No need to answer again, we've already tried 3 times).
  • Does this mean you performed any other steps on this page (e.g. moving WAN connection)???

I'm curious...as you keep mentioning this...

How did you manage disable them if you never accessed OpenWrt?

Again, since you say SSH and HTTP are not accessible, serial seems like your only choice.

Sorry for not being clear, but yes it was 18.06.1 that I installed, and when I say I disabled interfaces I did so on the PC I'm using, not the router itself.

Also, last suggestion:


If you're really running OpenWrt, it should be accepting SSH connections on the LAN. I guess you did SSH to the initial initramfs flash in order to install the final sysupgrade. This is something that usually is going to just work.

I'm so used to using serial as the first resort that its not a big deal so it is looking like that is your next step. This particular box should have serial pins already installed and it is easy to get inside without prying, but do be careful of the plastic light pipes that hang down from the top cover.

1 Like

Ok I'm in using the on-board serial port. Got tired of trying to debug this from the outside.

I'm able to download and update packages using opkg update, and I tried installing LuCI and rebooted, but neither it nor SSH will come up either using the IPv4 or IPv6 address of the router.

Any ideas on what to do now?

My only point about disabling interfaces is that people thought I was on more than one network at once to the point where it was interfering with my debugging. I ensured that the only network I was connected to was my ER-X on port 3, no other connections to/from either the ER-X or my computer.

Try a complete re-flash; sysupgrade -n to 18.06.5. Release versions have LuCI built in.

Bingo! That did it! Thank you!

As an aside, I did manage to bring up LuCI after installation after following the uhttpd guide, but everything seems to work now. I guess having a little CP2102 USB-TTL bridge kit and a screwdriver is the way to go if you're getting deep into the router.

mk24 and lleachi, thank you for your help and your patience!

1 Like