Easytether, Bridge mode, scripting

Hello everyone,
I have reached out to easytether for assistance with no response for several days. So I decided to see if anyone here could help.
I have 19.07 installed on MT300N GLiNet router.
I have easytether drivers installed to run application in openwrt.
Everything works fine when I run the command 'easytether-usb'

First, i am trying to overcome an issue I have when combo runs idle.
So when I am gone during the day or over night the interface gets dropped by easytether.
I can ping the easytether gateway, 192.168.117.1, on the android phone. but no internet and the interface is being used by another service when i run the command again.

What I would ultimately like is to bridge this interface with the lan
have the interface stop messing up but am looking to settle for a script.
I added the command to start Easytether to the startup but would prefer to have an IF script run every minute to check if the interface is connecting properly. This malfunction happens a few times a day. Im a rookie with writing my own scripts and in my research I have seen a ping test on an if statement but like i said pinging the gateway returns a reply but cant reach the internet. Also, ICMP packets are apparently blocked from easytether by carrier so pinging past phone is no option.(Visible) 25Mbps cell / 5Mbps tethered normally.

Ive been at this sh!t for days. Running boarder line exhausted with it all. Cellular is the only means of internet where I am. The corp giants dont care about the rules anymore of providing to rural areas CenturyLink and Comcast stop 1000ft from my community of homes(all privately owned). By county law they were supposed to extend their service but said screw us. anyways. Any help would be greatly appreciated.

I am running the same setup without any drops. Can you tell me what version of easytether your running on your router? Also, are you using the "Tiny" or the "OpenSSL" version?

I had dropping problems with 18.06 and had to revert to easytether-usb-openssl_0.8.9-2 to fix my issue.

Hi Scott,
I had 18 and 19 firmware versions on my router and kept getting the problem.
I always use the openssl version for easytether driver.
I am running version 1.15 easytether.

With that said, I reverted firmware to LEDE 17.01, which i believe was the lede clean version from Glinet website.
After I used this firmware the issue stopped.... Well until today when it completely took a dive and I could not get it to start working again. Pinging the gateway would sometimes reply on the first ping but dead for all others. tried restarting phone, router, clearing cache and data. revoked debug auth. Ended up having to reset router and run install and config again.
Wish there was a way to back up the whole thing so i could just do a flash and all the packages would be there with the config.

my current setup:(reinstalled 2 hours ago)
IPK is : easytether-usb-openssl_0.8.9-4_mipsel_24kc
openwrt : LEDE Reboot 17.01-SNAPSHOT r3657-45566fb / LuCI lede-17.01 branch
easytether: 1.15

Your software versions are correct. I am not sure what could possibly cause your install to fail so. I hope its not a flash memory problem.

I use this command before upgrade, then copy and paste the output to reinstall any user installed packages after:

echo -n "opkg update;opkg install ";install_time=$(opkg status kernel|awk '$1=="Installed-Time:" {print $2}');opkg status|awk '$1=="Package:" {package=$2} $1=="Status:" {
user_inst=/ user/ && / installed/} $1=="Installed-Time:" && $2!='$install_time' && user_inst {print package}'|sort|sed ':a;N;$!ba;s/\n/ /g'

Or alternately you could just list the user installed packages with this command:

install_time=$(opkg status kernel|awk '$1=="Installed-Time:" {print $2}');opkg status|awk '$1=="Package:" {package=$2} $1=="Status:" {user_inst=/ user/ && / installed/} $
1=="Installed-Time:" && $2!='$install_time' && user_inst {print package}'|sort

Hopefully you will not need them... :wink:

Thanks,
do you know if I can convert the USB 2.0 port on a router to a tether port?
I have a tp-link archer c1200 i wanted to try and convert to openwrt, there are other archer versions, like c5 ac1200 but this particular one is not listed. but im sure it will be fine.
Maybe I could us it to load balance my 2 connections and omit the mt300N and go direct to the TPlink with easytether.
what you think?

Not sure what you mean. I tether exclusively via a USB 2.0 port. I thought you did as well using EasyTether.

I use a router that is setup to tether. The tp-link isnt originally setup to tether. I guess if i change the firmware to openwrt, ill answer my question and setup wan0.1 to Easytether.

Looks like if you have an Archer C5 AC1200 V1 you are good. If V2 your out of luck for OpenWrt right now.

My phone is tethered via usb 2.0 cable to my router which is running OpenWRT. Just add this to "/etc/config/network"

config interface 'wan' 
  option ifname 'tap-easytether' 
  option proto 'dhcp'

Install your easytether router package, and that should do it.

what about having 2 WAN connections? also, would it be possible with 2 tether connections to use easytether?

Don't quote me but I thought the dev of easytether told me 2 WAN connections are ok but not 2 easytether usb connections. I was considering using two separate routers to allow 2 easytether connections. You may be able to add a second usb tethering device without using easytether. You may contact them and ask them to alter their code to allow for 2 working easytether connections on the same router/host.

Well you are a lucky man! I have emailed them 3 times trying to get some answers on things. No luck for me.
Well if 2 easytethered connections is a no, then oh well.