EAP225 US v1 back to US firmware

I'm completely new. Maybe yo can help me.
I have an EAP225USv1 outdoor. I flashed by mistake with an CA firmware and now I can't move to an US firmware, is there a way to put original US firmware again? tried with "factory" bin in this thread without success.


Nobody can help???

Your issue seems to be related to TP-Link's firmware, unless I'm missing where OpenWrt comes in here.

You could flash OpenWrt, and then use that to flash a modified version of the stock US firmware. But I can't guarantee that would solve your issue on future upgrades...

Thanks for the reply.
I couldn't flash with the openwrt pre-release... "file invalid" openwrt-ath79-generic-tplink_eap225-outdoor-v1-squashfs-factory.bin

Did your run cliclient stopcs on the device before you attempted to upgrade?

1 Like

No, Like I said, I'm new, How can I do that? didn't find on google.


Let's just try something else then. What CA version did you upgrade to? 1.20.0? From my experience, you can't upgrade this kind of device to the same version, so that probably also counts for different regions.

Try if the following works:

  1. From your CA firmware, flash a different version of the US firmware. E.g. if you currently have CA-1.20.0, downgrade to US-1.7.0.
  2. If that works, upgrade from US-1.7.0 to US-1.20.0

Thanks svanhuele.

I have EAP225-Outdoor(CA)_V1_V1.20.0 Build 20200604 installed, tried all firmwares and nothing, even EU versions "failed".

I really don't understand why I could made the mistake and cant't roll back.

With the help of another user, I managed to figure out what makes the CA firmware different. If you still have your device, you could build an image from my test branch:

After flashing OpenWrt, you would then need to modify the product-info partition manually, by removing the "region=CA" bit (e.g. by replacing it with space characters), and write it back using the mtd tool. Note that the product-info bit is part of /dev/mtd2 or "info" in /proc/mtd. This mtd partition also contains the device's mac address, so you want to make sure that you do everything right.

  1. Read /dev/mtd2 to /tmp/mtd2.bin (or other)
  2. Modify the data at starting offset 0x100 in mtd2.bin
  3. Unlock and erase /dev/mtd2
  4. Write back modified mtd2.bin to /dev/mtd2
1 Like