EA8300 mesh/roaming

Hi guys, does anyone know if EA8300 supports 802.11s with r/k/v roaming?

I currently have an EA8500 and I tried to use roaming + mesh with unifi ac lite but (I think) due to the broken driver on Wave1 chipsets it wouldn't work(roaming and mesh together). Any advice?

My understanding is mesh 11s a web of radio back haul links between WiFi routers supplying primary WiFi access to devices and back hauling wireless via a dedicated radio band to other mesh (via radio) routers making its way to a final access to a router with its WAN port connected to Internet. A tri-band router like the EA8300 would dedicate two bands for front end WiFi access to devices and dedicate its third band to back haul this data to other mesh (via radio) routers to gain access to Internet.

The Unifi AC Lite is a wired Access Point to your router and does not use radio to access its router as it is wired to access the switch/router connected to the WAN port to access Internet, where does mesh come into the equation here ?

Use those two devices for a mesh network even though the second is only dual band?

On EA8500 you will have to select which band will be access and which will be back haul, if 5Ghz is access the 2.4Ghz is back haul or vice versa if you want. However actual speed is 2.4 Ghz regardless as it is either the access bottleneck or back haul bottleneck depending on the role you give it.

Working exclusively with tri-band routers, you can use 2.4 and 5Ghz as WiFi access and a 5Ghz back haul, no bottleneck here.

Dual band routers are severely handicapped as mesh devices because of the choice you have to make regarding which band is access and which band is back haul.

I think QCA's own firmware should support meshing on wave1 chipsets, so i'd first try to replace ath10k-ct and its firmware with the non-ct variants for testing.

You can't mesh with a wired AP, of course it won't work, am I mistaken ?

Both EA8500 and Unifi Lite AP are dual band, Unifi is necessarily wired to EA8500, so mesh cannot work in this case. It has nothing to do with drivers, it's about network topology being wired interconnect between router and AP.

What I'm saying is that I use the third radio (5 Ghz) on the first router for return and the second radio on the second router (also 5Ghz, although you should create an access network on this radio to have 5Ghz available).

I am confused, the title of post says EA8300 and your actual post says EA8500, the first is tri-band, the second is dual-band...What are we really talking about here, 83 or 85, not same device.

Okay, but what I mean is that you don't always have to have a dedicated radio on any of the nodes.

Ubi Lite AP is not a mesh device, as it relies on a wired Ethernet connection to the Linksys router to fulfill its AP function. Mesh is irrelevant in this topology and will never work as mesh regardless.

Irrespective of bands, a dedicated AP like Ubi Lite will never work as mesh as it is a wired AP period.

So what is the real issue here ?

How can it not be part of a mesh? This device has Qualcomm hardware and has that capability. Besides, this forum is not just for troubleshooting.

Please read your original post, are we talking EA8300 or EA8500.

You also say you use with Ubi Lite, which is a WIRED Access Point.

I have difficulty understanding mesh usage (Wireless) with a WIRED AP.

Maybe you should rephrase your original issue or what you want to accomplish ?

It seems to me that you have little understanding or imagination. Also, just because it has a wired network port, it doesn't mean it's the only way to connect. I understood perfectly with the information that the OP gave, and he wants to know how to connect these two devices through the mesh and have it roaming.

Correct. I did mesh EA8500 and unifi lite, but i couldnt get roaming to work correctly. It would jump to the unifi but never back to the linksys. I would like to think its driver issues. I did use non-ct firmwares (on unifi) in order to get 802.11s working.

1 Like

I have a EA8500 and ubi lite which is connected via mesh by splitting both 5ghz. (Works perfecly without roaming) My question is if anyone has tested EA8300 on a roaming + mesh setup before. It should theoretically work.

I have just installed factory 19.07.4 on two (2) EA8300 for the purpose of testing your inquiry and for my own knowledge, as I am new to OpenWrt.

They have been updated and are ready for testing, however you will have to instruct me as to how you want these setup to test your issue, as there are so may paths to mesh my head spins.

Please let me know if you want me to move forward with this or if I mesh myself to death on my own :

  • Associativity-Based Routing (ABR)[1]
  • AODV (Ad hoc On-Demand Distance Vector)
  • B.A.T.M.A.N. (Better Approach To Mobile Adhoc Networking)
  • Babel (protocol) (a distance-vector routing protocol for IPv6 and IPv4 with fast convergence properties)
  • Dynamic NIx-Vector Routing|DNVR[13]
  • DSDV (Destination-Sequenced Distance-Vector Routing)
  • DSR (Dynamic Source Routing)
  • HSLS (Hazy-Sighted Link State)
  • HWMP (Hybrid Wireless Mesh Protocol, the default mandatory routing protocol of IEEE 802.11s)
  • Infrastructure Wireless Mesh Protocol (IWMP) for Infrastructure Mesh Networks by GRECO UFPB-Brazil[14]
  • OLSR (Optimized Link State Routing protocol)
  • OORP (OrderOne Routing Protocol) (OrderOne Networks Routing Protocol)
  • OSPF (Open Shortest Path First Routing)
  • Routing Protocol for Low-Power and Lossy Networks (IETF ROLL RPL protocol, RFC 6550)
  • PWRP (Predictive Wireless Routing Protocol)[15]
  • TORA (Temporally-Ordered Routing Algorithm)
  • ZRP (Zone Routing Protocol)

I understand not all are implemented in OpenWrt, but several are.

I don't mind testing your setup with my 2 EA8300 I am putting aside for my mesh knowledge.

Hmm, I tried to use batman, but didn't have any storage left on Unifi :rofl: tried to compile openwrt and everything but it didn't work. You should try to make a basic 802.11s mesh with wpad-mesh-openssl and luci, maybe challenge yourself with BATMAN afterwards.

Ok, but what is the actual setup you have that generates your question in the first place ?

I would like to reproduce in order to see if the issue persists...

Exactly what ive described above, but with 802.11r enabled. If that works then my theory is correct. Note you might need to use ct or ct-htt firmware.