E8350 why not supported by OpenWrt

Hi @tcolov,

Thank you for putting together and sharing the images!

A quick question about usage: I flashed the E8350 with the factory.bin, configured the network, then reboot -- all the settings were gone.
I then sysupgrade it with the ubi, then further configs can survive the reboots.

Is this behavior normal?

Thanks!

Nand driver is buggy. (Sync command and reboot can cause the error). You can see the error on dmesg.
As workaround, you can use rootfs on external USB flash drive.

Is this driver already included in openwrt or just on Google drive snapshot? Is any ETA for full support in main trunk for netgear r7500 v1. Will I loose 5Ghz if upgrade to newest openwrt via sysupgrade

The issues with the nand flash memory are Linksys E8350 specific and are already part of the openwrt kernel.

I've already submitted patches to include Linksys E8350 into the openwrt.

Wifi 5G driver is another driver, which I intend to submit after E8350 inclusion as part of the openwrt packages.

1 Like

Hi @tcolov,

Do you know where to get offical Quantenna FW? I see linux kernel driver shows the FW name is "qtn/fmac_qsr1000.img". But I did not find the FW from https://git.kernel.org/pub/scm/linux/kernel/git/firmware/linux-firmware.git/tree/

tony@tony-desktop /project/kernel/git/torvalds/linux/drivers/net/wireless/quantenna/qtnfmac
 % grep FW_NAME . -r        
./qtn_hw_ids.h:#define QTN_PCI_PEARL_FW_NAME            "qtn/fmac_qsr10g.img"
./qtn_hw_ids.h:#define QTN_PCI_TOPAZ_FW_NAME            "qtn/fmac_qsr1000.img"
./pcie/topaz_pcie.c:            ret = qtnf_topaz_fw_upload(ts, QTN_PCI_TOPAZ_FW_NAME);
./pcie/pearl_pcie.c:    const char *fwname = QTN_PCI_PEARL_FW_NAME;

The firmware is not published yet. There are two different drivers: the one you mentioned is included into the main kernel but without firmware. The other, which is 'with' firmware is from the Netgear GPL code of R7500. The firmware is not compatible between the two drivers.

First off thank you so much for your work!

I have an E8350 and the 5ghz is working, but the 2.4ghz does not. It stays stuck on obtaining ip address for about 1 minute, then if it does connect there is no internet. Did anyone else have to configure 2.4ghz in any special way?

Thanks for your help.

Update 1: 2.4ghz works on the older image but manages around 0.10 mbps. As someone else mentioned earlier, the settings do not stick on the older version.

Update 2: on the newest version the 5ghz works great out of the box thanks to the rc.local script. Now I did get the 2.4ghz to work by not using luci and just enabling it in /etc/config/wireless, but the speeds are really bad still. I'm getting around 2 mbps down and 5 up. Any ideas here? What else everyone else getting? Let me know if you need me to post anything.

Update 3: On 2.4ghz, I tweaked the settings by disabling legacy rates and dissoc_low_ack to 0. If I'm right next to the router the speeds are great, but if I get about 10 feet away, the speed goes back down to 2mbps or less. Which is strange to me because the dbm is still around -25dbm.

#Current wireliess config (using rc.local to set 5ghz):
config wifi-device 'radio0'
        option type 'mac80211'
        option hwmode '11g'
        option path 'soc/1b700000.pci/pci0001:00/0001:00:00.0/0001:01:00.0'
        option disabled '0'
        option legacy_rates '0'
        option country 'US'
        option txpower '20'
        option noscan '1'
        option bursting '1'
        option ff '1'
        option compression '1'
        option xr '1'
        option ar '1'
        option channel '8'
        option htmode 'HT40-'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ssid 'OpenWrt2'
        option encryption 'psk2'
        option key ''
        option disassoc_low_ack '0'

config wifi-device 'radio1'
        option type 'quantenna'
        option channel '36'
        option hwmode '11ac'
        option phy 'host0'
        option disabled '0'

config wifi-iface 'default_radio1'
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option ssid 'OpenWrt'
        option encryption 'none'

Update 4: Replaced the driver ath10k-firmware-qca988x-ct with ath10k-firmware-qca988x and it looks like I got wifi speeds up to where they should be.

Update 5: Settings no longer stick :frowning: Not sure what happened but I can't get anything to stay on the nand.

On 5ghz I'm also having dropped packets and disconnects while utilizing ssh forwarding. I tunnel through termux to my home debian machine and it cannot maintain a connection. Not sure if there is a fix for this, but thought I'd mention it. Again, thank you so much @tcolov for working on this!

Hi tcolov,

just to let you know that your image for R7500 from here


works fine on my device. I did not yet do any further testing, but 5GHz WLAN came up directly.

Let me know if I can contribute in any further testing/troubleshooting!

alex

Hi,

I have the official openwrt image. Can i use the web update to flash this one? What file from that google drive do I need?

EDIT: i have the R7500 v1

EDIT2: can i simply upload openwrt-ipq806x-generic-netgear_r7500-squashfs-sysupgrade.bin through the webinterface and upgrade?

@tcolov @Ansuel

I have an extra E8350. Would donating one help further development on this?

From what I can see this is already well supported. Am I wrong?

Hey @Ansuel,

It does work and I'm very appreciative. I was having issues when using nomachine through ssh on my phone. Basically the router would buffer and drop the connection on 5ghz. Since I'm of little use as a dev, just trying to see if donating a device was helpful. Thank you for the response. I'll keep an eye out for any updates.

Hi, I will be grateful for your work. I have flashed my E8350 with your build for the first time and it works except 5g wifi.
I don't understand how, where and in what to edit the file to make 5g work ... If it's not difficult for you, explain to the "teapot" ...
Hopefully your patch gets into the official build soon.
Thank you very much!

Hi, would be there any new releases I know they patched lot of things and also I have strange issue then I unplug power my router resets but when I do soft reboot all the settings remains.

hi tcolov,
I want to ask, if I use systemupgrade -F (force) to flash the ROM that you made. what might happen if the flash fails.
why do I force to use F because my e8350 can only be flashed by the Pandorabox version. every time I flash to the openwrt or original version of Linksys nothing ever works.
before that I used the openwrt rom and updated the software from the system -> software, after that it couldn't be accessed anymore, even though I tried resetting it for 10 seconds. and I flashed the new Pandorabox version, it can be accessed again.
I have tried to flash various ROMs all failing which can only be Pandorabox ROM, the error is image verivication failed
thanks beforehand

I assume this has not made it into official builds yet?

hm, tried to build new version for the r7500 v1 but it doesn't seem to package the qnt firmware files.

Hello,

Anyone familiar with Lean's lede repo?

There E8350 seems to have been supported since as early as July this year.

Thanks.
AG

Managed to apply the patches from E8350 why not supported by OpenWrt - #91 by tcolov to 21.02.0 and compile it properly for Netgear r7500, it's running on mine.
My image is rather bloated since I compiled basically every package i need into the image.

But if you are interested you can find it here https://mega.nz/folder/JUo3TSzT#x6fttpcjfv7SR5kSQUxwXg for download.

To get my 5G wifi to work properly I set it up in /etc/rc.local and /etc/config/wireless
wireless because when I didn't set it up in /etc/config/wireless I had an OpenWrt 5g wlan with no encryption and when I only had it in /etc/rc,local I had a wlan that was not in the proper network (and could not communicate with the internet)

config wifi-device 'radio1'
	option type 'quantenna'
	option phy 'host0'
	option hwmode '11a'
	option disabled '0'

config wifi-iface 'wifinet2'
	option device 'radio1'
	option mode 'ap'
	option ssid 'ssid'
	option network 'lan'
	option key 'password'
	option wpa_disable_eapol_key_retries '1'
	option disassoc_low_ack '0'
	option wmm '0'
	option short_preamble '0'
	option encryption 'sae-mixed'
1 Like

can you compile it properly for e8350 with update to 21.02.0? thank u