E8350 why not supported by OpenWrt

The WiFi speed is great. And it looks stable. I haven't tested it extensively, but at the moment it's stable. I will test the WiFi more intensively during the week.
I can confirm the duplicate menus under DHCP and DNS.

dupplicate menus can be fixed by manually removing the last entries for "qtn" section in file:
/etc/config/dhcp

  • they are for RGMII variant of Quantenna device and are not needed for R7500v1 and E8350 devices.
3 Likes

I've re-uploaded the updated test firmware with improvement tunnings on the wifi settings.

1 Like

I tested the firmware on Netgear R7500v1 for 4 days and the 5GHz WiFi is stable.

After a reboot my 5Ghz on the R7500v1 is working aswell and is stable so far! Thanks for your work!

Package folder is also in the link. As it is a custom build, you have to use the packages from this build. There is also openwrt-imagebuilder to create your own images with pre-installed packages there.
If you want to install a single package, you can do it via the putty/winscp:
opkg install /tmp/pkgname.opkg

How to modify opkg package download(wget) configuration.

from
wget -q --no-check-certificate -O xx.ipk
to
wget -q -6 --no-check-certificate -O xx.ipk

I've been using the latest version with the correct model name in the past few days. It's 5G signal has been stable and I haven't had any issue so far.

I've installed the image on my R7500 v1 right now and I'm very impressed so far. The 5GHz wi-fi is working perfectly and stable.
When will the driver be added to the master branch? (I'm missing wireguard in packages :wink: )

i got a problem with 5ghz wifi.
it must be power off completely to make it works again after reboot or make changes that need to reboot.
im on e8350 squashfs-factory last build date 2sep2020
before im using pandorabox version and cannot use 5ghz wifi
on linksys original firmware (every version have spesific bug) and the 5ghz wifi got random disconnect and off some times

kmod-ata-marvell-sata_5.4.52-1_arm_cortex-a15_neon-vfpv4.ipk is not match the version of this firmware cause i can not use the esata port ,will you guys give me the right driver for esata?

Is there any way to make 5G led flash on connection or not supported in driver

Also tried to install manually via ssh dependency from google drive/packages for qos but they are not compatible
root@OpenWrt:~# opkg install /tmp/kmod-sched-connmark_5.4.66-1_arm_cortex-a15_ne
on-vfpv4.ipk
Installing kmod-sched-connmark (5.4.66-1) to root...
Collected errors:

  • satisfy_dependencies_for: Cannot satisfy the following dependencies for kmod-sched-connmark:
  •  kernel (= 5.4.66-1-b6ce88a6e4cc7e9e71eb457e1eb001f2)
    
  • opkg_install_cmd: Cannot install package kmod-sched-connmark.
    What am I doing wrong?

2 posts were merged into an existing topic: Is it possible to use LEDE on Zyxel NBG6816?

I'm currently running your R7500v1 image for a couple of days and 5GHz WiFi is working like a charm! After I bought this router (and found out it was a v1 instead of a v2) I tried to integrate the driver and firmware myself but I couldn't get it to work. So thank you so much for your work on this router, and I sincerely hope that this is getting merged.

1 Like

Hi,

Is there any easy way just to install the driver for Quantenna QT3840BC + QT2518B on R7500v1?
or install OPKG

or any way to install the driver? I tried the image but I couldn't set a password...

  • At the moment e8350 patches are submitted for official inclusion into openwrt.
  • Quantenna wifi driver will be the next as part of the package section. Some work on the LUCI web UI has to be done so that can be configured natively for openwrt.
    ( and yes quantenna driver is the same for R7500v1 and E8350)
2 Likes

@tcolov
Thx for info, will You also maintain support for netgear r7500v1 or only asus?

Quantenna wifi driver is the same for both Netgear R7500v1 and Linksys E8350. It will be part of the package section.

1 Like