Dynalink DL-WRX36 Askey RT5010W IPQ8072A technical discussion

rc3 had WLAN.HK. drivers when I installed 12 days ago.

There's some talk about merges here:

I'm not sure what snapshots are on now?

I'm on Thursday's snapshot and that's at


1 Like

You can try other firmwares if you like I have collected the ones from firmware 2.9.0 in my github repo with instruction how to change the firmware.
It contains 1835, 1837, 1862 and 1890


The official Qualcomm firmware repo is here https://github.com/quic/upstream-wifi-fw


How does 1835 perform?

Just for the record, I been running DL-WRX36 with 802.11r on 5 GHz with WPA3 since Jan-Feb, and it's been rock solid so far with both of snapshot and rc images. However, in my case it's 802.11r between DL-WRX36, Netgear EX7300 v2 and ClearFog SolidRun Pro with Compex WLE900VX (QCA9880). In you case you have three DL-WRX36, is that right? So it's seems like there is possibility that DL-WRX36 knock out each other somehow?

As for 2.4 GHz on DL-WRX36 - in my case it's regular WPA2 AP that serve more than 30 devices - no issues, at all.

1 Like

What are your wan and wifi specs? ath11k fw version? multicast-to-unicast enabled?

Mine: 300/10 cable with sqm, 2.4n 20mhz / 5ax 80mhz WPA2-AES, 1890, m-t-u yes.

So strange I'm having issues than. Are you running a current fw? Or from Jan/Feb?

Okay, merged WLAN.HK. with build, testing now, fingers crossed!!

1 Like

Yes correct, 3 of the same. Yes, 802.11r likely is the common denominator as they all go down at the same time but pairing of a nearby smart device seem to knock it down.

DL-WRX36 serve as just an access point in my case, so WAN is unused. WiFi channel is 116, NL reg, width is 80 MHz.


It's in default state, so it's enabled on wireless interfaces.

rc2 (didn't had chance to install rc3 yet)

1 Like

Okay, so, rc3, newest firmware, wifi radios dropped again.

To clarify, I'm only using 802.11r on 5Ghz radios, 2.4Ghz is reserved for IoT smart switches and plugs, so, I don't use 802.11r as there is no need to.

My 2.4Ghz is running 2 ssids so I've removed one now to see if that improves things

Update: Utilizing only one ssid on the 2.4Ghz radio seems to have fixed the issue. I can pair now with smart switches / smart power points and not bring down the radios!!

Thanks for helping guys!

Currently running with 4 5Ghz ssids w 802.11r on 3 of these routers and One independent 2.4Ghz IoT ssid on each router!

Perhaps 6 ssids was a bit much!


You're the power user this router needs, it should be able to handle that though. Hope it holds up for you

1 Like

Also check your scaling_governor if you're on 'performance' and not 'ondemand'.

Thx mate, will do!

I fixed the devices dropping out of 5ghz by turning off Disassociate On Low Acknowledgement and increasing Time interval for rekeying GTK to 3600


Right, so, I'm sorted! WiFi has been stable for me, no drop outs 24hrs+, recommend for VLAN & 802.11r

The fix was merged yesterday to both main/master and 23.05, so the sysupgrade should be more reliable than earlier.


I just wanted to say thanks to everyone who has been helping to get OpenWRT working on the WRX36. Installation went well, I initially installed 23.05-rc3 and while it worked I noticed that range was a little lower than my trusty Netgear R7800, as on the 5 GHz band it was limiting to 23 dBm power. Upgrading to a recent snapshot release (SNAPSHOT r23900-7f54d9ba1a) I noticed that the range had significantly improved and was better than my R7800, as it was now using 29 dBm. Based on recommendations I have the the "Multi to Unicast" option enabled on the 5 GHz band and everything has been very stable for >4.5 days. So far I only have a few clients on the WRX36 but will slowly migrate my old networks over.


So how does it work correctly with the same BDF on the manufacturer's software?