Dynalink DL-WRX36 5Ghz Band not visible to devices

Hello all! I recently purchased this router to use with OpenWrt: https://openwrt.org/toh/dynalink/dl-wrx36

I followed the linked guide and successfully installed OpenWrt on my device: Dynalink DL-WRX36 Install - #68 by S7venLights

I used the snapshot build from this URL (looks like it was dated 2023-06-15, which is a little confusing): https://firmware-selector.openwrt.org/?version=SNAPSHOT&target=ipq807x%2Fgeneric&id=dynalink_dl-wrx36

While my 2.4Ghz Band is working fine, my 5Ghz band is not detected by my devices at all. Has anyone run into this with this router? Posting images of my config. I have already set both Country Codes to "US"

5Ghz

Start with non-DFS channels (e.g. ch36) - and be sure to wait a tad over 10 minutes before declaring failure (DFS will have to listen at least 1 minute before enabling the 5 GHz channel, 10 minutes under some circumstances).

Hey! Thanks for the quick reply.

Looking at the setup for the 5ghz band, I don't see somewhere to configure the channel. I only see Mode and Width. I coulda sworn it used to be here on my old router. Has it moved somewhere else?

Also side-question hoping someone can answer, I noticed the stable firmware is dated for 2024-03-23 compared to the 2023-06-15 snapshot. Does that mean the stable release is more up to date than the latest snapshot for this device? https://firmware-selector.openwrt.org/?version=23.05.3&target=ipq807x%2Fgeneric&id=dynalink_dl-wrx36

EDIT: interesting -- about the snapshot image, it looks like I had clicked the URL from the setup guide, which linked to the latest snapshot at the time; I had assumed that was a live URL :man_facepalming:

No, that just means you picked the wrong -stale- image, https://downloads.openwrt.org/snapshots/targets/qualcommax/ipq807x/openwrt-qualcommax-ipq807x-dynalink_dl-wrx36-squashfs-sysupgrade.bin would be the correct one for snapshots.

Thanks, I realized that a little late. Now I'm having a new problem :sweat: I uploaded this one to my device using a wired connection, let it do it's flash for 10 minutes, and watched as the router came back on with a blue solid light. But now I cannot access Luci or ssh into the device (getting "connect to host 192.168.1.1 port 22: Network is unreachable")

I'd start with
https://openwrt.org/docs/guide-user/troubleshooting/failsafe_and_factory_reset
if that doesn't help, the dl-wrx36 can be recovered via USB (if you set that up).

1 Like

I wasn't able to get in using the failsafe mode, but I was able to get in using the recovery USB i made as part of the installation process.

Running firstboot && reboot gave me "MTD partition 'rootfs_data' not found".

Trying umount /overlay && jffs2reset && reboot gave umount: can't unmount /overlay: Invalid argument

Now I'm attempting to put the sysupgrade.bin file on my USB, and mount my USB to see if I can do a sysupgrade from the terminal after booting from the USB.

OK I wasn't able to mount my USB drive, so I just used wget to download the latest snapshot sysupgrade.bin file once I ssh'd in. However, that didn't fix anything and I was still busted.

So I tried again, but this time with the stable 23.05.3 sysupgrade.bin file, and voila! It worked. AND my 5ghz band is being picked up by my devices now.

Thanks for all your help.

snapshots should be fine for that hardware (but I don't have the dl-wrx36 myself, only the roughly related ax3600 - and I didn't try today's build). qualcommax/ipq807x in general is quite well behaved.

1 Like

Yeah I figured something is just off in my setup. I'm afraid to touch it again now that it's working as intended (and also my wife has been annoyed at me since she hasn't been able to watch Netflix :joy: ).

Glad you got use out of my guide, the 5Ghz issue is happening with people, myself included, the solution for me was here
I'll add that to my guide