Dumb AP with VLANs

Hello everyone,

I'm looking for some help with setting up a dumb AP with multiple VLANs that are administered by my router. I've tried various configurations but haven't had any success.

The VLANs I have set up on the router are VLAN 10 with an IP address in the 192.168.10.x range, and VLAN 20 with an IP address in the 192.168.20.x range.

I was able to verify that the router configuration works as expected by connecting my MacBook to the port on the router where the AP is supposed to be connected with the different VLANs. My MacBook gets the expected IP addresses and has access to the internet.

I have tried setting it up in OpenWRT using "bridge VLAN filtering," but I can't get it to work and lose access to LuCI every time I configure it. Am i on the right track or should this be setup in some other way?

Thanks in advance, David

Here's the content of my etc/config/network:

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix [ula_prefix]
        option packet_steering '1'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'lan'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.10.2'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option gateway '192.168.1.1'
        list dns '192.168.1.1'

The gateway and DNS are wrong in the section below, but it may be mostly insignificant. I'm guessing they should be 192.168.10.1.

Anyway, I'm assuming VLAN 10 is untagged on the uplink, and VLAN 20 is tagged. So, we'll add bridge VLANs as follows:

config bridge-vlan
        option device 'br-lan'
        option vlan '10'
        list ports 'lan:u*'

config bridge-vlan
        option device 'br-lan'
        option vlan '20'
        list ports 'lan:t'

Then we'll edit the lan interface to use br-lan.10 and we'll fix the other issues:

config interface 'lan'
        option device 'br-lan.10'
        option proto 'static'
        option ipaddr '192.168.10.2'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option gateway '192.168.10.1'
        list dns '192.168.10.1'

Finally, we'll add an unmanaged interface for VLAN 20.

config interface 'vlan20'
        option device 'br-lan.20'
        option proto 'none'

Now you can create an SSID and connect it with network vlan20 and it should work (assuming the upstream is configured properly).

1 Like

Brilliant, that worked! Thank you so much

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.