Dumb ap setup help

Okay so my power flickered and it messed up my router config for some reason. So I'm having to set it up again, I put it in recovery mode or w/e and then went to set it up.

My goal is for it to be a dumb ap as I have a main router I want to do the actual routing work, I'm trying to follow this guide: https://openwrt.org/docs/guide-user/network/wifi/dumbap

However I'm having problems, once I finish setting it up, the internet doesn't work, it says it takes too long to connect/the site can't be reached after trying for a while. I've tried resetting both routers and the PC (the PC is only directly connected to the second router that I'm setting up as a dumb ap btw)

I think it might be related to the IP addresses I'm using?

My main router is using 192.168.0.3-192.168.0.253 as it's ip range by default for dhcp. It's default gateway is 192.168.0.1

With that in mind I'm setting my static IP on my dumbap router as 192.168.0.2, is this fine?

Also the guide says to set the dns and gateway on my dumb router to my main routers ip, would those be 192.168.0.1 in my case?

Also the guide doesn't mention it anywhere, but I'm supposed to set my ipv4 settings on my computer back from the required to access after reboot 192.168.1.1 to automatic when after I set the static IP address right? Because I noticed otherwise my pc won't connect to the router login page when I change the static address.

Any other ideas why it might not be connecting to the internet? The internet is working fine on the main router. The Ethernet also works fine connected directly to the main router Could it be something like the main router is holding the old IP custody? I think it's set to hold/lease addresses for 12 hours by default or something.

The IP you've chosen is fine, provided that nothing else on the network is using that address.

We'd need to see your config to know what is going on:

Please copy the output of the following commands and post it here using the "Preformatted text </> " button:
grafik
Remember to redact passwords, MAC addresses and any public IP addresses you may have:

cat /etc/config/network
cat /etc/config/wireless
cat /etc/config/dhcp
cat /etc/config/firewall

Yes.

Yes for the gateway, unknown for DNS. Is your main router also the primary DNS server for your network? If so, then yes.

Automatic means DHCP. Assuming all the IP addressing is consistent, then you could just as easily give your computer a fixed address in the 192.168.0.0/24 subnet.

A few:

  • Have you disabled the DHCP server on the AP? OpenWRT ships with a DHCP server active on the LAN interface and issuing addresses in the 192.168.1.100-.249 range.
  • Have you run the Ethernet cable into the LAN socket of the OpenWRT device, not the WAN socket?
  • Is the Wireless interface on the AP enabled? OpenWRT ships with the Wireless interface disabled by default.

Just to check, are these commands I do through SSH?

Yes... ssh into your router and then issue the commands. Copy and paste the output so we get the full text.

(c) Microsoft Corporation. All rights reserved.

C:\Users\Firion>ssh root@192.168.0.2


BusyBox v1.35.0 (2023-04-27 20:28:15 UTC) built-in shell (ash)

  _______                     ________        __
 |       |.-----.-----.-----.|  |  |  |.----.|  |_
 |   -   ||  _  |  -__|     ||  |  |  ||   _||   _|
 |_______||   __|_____|__|__||________||__|  |____|
          |__| W I R E L E S S   F R E E D O M
 -----------------------------------------------------
 OpenWrt 22.03.5, r20134-5f15225c1e
 -----------------------------------------------------
=== WARNING! =====================================
There is no root password defined on this device!
Use the "passwd" command to set up a new password
in order to prevent unauthorized SSH logins.
--------------------------------------------------
root@OpenWrt:~# cat /etc/config/network

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd86:b913:5d07::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth0.1'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option ipaddr '192.168.0.2'
        option gateway '192.168.0.1'
        list dns '192.168.0.2'

config device
        option name 'eth0.2'
        option macaddr

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '2 3 4 5 0t'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '1 0t'

root@OpenWrt:~# cat /etc/config/wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option path 'pci0000:00/0000:00:00.0'
        option band '5g'
        option htmode 'VHT80'
        option channel 'auto'
        option country 'US'
        option cell_density '0'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ssid 
        option encryption 'psk2'
        option key 

config wifi-device 'radio1'
        option type 'mac80211'
        option path 'platform/ahb/18100000.wmac'
        option channel '1'
        option band '2g'
        option htmode 'HT20'
        option disabled '1'

config wifi-iface 'default_radio1'
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option ssid 'OpenWrt'
        option encryption 'none'

root@OpenWrt:~# cat /etc/config/dhcp

config dnsmasq
        option domainneeded '1'
        option boguspriv '1'
        option filterwin2k '0'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option nonegcache '0'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
        option nonwildcard '1'
        option localservice '1'
        option ednspacket_max '1232'

config dhcp 'lan'
        option interface 'lan'
        option start '100'
        option limit '150'
        option leasetime '12h'
        option dhcpv4 'server'
        option ignore '1'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'
        option loglevel '4'

root@OpenWrt:~# cat /etc/config/firewall

config defaults
        option syn_flood '1'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'REJECT'

config zone
        option name 'lan'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'ACCEPT'
        list network 'lan'

config zone
        option name 'wan'
        option input 'REJECT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option masq '1'
        option mtu_fix '1'

config forwarding
        option src 'lan'
        option dest 'wan'

config rule
        option name 'Allow-DHCP-Renew'
        option src 'wan'
        option proto 'udp'
        option dest_port '68'
        option target 'ACCEPT'
        option family 'ipv4'

config rule
        option name 'Allow-Ping'
        option src 'wan'
        option proto 'icmp'
        option icmp_type 'echo-request'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-IGMP'
        option src 'wan'
        option proto 'igmp'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-DHCPv6'
        option src 'wan'
        option proto 'udp'
        option dest_port '546'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-MLD'
        option src 'wan'
        option proto 'icmp'
        option src_ip 'fe80::/10'
        list icmp_type '130/0'
        list icmp_type '131/0'
        list icmp_type '132/0'
        list icmp_type '143/0'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Input'
        option src 'wan'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        list icmp_type 'router-solicitation'
        list icmp_type 'neighbour-solicitation'
        list icmp_type 'router-advertisement'
        list icmp_type 'neighbour-advertisement'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Forward'
        option src 'wan'
        option dest '*'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-IPSec-ESP'
        option src 'wan'
        option dest 'lan'
        option proto 'esp'
        option target 'ACCEPT'

config rule
        option name 'Allow-ISAKMP'
        option src 'wan'
        option dest 'lan'
        option dest_port '500'
        option proto 'udp'
        option target 'ACCEPT'

root@OpenWrt:~#```

I do believe my main router is my DNS server, since it's connected to my modem, and I'm not using any third party dns servers or anything like that atm, just whatever the default Internet Provider ones are.

Yeah I disabled the DHCP server, or at least did the steps it says that'll accomplish that in the guide I've linked.

It's in the sockets named 1/2/3/4 instead of the internet one, the 1/2/3/4 one are the LAN sockets correct?

I'm trying to connect to the router wired so I wouldn't think my wireless connection would matter either way?

Thank you both for your help so far btw

It appears as if you've configured OpenWRT to be its own DNS server:

Was that intentional, or did you intend for your main router (192.168.0.1) to be the DNS server?

Woops that must've been a typo. Unfortunately changing it to .1 at the end didn't fix the issue, even restarted the router to be sure

I don't know the router in question (the one with OpenWRT) so I don't know how the logical port numbers map to the physical sockets.

Your configuration shows six logical ports, numbered from 0 (the hook into the kernel) through to 5.

The numbering suggests that logical port 1 corresponds - or should correspond - to the WAN socket, and ports 2-5 should correspond to the LAN sockets.

Couldn't hurt to try the cable in each of the sockets to see which - if any - offers connectivity between the AP and the main router.

Wtf I tried this for the heck of it, changing the ethernet that connects my main router to my openwrt rotuer from slot 2 to slot 3 (both still in the same group of ports with orange coloring around them) instantly made it start working. Any idea why that might've been? I definitely didn't have it connected to that port when it was working before the power spike.

Also thank you.

Dodgy cable, dodgy plug, dodgy socket? Any and/or all of those? If you had a power spike it could have fried some circuitry.

You're welcome. Glad it's working.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.