Dumb AP Guest Wi-Fi not working

Hey all, I followed this guide to the T on my WRT32X:

Unfortunately I get no internet. The Wi-Fi devices get an IP address with gateway and DNS server from the different subnet. The local network is 192.168.2.0/24 where the gateway is 192.168.2.254 (FIOS modem) and the IP subnet of the Guest network is 192.168.160.0/24 where it gives out 192.168.160.1 as gateway and DNS.

I am at a loss what I did wrong here.
DHCP:

config dhcp 'Guest'
	option interface 'Guest'
	option start '100'
	option limit '150'
	option leasetime '12h'
	list ra_flags 'none'

Network:

config interface 'Guest'
	option proto 'static'
	option ipaddr '192.168.160.1'
	option netmask '255.255.255.0'
       	option device 'wlan1'

Firewall:

config zone
	option name 'Guest'
	option output 'ACCEPT'
	option forward 'REJECT'
	option input 'REJECT'
	list network 'Guest'

config forwarding
	option src 'Guest'
	option dest 'lan'

config rule
	option name 'Guest DHCP'
	list proto 'udp'
	option src 'Guest'
	option dest_port '67-68'
	option target 'ACCEPT'
	option family 'ipv4'

config rule
	option name 'Guest DNS'
	option src 'Guest'
	option dest_port '53'
	option target 'ACCEPT'
	option family 'ipv4'

config rule
	option name 'Block Guest Access to Private Network'
	option src 'Guest'
	option dest 'lan'
	list dest_ip '192.168.2.0/24'
	option target 'DROP'
	option family 'ipv4'
	list proto 'all'
	option enabled '1'

Any help would be appreciated!

config forwarding
option src 'Guest'
option dest 'lan'

I thought this should be forwarding to wan but the guide has masquerading on lan so must be something else.

Thanks, I didn't follow it to the T it seems! I forgot to turn on masq on LAN, it works now!

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.