Dumb AP for different subnet

Hey guys,

I have a setup with 3 SSIDs on 3 different subnets (Main, Guest, lodger flat) running stable for some time now. All Ethernet ports are routed to my main subnet.

Now I need to add a dump AP in my rented flat since my tenant is complaining about poor WiFi reception.

Unfortunately I can’t spare a dedicated Ethernet port on my main router. Is it possible to use VLANs to run all subnets over the same line?

Any help in configuring the main router and dumb ap (both are OpenWRT devices)?Hey guys,

I have a setup with 3 SSIDs on 3 different subnets (Main, Guest, lodger flat) running stable for some time now. All Ethernet ports are routed to my main subnet.

Now I need to add a dump AP in my rented flat since my tenant is complaining about poor WiFi reception.

Unfortunately I can’t spare a dedicated Ethernet port on my main router. Is it possible to use VLANs to run all subnets over the same line?

Any help in configuring the main router and dumb ap (both are OpenWRT devices)?

thanks!

if the dumb ap have two radios (sometimes one is enough), why not simply retransmit the lodger flat wifi ?
basically making the AP a repeater.

Sure, that would be an easy solution. However definitely not the best from a technical side. I have an Ethernet line running to the flat so I would prefer using an AP over a repeater.

This is the network config of my main router


config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'

config interface 'lan'
	option type 'bridge'
	option ifname 'eth0.1'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option 'bcast' '192.168.1.255'

config interface 'guest'
	option proto 'static'
	option ipaddr '192.168.2.1'
	option netmask '255.255.255.0'

config interface 'mietwohnung'
	option proto 'static'
	option ipaddr '192.168.3.1'
	option netmask '255.255.255.0'

config interface 'wan'
	option ifname 'eth0.2'
	option proto 'dhcp'

config interface 'wan6'
	option ifname 'eth0.2'
	option proto 'dhcpv6'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '2 3 4 5 0t'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option ports '1 0t'

config interface 'vpn0'
	option ifname 'tun0'
	option proto 'none'
	option auto '1'
	option delegate '0'

I recently learned about VLANs, here are a couple nice videos (but the author made them on an older version of OpenWRT) but the concepts are the same.

First: setup on the router

Second: setup on the dumb AP

1 Like

Very nice videos! Thanks for sharing. I believe this will help me achieve what I want.

Yes, they were helpful for me. In my case, my hardware needed DSA which is replacing the old 'switch' interface but concepts are the same. Let me know if you need help in this thread.

Thanks for the offer. Unfortunately I do have a problem. As soon as I bridge the radio of my guest network with the vlan I no longer have a connection to the router from there. All other networks work fine. (I can connect via wifi but do not get an IP Adress, manually configuring the ip does not help).

This is the not working config:

config interface 'guest'
	option proto 'static'
	option ipaddr '192.168.2.1'
	option netmask '255.255.255.0'
	option type 'bridge'
	option ifname 'eth0.3'
config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '0t 2 3 4 5'
	option vid '1'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option ports '0t 1'
	option vid '2'

config interface 'vpn0'
	option ifname 'tun0'
	option proto 'none'
	option auto '1'
	option delegate '0'

config switch_vlan
	option device 'switch0'
	option vlan '3'
	option vid '3'
	option ports '0t'

config switch_vlan
	option device 'switch0'
	option vlan '4'
	option vid '4'
	option ports '0t'

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.