Dual Wan IPv6-PD ... choose one?

Hi there, (sorry for my bad english)
I have two ISP connected to my router, using mwan3 for IPv4
And I have 3 internal VLANs.
Now I'm trying to understand and test IPv6
Both ISP provides my router a IPv6-PD
If I configure DHCP server on the router, it leases 2 IPv6 to my lan. Any way to lease ISP 1 IPv6 to VLAN 1 and ISP 2 IPv6 to VLAN 2?
Or... if my desktop receives both IPs, it will receive two gateways and ... how it will decide which one to use?
Can I fine tune this?

ty

For IPv6, the default would be to route according to the largest common prefix match.

With consumer ISPs this is likely still not an ideal setup (in enterprise settings there are more options, as you typically get more help from your ISP --> them routing your subnet, not just their own).

Will keep testing :grimacing:
I want to load balance with mwan3 AND I want certain devices to have a public IPv6... I don't now if it's possible

Ok, for future me to see =P

wan6 and wanb6 , being wan interfaces for ipv6
lan1 and lan2, being lan interface for vlan1 and lan interface for vlan2
On /etc/config/network ...

config interface 'lan1'
        option type 'bridge'
        option ifname 'eth0.1'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6ifaceid '::ZZ'
        option ip6hint 'YYYY'
        option ip6assign '64'
        list ip6class 'wan6'

config interface 'lan2'
        option type 'bridge'
        option ifname 'eth0.2'
        option proto 'static'
        option ipaddr '192.168.2.1'
        option netmask '255.255.255.0'
        option ip6ifaceid '::XX'
        option ip6hint 'WWWW'
        option ip6assign '64'
        list ip6class 'wanb6'

I think they called this prefix filter... or something like that.
I'm also using NAT6, but that's another story.