Dual router setup Internet connection issues

I am new to LEDE OpenWRT. I found the setup guide, but had difficulty following the firewall instructions. I've been using DD-WRT for several years now, and I am interested in learning the LEDE OpenWRT system.

I have 2 routers (both Netgear Nighthawk R7000s) in a chain - router 2 (which is running LEDE OpenWRT) is connected to router 1 (running DD-WRT), and router 1 is connected to a modem out to the Internet.

When I connect my PC directly to router 1, I am able to get on the Internet with no issues.

Here is my setup when I connect my PC to router 2, which is then connected to router 1:

My PC is plugged into one of the LAN ports on router 2.
Router 2's WAN port is plugged into one of the LAN ports of router 1.
I have Router 2's WAN interface set to mode DHCP. It has a dynamic IP assigned to it by router 1.
I have Router 2's LAN interface set to the default ( for now, which is an entirely different subnet from router 1.

When I go to the router 2 GUI and navigate to the diagnostics tab, I am able to ping lede-project.org successfully.

However, when I open the Firefox browser on my PC user the router 2 > router 1 > Internet, I am unable to access any web pages.

I have also opened a command prompt and ran a ping and an nslookup on a few known websites, but got no response.

I am wondering if the router 2 WAN interface is communicating with router 1, but the LAN interface of router 2 is not communicating with the WAN interface of router 2 (see screenshot below).

I am at a loss of how to fix this. Any help is appreciated - at this point I am just trying to get my PC to connect to the Internet (PC > router 2 > router 1 > Internet).

FYI my ultimate goal is to set up two routers chaining VPN2 through VPN1 (2 different companies), and I'm taking it step by step.

Sounds like a DNS problem. Try setting DNS manually on your PC to confirm. Google's DNS servers are usually a good choice @ and

If that fixes the issue we can set DNS on "router 2" on the WAN or LAN interface. Since your ultimate goal is a double VPN, LAN settings are probably best.

Go to Network - Interfaces - LAN - EDIT - DHCP Server - Advanced Settings - DHCP-Options and enter 6,, for a permanent fix.

As a sanity check, make sure the PC is setup to obtain an IP address automatically, and is -not- using a manually entered IP address on the Router 1 segment.

Why are you setting it up like this? It will give you double NAT. I suggest to let router 1 handle all DHCP and DNS; router 2 should have a Static IP within the subnet of router 1, but outside the DHCP range. DHCP disabled on router 2. All your devices connecting to either router will be in the same subnet and can see/access each other.

The VPN comes after that. Whether you want all devices over the VPN or as it sounds like, a VPN inside a VPN, is your choice. Look at VPN bypass in other threads.

So either LAN to LAN or add the router 2 WAN port to the LAN bridge so you don’t loose the “extra” port.

Thank you all for your responses - they were very helpful and pushed me in the direction I needed to get it working. It turns out adjusting the network card to automatically acquire an IP was all that was necessary. I set it up as a double NAT because I am choosing to avoid the different devices talking to each other. I'm looking to have one set of devices exit through one VPN while the other set of devices go through both VPNs. I'm about to get started on setting up the second VPN.

Thank you again for your comments.

NAT is not a firewall. You can achieve the isolation by setting a different subnet and proper firewall rules on the devices. This potentially saves load on the second router and can make diagnostics a lot easier as each packet has the client’s address throughout your network.