DSL with Deutsche Telekom and Fritz!Box7412: Timeout waiting for PADO packets

I know there have been posts and answers about this, but I still don't get mine to work.

I've got a Fritz!Box7412 with OpenWrt 22.0.3 (Lantiq) and have been following this fabulously precise guide: VDSL+VoIP Fritz!Box to OpenWRT-on-FB-7412 migration cheat sheet

Only difference: I'm not "migrating" as in the guide, and my ISP is Deutsche Telekom directly (not 1und1 via their lines as in the guide).

I have now reset all settings and only changed what I found in various documentations crucial for getting DSL to work, and now have

root@OpenWrt:~# uci show network

network.loopback=interface
network.loopback.device='lo'
network.loopback.proto='static'
network.loopback.ipaddr='127.0.0.1'
network.loopback.netmask='255.0.0.0'

network.globals=globals
network.globals.ula_prefix='fd08:7e78:42d7::/48'

network.atm=atm-bridge
network.atm.vpi='1'
network.atm.vci='32'
network.atm.encaps='llc'
network.atm.payload='bridged'
network.atm.nameprefix='dsl'

network.dsl=dsl
network.dsl.annex='b'
network.dsl.ds_snr_offset='0'
network.dsl.line_mode='vdsl'
network.dsl.firmware='/usr/lib/firmware/modem/5.9.0.C.1.7/vr9-B-dsl.bin'
network.dsl.tone='bv'
network.dsl.xfer_mode='ptm'

network.@device[0]=device
network.@device[0].name='br-lan'
network.@device[0].type='bridge'
network.@device[0].ports='lan'
network.@device[1]=device
network.@device[1].name='lan'
network.@device[1].macaddr='yy:yy:yy:yy:yy:yy'

network.lan=interface
network.lan.device='br-lan'
network.lan.proto='static'
network.lan.netmask='255.255.255.0'
network.lan.ip6assign='60'
network.lan.ipaddr='192.168.6.1'

network.@device[2]=device
network.@device[2].name='dsl0'
network.@device[2].macaddr='xx:xx:xx:xx:xx:xx'

network.wan=interface
network.wan.proto='pppoe'
network.wan.ifname='dsl0.7'
network.wan.ipv6='auto'
network.wan.password='***'
network.wan.device='dsl0'
network.wan._orig_ifname='ptm0'
network.wan._orig_bridge='false'
network.wan.username='***@t-online.de'
network.wan6=interface
network.wan6.device='@wan'
network.wan6.proto='dhcpv6'

I keep getting


Tue Jan 3 06:15:17 2023 daemon.notice netifd: Interface 'wan' is enabled
Tue Jan 3 06:15:17 2023 daemon.notice netifd: Interface 'wan' is setting up now
Tue Jan 3 06:15:17 2023 daemon.err insmod: module is already loaded - slhc
Tue Jan 3 06:15:17 2023 daemon.err insmod: module is already loaded - ppp_generic
Tue Jan 3 06:15:17 2023 daemon.err insmod: module is already loaded - pppox
Tue Jan 3 06:15:17 2023 daemon.err insmod: module is already loaded - pppoe
Tue Jan 3 06:15:17 2023 daemon.info pppd[8455]: Plugin pppoe.so loaded.
Tue Jan 3 06:15:17 2023 daemon.info pppd[8455]: PPPoE plugin from pppd 2.4.9
Tue Jan 3 06:15:17 2023 daemon.notice pppd[8455]: pppd 2.4.9 started by root, uid 0
Tue Jan 3 06:15:32 2023 daemon.warn pppd[8455]: Timeout waiting for PADO packets
Tue Jan 3 06:15:32 2023 daemon.err pppd[8455]: Unable to complete PPPoE Discovery
Tue Jan 3 06:15:32 2023 daemon.info pppd[8455]: Exit.
Tue Jan 3 06:15:32 2023 daemon.notice netifd: Interface 'wan' is now down
Tue Jan 3 06:15:32 2023 daemon.notice netifd: Interface 'wan' is disabled

and endless repeats of this.

Unfortunately my ISP is not very helpful and very imprecise in their communication.

I wonder if I should do anything different or if this is something on the side
of the ISP, since they also keep mentioning there is a "disruption"
(while some to whom I spoke say the line is fine).

I think the VLAN ID is set to 7 by ifname='dsl0.7' but I am not entirely sure
if it needs more to that. VLAN ID 7 is required by the ISP if I understand them
and all the tutorials correctly.

Any help appreciated, even if it's just saying everything looks allright.

Thanks

John

PS: This is displayed on the "Overview" tab:
image

If you never get actual DSL sync then all the PADO timeout tells you nothing diagnostic...
Does "Line State:" ever show the word showtime?

Thank you for replying and specifying, and yes indeed, observing for a while I got to see the following:

and showtime then also appears in logs amidst the earlier lines:

Tue Jan  3 07:30:32 2023 daemon.notice netifd: Interface 'wan' is enabled
Tue Jan  3 07:33:26 2023 daemon.info dnsmasq[1]: read /etc/hosts - 4 addresses
Tue Jan  3 07:33:26 2023 daemon.info dnsmasq[1]: read /tmp/hosts/dhcp.cfg01411c - 2 addresses
Tue Jan  3 07:33:26 2023 daemon.info dnsmasq[1]: read /tmp/hosts/odhcpd - 4 addresses
Tue Jan  3 07:33:26 2023 daemon.info dnsmasq-dhcp[1]: read /etc/ethers - 0 addresses
Tue Jan  3 07:41:01 2023 kern.warn kernel: [22123.789960] enter showtime
Tue Jan  3 07:41:01 2023 kern.info kernel: [22123.791505] IPv6: ADDRCONF(NETDEV_CHANGE): dsl0: link becomes ready
Tue Jan  3 07:41:01 2023 daemon.notice netifd: Network device 'dsl0' link is up
Tue Jan  3 07:41:01 2023 daemon.notice netifd: Interface 'wan' has link connectivity
Tue Jan  3 07:41:01 2023 daemon.notice netifd: Interface 'wan' is setting up now
Tue Jan  3 07:41:01 2023 kern.warn kernel: [22123.812873] enter showtime
Tue Jan  3 07:41:01 2023 daemon.err insmod: module is already loaded - slhc
Tue Jan  3 07:41:01 2023 daemon.err insmod: module is already loaded - ppp_generic
Tue Jan  3 07:41:01 2023 daemon.err insmod: module is already loaded - pppox
Tue Jan  3 07:41:01 2023 daemon.err insmod: module is already loaded - pppoe
Tue Jan  3 07:41:01 2023 daemon.info pppd[17162]: Plugin pppoe.so loaded.
Tue Jan  3 07:41:01 2023 daemon.info pppd[17162]: PPPoE plugin from pppd 2.4.9
Tue Jan  3 07:41:01 2023 daemon.notice pppd[17162]: pppd 2.4.9 started by root, uid 0
Tue Jan  3 07:41:16 2023 daemon.warn pppd[17162]: Timeout waiting for PADO packets
Tue Jan  3 07:41:16 2023 daemon.err pppd[17162]: Unable to complete PPPoE Discovery
Tue Jan  3 07:41:16 2023 daemon.info pppd[17162]: Exit.
Tue Jan  3 07:41:16 2023 daemon.notice netifd: Interface 'wan' is now down
Tue Jan  3 07:41:16 2023 daemon.notice netifd: Interface 'wan' is disabled
Tue Jan  3 07:41:16 2023 daemon.notice netifd: Interface 'wan' is enabled
Tue Jan  3 07:41:16 2023 daemon.notice netifd: Interface 'wan' is setting up now
Tue Jan  3 07:41:17 2023 daemon.err insmod: module is already loaded - slhc
Tue Jan  3 07:41:17 2023 daemon.err insmod: module is already loaded - ppp_generic
Tue Jan  3 07:41:17 2023 daemon.err insmod: module is already loaded - pppox
Tue Jan  3 07:41:17 2023 daemon.err insmod: module is already loaded - pppoe
Tue Jan  3 07:41:17 2023 daemon.info pppd[17233]: Plugin pppoe.so loaded.
Tue Jan  3 07:41:17 2023 daemon.info pppd[17233]: PPPoE plugin from pppd 2.4.9
Tue Jan  3 07:41:17 2023 daemon.notice pppd[17233]: pppd 2.4.9 started by root, uid 0
Tue Jan  3 07:41:32 2023 daemon.warn pppd[17233]: Timeout waiting for PADO packets
Tue Jan  3 07:41:32 2023 daemon.err pppd[17233]: Unable to complete PPPoE Discovery
Tue Jan  3 07:41:32 2023 daemon.info pppd[17233]: Exit.
Tue Jan  3 07:41:32 2023 daemon.notice netifd: Interface 'wan' is now down
Tue Jan  3 07:41:32 2023 daemon.notice netifd: Interface 'wan' is disabled
Tue Jan  3 07:41:32 2023 daemon.notice netifd: Interface 'wan' is enabled
Tue Jan  3 07:41:32 2023 daemon.notice netifd: Interface 'wan' is setting up now
Tue Jan  3 07:41:32 2023 daemon.err insmod: module is already loaded - slhc
Tue Jan  3 07:41:32 2023 daemon.err insmod: module is already loaded - ppp_generic
Tue Jan  3 07:41:32 2023 daemon.err insmod: module is already loaded - pppox
Tue Jan  3 07:41:32 2023 daemon.err insmod: module is already loaded - pppoe
Tue Jan  3 07:41:33 2023 daemon.info pppd[17316]: Plugin pppoe.so loaded.
Tue Jan  3 07:41:33 2023 daemon.info pppd[17316]: PPPoE plugin from pppd 2.4.9
Tue Jan  3 07:41:33 2023 daemon.notice pppd[17316]: pppd 2.4.9 started by root, uid 0
Tue Jan  3 07:41:48 2023 daemon.warn pppd[17316]: Timeout waiting for PADO packets
Tue Jan  3 07:41:48 2023 daemon.err pppd[17316]: Unable to complete PPPoE Discovery
Tue Jan  3 07:41:48 2023 daemon.info pppd[17316]: Exit.
Tue Jan  3 07:41:48 2023 daemon.notice netifd: Interface 'wan' is now down
Tue Jan  3 07:41:48 2023 daemon.notice netifd: Interface 'wan' is disabled
Tue Jan  3 07:41:48 2023 daemon.notice netifd: Interface 'wan' is enabled
Tue Jan  3 07:41:48 2023 daemon.notice netifd: Interface 'wan' is setting up now
Tue Jan  3 07:41:48 2023 daemon.err insmod: module is already loaded - slhc
Tue Jan  3 07:41:48 2023 daemon.err insmod: module is already loaded - ppp_generic
Tue Jan  3 07:41:48 2023 daemon.err insmod: module is already loaded - pppox
Tue Jan  3 07:41:48 2023 daemon.err insmod: module is already loaded - pppoe
Tue Jan  3 07:41:48 2023 daemon.info pppd[17399]: Plugin pppoe.so loaded.
Tue Jan  3 07:41:48 2023 daemon.info pppd[17399]: PPPoE plugin from pppd 2.4.9
Tue Jan  3 07:41:48 2023 daemon.notice pppd[17399]: pppd 2.4.9 started by root, uid 0
Tue Jan  3 07:41:56 2023 daemon.notice netifd: Network device 'dsl0' link is down
Tue Jan  3 07:41:56 2023 daemon.notice netifd: Interface 'wan' has link connectivity loss
Tue Jan  3 07:41:56 2023 kern.warn kernel: [22178.902418] leave showtime
Tue Jan  3 07:41:56 2023 daemon.err pppd[17399]: select (waitForPADO): Interrupted system call
Tue Jan  3 07:41:56 2023 daemon.warn pppd[17399]: Timeout waiting for PADO packets
Tue Jan  3 07:41:56 2023 daemon.err pppd[17399]: Unable to complete PPPoE Discovery
Tue Jan  3 07:41:56 2023 daemon.info pppd[17399]: Exit.
Tue Jan  3 07:41:56 2023 daemon.notice netifd: Interface 'wan' is now down
Tue Jan  3 07:41:56 2023 daemon.notice netifd: Interface 'wan' is disabled

And it then returns to the state in the original post.

This is redundant, one says to use a VLAN and one not to. ifname is deprecated, you should use only device 'dsl0.7'.

In other words remove the ifname line and change device dsl0 to device dsl0.7.

I think I had that setting already vie Luci, but now I've done it on the command line. This is what you mean?

root@OpenWrt:~# uci delete network.wan.ifname
root@OpenWrt:~# uci set network.wan.device='dsl0.7'
root@OpenWrt:~# uci commit network

When having this setting in Luci I endet up having not a single packet sent/received. After 5 mins with this setting no success yet (0 pkts rx/tx). But I'll observe...

OK now I get actually logs which tell something, at least I think they do. Sorry for the many lines. Can I deduce from this the authentication (PPPoE username+password) is valid? It says PAP authentication succeeded:

[...] kern.warn kernel: [24309.705660] enter showtime
[...] kern.info kernel: [24309.707130] IPv6: ADDRCONF(NETDEV_CHANGE): dsl0: link becomes ready
[...] daemon.notice netifd: Network device 'dsl0' link is up
[...] kern.info kernel: [24309.719400] IPv6: ADDRCONF(NETDEV_CHANGE): dsl0.7: link becomes ready
[...] kern.warn kernel: [24309.726824] enter showtime
[...] daemon.notice netifd: VLAN 'dsl0.7' link is up
[...] daemon.notice netifd: Interface 'wan' has link connectivity
[...] daemon.notice netifd: Interface 'wan' is setting up now
[...] daemon.err insmod: module is already loaded - slhc
[...] daemon.err insmod: module is already loaded - ppp_generic
[...] daemon.err insmod: module is already loaded - pppox
[...] daemon.err insmod: module is already loaded - pppoe
[...] daemon.info pppd[20499]: Plugin pppoe.so loaded.
[...] daemon.info pppd[20499]: PPPoE plugin from pppd 2.4.9
[...] daemon.notice pppd[20499]: pppd 2.4.9 started by root, uid 0
[...] daemon.info pppd[20499]: PPP session is 184
[...] daemon.warn pppd[20499]: Connected to 9c:cc:83:c8:a6:ac via interface dsl0.7
[...] kern.info kernel: [24315.447099] pppoe-wan: renamed from ppp0
[...] daemon.info pppd[20499]: Renamed interface ppp0 to pppoe-wan
[...] daemon.info pppd[20499]: Using interface pppoe-wan
[...] daemon.notice pppd[20499]: Connect: pppoe-wan <--> dsl0.7
[...] daemon.info pppd[20499]: Remote message: SRU=11988#SRD=28210#
[...] daemon.notice pppd[20499]: PAP authentication succeeded
[...] daemon.notice pppd[20499]: peer from calling number 9C:CC:83:C8:A6:AC authorized
[...] daemon.notice pppd[20499]: local  IP address 93.199.110.87
[...] daemon.notice pppd[20499]: remote IP address 62.155.241.200
[...] daemon.notice pppd[20499]: primary   DNS address 217.237.150.115
[...] daemon.notice pppd[20499]: secondary DNS address 217.237.151.205
[...] daemon.warn dnsmasq[1]: failed to create listening socket for fe80::9ecc:83ff:fec8:a6ac%pppoe-wan: Address not available
[...] daemon.notice pppd[20499]: local  LL address fe80::8941:d3f4:ed4b:1336
[...] daemon.warn dnsmasq[1]: failed to create listening socket for fe80::9ecc:83ff:fec8:a6ac%pppoe-wan: Address not available
[...] daemon.notice pppd[20499]: remote LL address fe80::9ecc:83ff:fec8:a6ac
[...] daemon.notice netifd: Network device 'pppoe-wan' link is up
[...] daemon.notice netifd: Interface 'wan6' is enabled
[...] daemon.notice netifd: Network alias 'pppoe-wan' link is up
[...] daemon.notice netifd: Interface 'wan6' has link connectivity
[...] daemon.notice netifd: Interface 'wan6' is setting up now
[...] daemon.notice netifd: Interface 'wan' is now up
[...] daemon.info dnsmasq[1]: reading /tmp/resolv.conf.d/resolv.conf.auto
[...] daemon.info dnsmasq[1]: using nameserver 217.237.150.115#53
[...] daemon.info dnsmasq[1]: using nameserver 217.237.151.205#53
[...] daemon.info dnsmasq[1]: using only locally-known addresses for test
[...] daemon.info dnsmasq[1]: using only locally-known addresses for onion
[...] daemon.info dnsmasq[1]: using only locally-known addresses for localhost
[...] daemon.info dnsmasq[1]: using only locally-known addresses for local
[...] daemon.info dnsmasq[1]: using only locally-known addresses for invalid
[...] daemon.info dnsmasq[1]: using only locally-known addresses for bind
[...] daemon.info dnsmasq[1]: using only locally-known addresses for lan
[...] daemon.warn dnsmasq[1]: failed to create listening socket for fe80::9ecc:83ff:fec8:a6ac%pppoe-wan: Address not available
[...] daemon.warn dnsmasq[1]: failed to create listening socket for fe80::9ecc:83ff:fec8:a6ac%pppoe-wan: Address not available
[...] daemon.warn dnsmasq[1]: failed to create listening socket for fe80::9ecc:83ff:fec8:a6ac%pppoe-wan: Address not available
[...] daemon.warn dnsmasq[1]: failed to create listening socket for fe80::9ecc:83ff:fec8:a6ac%pppoe-wan: Address not available
[...] daemon.notice netifd: Interface 'wan6' is now up
[...] daemon.info dnsmasq[1]: reading /tmp/resolv.conf.d/resolv.conf.auto
[...] daemon.info dnsmasq[1]: using nameserver 217.237.150.115#53
[...] daemon.info dnsmasq[1]: using nameserver 217.237.151.205#53
[...] daemon.info dnsmasq[1]: using nameserver 2003:180:2:5000::53#53
[...] daemon.info dnsmasq[1]: using nameserver 2003:180:2:2000::53#53
[...] daemon.info dnsmasq[1]: using only locally-known addresses for test
[...] daemon.info dnsmasq[1]: using only locally-known addresses for onion
[...] daemon.info dnsmasq[1]: using only locally-known addresses for localhost
[...] daemon.info dnsmasq[1]: using only locally-known addresses for local
[...] daemon.info dnsmasq[1]: using only locally-known addresses for invalid
[...] daemon.info dnsmasq[1]: using only locally-known addresses for bind
[...] daemon.info dnsmasq[1]: using only locally-known addresses for lan
[...] daemon.notice netifd: Interface 'wan_6' is enabled
[...] daemon.notice netifd: Interface 'wan_6' has link connectivity
[...] daemon.notice netifd: Interface 'wan_6' is setting up now
[...] user.notice firewall: Reloading firewall due to ifup of wan (pppoe-wan)
[...] daemon.warn odhcpd[1431]: A default route is present but there is no public prefix on lan thus we don't announce a default route!
[...] daemon.warn dnsmasq[1]: failed to create listening socket for fe80::9ecc:83ff:fec8:a6ac%pppoe-wan: Address not available
[...] daemon.warn dnsmasq[1]: failed to create listening socket for fe80::9ecc:83ff:fec8:a6ac%pppoe-wan: Address not available
[...] daemon.notice netifd: Interface 'wan_6' is now up
[...] daemon.info dnsmasq[1]: reading /tmp/resolv.conf.d/resolv.conf.auto
[...] daemon.info dnsmasq[1]: using nameserver 217.237.150.115#53
[...] daemon.info dnsmasq[1]: using nameserver 217.237.151.205#53
[...] daemon.info dnsmasq[1]: using nameserver 2003:180:2:5000::53#53
[...] daemon.info dnsmasq[1]: using nameserver 2003:180:2:2000::53#53
[...] daemon.info dnsmasq[1]: using nameserver 2003:180:2:5000::53#53
[...] daemon.info dnsmasq[1]: using nameserver 2003:180:2:2000::53#53
[...] daemon.info dnsmasq[1]: using only locally-known addresses for test
[...] daemon.info dnsmasq[1]: using only locally-known addresses for onion
[...] daemon.info dnsmasq[1]: using only locally-known addresses for localhost
[...] daemon.info dnsmasq[1]: using only locally-known addresses for local
[...] daemon.info dnsmasq[1]: using only locally-known addresses for invalid
[...] daemon.info dnsmasq[1]: using only locally-known addresses for bind
[...] daemon.info dnsmasq[1]: using only locally-known addresses for lan
[...] daemon.warn dnsmasq[1]: failed to create listening socket for fe80::9ecc:83ff:fec8:a6ac%pppoe-wan: Address not available
[...] daemon.warn dnsmasq[1]: failed to create listening socket for fe80::9ecc:83ff:fec8:a6ac%pppoe-wan: Address not available
[...] daemon.warn odhcpd[1431]: A default route is present but there is no public prefix on lan thus we don't announce a default route!
[...] daemon.notice netifd: Interface 'wan_6' has lost the connection
[...] daemon.warn dnsmasq[1]: failed to create listening socket for fe80::9ecc:83ff:fec8:a6ac%pppoe-wan: Address not available
[...] daemon.warn dnsmasq[1]: failed to create listening socket for fe80::9ecc:83ff:fec8:a6ac%pppoe-wan: Address not available
[...] daemon.info dnsmasq[1]: reading /tmp/resolv.conf.d/resolv.conf.auto
[...] daemon.info dnsmasq[1]: using nameserver 217.237.150.115#53
[...] daemon.info dnsmasq[1]: using nameserver 217.237.151.205#53
[...] daemon.info dnsmasq[1]: using nameserver 2003:180:2:5000::53#53
[...] daemon.info dnsmasq[1]: using nameserver 2003:180:2:2000::53#53
[...] daemon.info dnsmasq[1]: using only locally-known addresses for test
[...] daemon.info dnsmasq[1]: using only locally-known addresses for onion
[...] daemon.info dnsmasq[1]: using only locally-known addresses for localhost
[...] daemon.info dnsmasq[1]: using only locally-known addresses for local
[...] daemon.info dnsmasq[1]: using only locally-known addresses for invalid
[...] daemon.info dnsmasq[1]: using only locally-known addresses for bind
[...] daemon.info dnsmasq[1]: using only locally-known addresses for lan
[...] daemon.warn dnsmasq[1]: failed to create listening socket for fe80::9ecc:83ff:fec8:a6ac%pppoe-wan: Address not available
[...] daemon.warn dnsmasq[1]: failed to create listening socket for fe80::9ecc:83ff:fec8:a6ac%pppoe-wan: Address not available
[...] daemon.warn dnsmasq[1]: failed to create listening socket for fe80::9ecc:83ff:fec8:a6ac%pppoe-wan: Address not available
[...] daemon.warn dnsmasq[1]: failed to create listening socket for fe80::9ecc:83ff:fec8:a6ac%pppoe-wan: Address not available
[...] daemon.warn dnsmasq[1]: failed to create listening socket for fe80::9ecc:83ff:fec8:a6ac%pppoe-wan: Address not available
[...] daemon.warn dnsmasq[1]: failed to create listening socket for fe80::9ecc:83ff:fec8:a6ac%pppoe-wan: Address not available
[...] daemon.warn dnsmasq[1]: failed to create listening socket for fe80::9ecc:83ff:fec8:a6ac%pppoe-wan: Address not available
[...] daemon.notice netifd: Interface 'wan_6' is now up
[...] daemon.warn dnsmasq[1]: failed to create listening socket for fe80::9ecc:83ff:fec8:a6ac%pppoe-wan: Address not available
[...] daemon.info dnsmasq[1]: reading /tmp/resolv.conf.d/resolv.conf.auto
[...] daemon.info dnsmasq[1]: using nameserver 217.237.150.115#53
[...] daemon.info dnsmasq[1]: using nameserver 217.237.151.205#53
[...] daemon.info dnsmasq[1]: using nameserver 2003:180:2:5000::53#53
[...] daemon.info dnsmasq[1]: using nameserver 2003:180:2:2000::53#53
[...] daemon.info dnsmasq[1]: using nameserver 2003:180:2:5000::53#53
[...] daemon.info dnsmasq[1]: using nameserver 2003:180:2:2000::53#53
[...] daemon.info dnsmasq[1]: using only locally-known addresses for test
[...] daemon.info dnsmasq[1]: using only locally-known addresses for onion
[...] daemon.info dnsmasq[1]: using only locally-known addresses for localhost
[...] daemon.info dnsmasq[1]: using only locally-known addresses for local
[...] daemon.info dnsmasq[1]: using only locally-known addresses for invalid
[...] daemon.info dnsmasq[1]: using only locally-known addresses for bind
[...] daemon.info dnsmasq[1]: using only locally-known addresses for lan
[...] daemon.info dnsmasq[1]: read /etc/hosts - 4 addresses
[...] daemon.info dnsmasq[1]: read /tmp/hosts/dhcp.cfg01411c - 2 addresses
[...] daemon.info dnsmasq[1]: read /tmp/hosts/odhcpd - 8 addresses
[...] daemon.info dnsmasq-dhcp[1]: read /etc/ethers - 0 addresses
[...] user.notice firewall: Reloading firewall due to ifupdate of wan (pppoe-wan)
[...] daemon.warn dnsmasq[1]: failed to create listening socket for fe80::9ecc:83ff:fec8:a6ac%pppoe-wan: Address not available
[...] daemon.warn dnsmasq[1]: failed to create listening socket for fe80::9ecc:83ff:fec8:a6ac%pppoe-wan: Address not available
[...] user.notice firewall: Reloading firewall due to ifup of wan6 (pppoe-wan)
[...] user.notice firewall: Reloading firewall due to ifup of wan_6 (pppoe-wan)
[...] daemon.info pppd[20499]: No response to 5 echo-requests
[...] daemon.notice pppd[20499]: Serial link appears to be disconnected.
[...] daemon.info pppd[20499]: Connect time 0.9 minutes.
[...] daemon.info pppd[20499]: Sent 12832 bytes, received 22500 bytes.
[...] daemon.warn dnsmasq[1]: failed to create listening socket for fe80::9ecc:83ff:fec8:a6ac%pppoe-wan: Address not available
[...] daemon.warn dnsmasq[1]: failed to create listening socket for fe80::9ecc:83ff:fec8:a6ac%pppoe-wan: Address not available
[...] daemon.err odhcp6c[20598]: Failed to send RS (Network unreachable)
[...] daemon.err odhcp6c[20635]: Failed to send RELEASE message to ff02::1:2 (Network unreachable)
[...] daemon.notice netifd: Network device 'pppoe-wan' link is down
[...] daemon.notice netifd: Network alias 'pppoe-wan' link is down
[...] daemon.notice netifd: Interface 'wan6' has link connectivity loss
[...] daemon.notice netifd: Interface 'wan_6' has link connectivity loss
[...] daemon.err odhcp6c[20635]: Failed to send SOLICIT message to ff02::1:2 (Network unreachable)
[...] daemon.notice netifd: Interface 'wan' has lost the connection
[...] daemon.warn dnsmasq[1]: no servers found in /tmp/resolv.conf.d/resolv.conf.auto, will retry
[...] daemon.notice netifd: wan_6 (20635): Command failed: ubus call network.interface notify_proto { "action": 0, "link-up": false, "keep": false, "interface": "wan_6" } (Permission denied)
[...] daemon.notice netifd: Interface 'wan_6' is now down
[...] daemon.info dnsmasq[1]: read /etc/hosts - 4 addresses
[...] daemon.info dnsmasq[1]: read /tmp/hosts/dhcp.cfg01411c - 2 addresses
[...] daemon.info dnsmasq[1]: read /tmp/hosts/odhcpd - 4 addresses
[...] daemon.info dnsmasq-dhcp[1]: read /etc/ethers - 0 addresses
[...] daemon.err odhcp6c[20598]: Failed to send SOLICIT message to ff02::1:2 (Network unreachable)
[...] daemon.notice netifd: Interface 'wan6' is now down
[...] daemon.notice netifd: Interface 'wan6' is disabled
[...] kern.info kernel: [24373.396470] do_page_fault(): sending SIGSEGV to dnsmasq for invalid read access from 00000000
[...] kern.info kernel: [24373.403675] epc = 77eb22a8 in ld-musl-mips-sf.so.1[77e32000+a9000]
[...] kern.info kernel: [24373.409756] ra  = 555ce20f in dnsmasq[555b0000+2f000]
[...] daemon.notice netifd: Network device 'dsl0' link is down
[...] daemon.notice netifd: VLAN 'dsl0.7' link is down
[...] daemon.notice netifd: Interface 'wan' has link connectivity loss
[...] kern.warn kernel: [24376.262242] leave showtime
[...] daemon.info pppd[20499]: Terminating on signal 15
[...] daemon.notice pppd[20499]: Connection terminated.
[...] daemon.info pppd[20499]: Connect time 0.9 minutes.
[...] daemon.info pppd[20499]: Sent 12832 bytes, received 22500 bytes.
[...] daemon.notice pppd[20499]: Modem hangup
[...] daemon.info pppd[20499]: Exit.
[...] daemon.notice netifd: Interface 'wan' is now down
[...] daemon.notice netifd: Interface 'wan' is disabled
[...] daemon.notice netifd: Interface 'wan' is enabled
[...] daemon.info dnsmasq[1]: started, version 2.86 cachesize 150
[...] daemon.info dnsmasq[1]: DNS service limited to local subnets
[...] daemon.info dnsmasq[1]: compile time options: IPv6 GNU-getopt no-DBus UBus no-i18n no-IDN DHCP no-DHCPv6 no-Lua TFTP no-conntrack no-ipset no-auth no-cryptohash no-DNSSEC no-ID loop-detect inotify dumpfile
[...] daemon.info dnsmasq[1]: UBus support enabled: connected to system bus
[...] daemon.info dnsmasq-dhcp[1]: DHCP, IP range 192.168.6.100 -- 192.168.6.249, lease time 12h
[...] daemon.info dnsmasq[1]: using only locally-known addresses for test
[...] daemon.info dnsmasq[1]: using only locally-known addresses for onion
[...] daemon.info dnsmasq[1]: using only locally-known addresses for localhost
[...] daemon.info dnsmasq[1]: using only locally-known addresses for local
[...] daemon.info dnsmasq[1]: using only locally-known addresses for invalid
[...] daemon.info dnsmasq[1]: using only locally-known addresses for bind
[...] daemon.info dnsmasq[1]: using only locally-known addresses for lan
[...] daemon.warn dnsmasq[1]: no servers found in /tmp/resolv.conf.d/resolv.conf.auto, will retry
[...] daemon.info dnsmasq[1]: read /etc/hosts - 4 addresses
[...] daemon.info dnsmasq[1]: read /tmp/hosts/dhcp.cfg01411c - 2 addresses
[...] daemon.info dnsmasq[1]: read /tmp/hosts/odhcpd - 4 addresses
[...] daemon.info dnsmasq-dhcp[1]: read /etc/ethers - 0 addresses

This actually looks good, though there may be some problems with IPv6. Try running v4 only for now.

...until this happens:

Then it drops the connection and resets everything. There is a way to disable the echo check if it really is just a false positive.

This still looks like the DSL connection itself is the issue. Your focus should be on getting the DSL connection stable: It needs to stay in showtime state. Did you previously use another modem that was stable?

From your config, you seem to use the DSL firmware from the Fritzbox 7412 vendor firmware. However, this version is quite old, and it is possible that a newer version would improve stability. The latest version in the firmware list is 5.9.1.4.0.7-5.9.0.D.0.2, which should be a good pick.

If that doesn't help, it would make sense to further diagnose the DSL issue by looking at spectrum data (while the line is in showtime state). If you were using OpenWrt master, then that would be possible using the luci-mod-dsl package. On the stable release an external tool is needed, like my own application or @moeller0's parser.

Thank you, I removed the device property from WAN6 and hope that this dropped the link entirely. As a result I did have the chance to actually load a website for the first time, but this state lasts only about 90 seconds, then the process repeats. Now I'm at:

[...] kern.warn kernel: [  450.584900] enter showtime
[...] kern.info kernel: [  450.586506] IPv6: ADDRCONF(NETDEV_CHANGE): dsl0: link becomes ready
[...] daemon.notice netifd: Network device 'dsl0' link is up
[...] kern.info kernel: [  450.600362] IPv6: ADDRCONF(NETDEV_CHANGE): dsl0.7: link becomes ready
[...] daemon.notice netifd: VLAN 'dsl0.7' link is up
[...] daemon.notice netifd: Interface 'wan' has link connectivity
[...] daemon.notice netifd: Interface 'wan' is setting up now
[...] kern.warn kernel: [  450.618500] enter showtime
[...] daemon.err insmod: module is already loaded - slhc
[...] daemon.err insmod: module is already loaded - ppp_generic
[...] daemon.err insmod: module is already loaded - pppox
[...] daemon.err insmod: module is already loaded - pppoe
[...] daemon.info pppd[2896]: Plugin pppoe.so loaded.
[...] daemon.info pppd[2896]: PPPoE plugin from pppd 2.4.9
[...] daemon.notice pppd[2896]: pppd 2.4.9 started by root, uid 0
[...] daemon.info pppd[2896]: PPP session is 181
[...] daemon.warn pppd[2896]: Connected to 9c:cc:83:c8:a6:ac via interface dsl0.7
[...] kern.info kernel: [  456.495931] pppoe-wan: renamed from ppp0
[...] daemon.info pppd[2896]: Renamed interface ppp0 to pppoe-wan
[...] daemon.info pppd[2896]: Using interface pppoe-wan
[...] daemon.notice pppd[2896]: Connect: pppoe-wan <--> dsl0.7
[...] daemon.notice pppd[2896]: Modem hangup
[...] daemon.notice pppd[2896]: Connection terminated.
[...] daemon.info pppd[2896]: Exit.
[...] daemon.notice netifd: Interface 'wan' is now down
[...] daemon.notice netifd: Interface 'wan' is disabled

I will try the latest firmware as suggested by @janh

Interestingly there was just a similar error reported here:

while not conclusive the "fix" was to replace the modem. Now unclear whether the root cause is software or hardware....

By all means, take @janh's tool, which is leaps and bounds better than my crufty parser (which I started years back when I could not find anything similar, if Jan's tool had existed then I would never have started, and I never really finished this beyond a "works for me" state, so it might well break on other systems).

OK I am using the newer firmware I now get, among other lines:

failed to create listening socket for fe80::9ecc:83ff:fec8:a6ac%pppoe-wan: Address not available
Failed to send RS (Network unreachable)
Failed to send RELEASE message to ff02::1:2 (Network unreachable)
wan_6 (17378): Command failed: ubus call network.interface notify_proto { "action": 0, "link-up": false, "keep": false, "interface": "wan_6" } (Permission denied)

Which looks like I still haven't entirely switched off ipv6?

@janh I think I can't make much sense of your tool's output :smiley:
The summary is

         State:    Showtime
            Mode:    VDSL2 Profile 17a
          Uptime:    0 minutes

          Remote:    Broadcom 12.3.86 (193.214)
           Modem:    Infineon

     Actual rate:       40193 kbit/s      12735 kbit/s 
 Attainable rate:       40861 kbit/s      17820 kbit/s 
         MINEFTR:         233 kbit/s    3650065 kbit/s 

         Bitswap:     on (14)            on (2)        
 Rate adaptation:         off               off        

    Interleaving:        0.14 ms              0 ms     
             INP:        35.0 symbols      34.0 symbols
  Retransmission:          on                on        

       Vectoring:        full              full        

     Attenuation:        19.7 dB           29.0 dB     
      SNR margin:         6.2 dB            8.1 dB     
  Transmit power:        12.4 dBm          10.4 dBm    

    RTX TX Count:    208818082            134147        
     RTX C Count:        6860            954283        
    RTX UC Count:      420550          15743837        

       FEC Count:           0               923        
       CRC Count:           1                 0        

        ES Count:           8                 4        
       SES Count:           6                 4        

You mean same product, new device?

Unfortunately the OP in that thread did not elaborate...

Why? Why do you want to do that? DTAG offers by far the best IPv6 support in Germany. You get a /56 and as long as your session stays up the prefix do not even change...
And btw you can not really disable ipv6. If you really need to you can however not configure IPv6 on the wan interface but this simply does not make any sense given the fact that IPv6 just works with DTAG. I'm a happy customer myself. Nowadays half my traffic sometimes more is using IPv6 networks. It's already 11 years since the global IPv6 day and there are no excuses left why someone would not use it.

Well just as @mk24 explained, there seems to be a problem with ipv6, and as I wrote, switching it off did help in the sense the connection can be established. But yes, I totally agree with you that it's not really the desired state.
Also, from recent logs it seems like ipv6 is still an issue even with the device removed ^^
Do you have any suggestions for the exact settings of wan6?
I'm confused if it should be PPPoE protocol or DHCP client (which was the default and is in some tutorials). Either way it should eventually be device='@wan', right?

Definitely trying a new Modem as soon as I can get one, unless this starts working soon... :slight_smile:

As I understand you have an integrated (not external modem) running? I can't say something on it... but wan config (using an external one) looks like:

#######################################################################
# VLAN 7: wan               (DTAG VDSL2+ PPPoE)
config switch_vlan
    option  device          'switch0'
    option  ports           '1t 0t'
    option  vlan            '7'

config device
    option  name            'eth0.7'

config interface            'wan'
    option  device          'eth0.7'
    option  proto           'pppoe'
    option  username        '<25 digit number>@t-online.de' # anschlusskennung? 
    option  password        '<9 digit>'
    option  ipv6            'auto'

config interface            'wan6'
    option  device          'eth0.7'
    option  proto           'dhcpv6'
    option  reqaddress      'try'       # [try,force,none]
    option  reqprefix       '56'

Edit: The config is from a device with swconfig on 21.04.

Regarding external modem: I tried to find a suitable one too, but only found Vigor devices and nowhere clear statements if works and if, with what settings. Called it a day and just brought the Speed Port from DTAG and set it into bridge-mode. Old speed port 4 served me 5 years and is still running at a friends place, and the current speed port 5(?) shows the same good behavior. Its quiet expensive but also are the Vigor Modems. And for me it was easier and more sane to just spend the 40 EUR more on the DTAG device and having no issues. And if there should be an issue, DTAG support can not blame you to use an "not supported device" :wink:

Thanks, I did put wan6 on the same device as wan (not @wan), and this time it works (briefly) even with wan6 enabled, so that's a step forward I think :-).
Still the point where it switches off:

[...] daemon.notice netifd: Network device 'pppoe-wan' link is down
[...] daemon.notice netifd: Network alias 'pppoe-wan' link is down
[...] daemon.err odhcp6c[23714]: Failed to send RS (Network unreachable)
[...] daemon.notice netifd: Interface 'wan_6' has link connectivity loss
[...] daemon.err odhcp6c[23714]: Failed to send RELEASE message to ff02::1:2 (Network unreachable)
[...] daemon.notice netifd: Interface 'wan' has lost the connection
[...] daemon.warn dnsmasq[1]: no servers found in /tmp/resolv.conf.d/resolv.conf.auto, will retry
[...] daemon.notice netifd: wan_6 (23714): Command failed: ubus call network.interface notify_proto { "action": 0, "link-up": false, "keep": false, "interface": "wan_6" } (Permission denied)
[...] daemon.err odhcp6c[23714]: Failed to send SOLICIT message to ff02::1:2 (Network unreachable)
[...] daemon.notice netifd: Interface 'wan_6' is now down
[...] daemon.notice netifd: Interface 'wan_6' is disabled
[...] daemon.notice netifd: Network device 'dsl0' link is down
[...] kern.warn kernel: [ 7671.448276] leave showtime
[...] daemon.notice netifd: VLAN 'dsl0.7' link is down
[...] daemon.notice netifd: Interface 'wan' has link connectivity loss
[...] daemon.notice netifd: Interface 'wan6' has link connectivity loss
[...] daemon.notice netifd: Interface 'wan6' is now down
[...] daemon.info pppd[1600]: Terminating on signal 15
[...] daemon.notice pppd[1600]: Connection terminated.
[...] daemon.info pppd[1600]: Connect time 0.8 minutes.
[...] daemon.info pppd[1600]: Sent 100796 bytes, received 337623 bytes.
[...] daemon.notice pppd[1600]: Modem hangup
[...] daemon.info pppd[1600]: Exit.

One thing I jsut noticed: I don't have an explicit switch_vlan in my config, it looks like this:

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd08:7e78:42d7::/48'

config atm-bridge 'atm'
	option vpi '1'
	option vci '32'
	option encaps 'llc'
	option payload 'bridged'
	option nameprefix 'dsl'

config dsl 'dsl'
	option annex 'b'
	option ds_snr_offset '0'
	option line_mode 'vdsl'
	option tone 'bv'
	option xfer_mode 'ptm'
	option firmware '/usr/lib/firmware/modem/5.9.1.4.0.7-5.9.0.D.0.2/vr9-B-dsl.bin'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'lan'

config device
	option name 'lan'
	option macaddr '**:**:**:DC:22:69'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option ipaddr '192.168.6.1'

config device
	option name 'dsl0'
	option macaddr '**'

config interface 'wan'
	option proto 'pppoe'
	option ipv6 'auto'
	option password '***'
	option _orig_ifname 'ptm0'
	option _orig_bridge 'false'
	option username '***@t-online.de'
	option device 'dsl0.7'

config interface 'wan6'
	option proto 'dhcpv6'
	option reqaddress 'try'
	option reqprefix 'auto'
	option device 'dsl0.7'

I think I will declare that explicitly like you did, but I must find out which should be the port and underlying device.
And yes, I'm using the built-in modem of Fritz Box 7412. I was quite confident to get this 5€ device and just get DSL to work in this house, as it was quite positively reviewed with OpenWrt... But seems like there is work to be done.

And another sidenote: I am using just <kundennummer>@t-online.de as the customer support said nowadays this is sufficient. And since I am able to connect even for a short amount of time I think this part works fine. I've tried the other combinations with Anschlusskennung etc., too, same result.

Regarding using no password I think/guess this works only on the default firmware where Auto config is supported... Called tr 069.

Regarding the internal switch config: cross check with the wiki because your Fritzbox is different then my old tplink archer...