DSL to ETH-WAN or LAN to WAN

Hello all,
I need your help. Unfortunately, I did not find what I was looking for on the Internet. Unfortunately, the WLAN on my "old" router WDR3600 failed, so I want to use my replacement router Easybox 904xDSL.


Unfortunately this has no eth-WAN connection, but uses the DSL connection as WAN. How can I configure this so that it fetches the internet connection from another router?
If it does not work via the DSL port, I would implement it via the LAN1 socket so that this then becomes the WAN socket.
So far I had only used the normal configuration (on the WDR3600 with OpenWRT), but never got that deep into it. Thanks!

Greetings Icke
Translated with www.DeepL.com/Translator (free version)
ORIGINAL------------------------------------
Hallo zusammen,
ich brauche Eure Hilfe. Im Internet bin ich leider nicht fündig geworden. Leider ist bei meinem "alten" Router WDR3600 das WLAN ausgefallen, deshalb möchte ich meinen Ersatzrouter Easybox 904xDSL verwenden. Leider hat diese keinen eth-WAN-Anschluß, sondern verwendet als WAN den DSL-Anschluß. Wie kann ich diesen so konfigurieren, damit er von einem anderen Router die Internetverbindung holt?
Falls es nicht über den DSL-Anschluß funktioniert, würde ich es über die LAN1-Buchse realisieren, damit diese dann zur WAN-Buchse wird.
Bisher hatte ich nur die normale Konfiguration angewendet (auf dem WDR3600 mit OpenWRT), bin aber nie so tief in die Materie eingestiegen. Danke!

Gruß Icke

@icke68746
You can't use the DSL port for anything else, because it's hardwired to the DSL modem chip.
Edit: That seems to not be true. It's possible to use it as an ethernet wan port, but apparently with only 100MBit/s.
So the better way is to use a LAN port as the WAN port.
Or you could just keep the WDR3600 as a router and use the Easybox just as a dumb AP.
How is the primary router set up? As a router or a bridged modem?

/ German * Deutsch /
Den DSL-Anschluss kannst du nur für DSL benutzen, da er direkt an den DSL-Modem-Chip angeschlossen ist.
Edit: Das scheint nicht richtig zu sein.
Es ist möglich den Anschluss als Ethernet WAN Anschluss zu nutzen,
aber wohl nur mit 100MBit/s.
Die bessere Möglichkeit wäre, einen LAN-Anschluss als WAN zu konfigurieren.
Oder du behältst den WDR3600 als Router und schliesst die Easybox als dummen AP an ihn an.
Wie ist denn der andere Router eingestellt? Fungiert er als vollwertiger Router oder als reines Modem?

You are facing three quite fundamental issues here:

  • eb904xdsl support isn't merged into OpenWrt, maintained forks to make it working exist, but it's far from a first class citizen here.
  • the switch setup of this hardware is very special, basically two stacked switches with some hardcoded logic behind it, setting this up (beyond the defaults) isn't quite trivial.
  • the wireless side (RaLink iNIC) is also very quirky, to say the least.

None of these make your endeavour impossible, but you're looking at a quite steep learning curve with lots of tinkering (reading through multiple dozens of old, half incomplete, forum posts about this device) and frustration ahead.

Do yourself a favour and look at the used markets for something fully supported, something much easier and more reliable (even faster) to work with, it's realistic to find very decent things for 5-20 EUR plus shipping in used, but fully functional, condition (e.g. the tl-wdr3600 is commonly found in the lower end of that price bracket, while I wouldn't quite recommend to buy that in 2023, it's heaps ahead of the eb904xdsl).

After reading about the issues @slh mentioned, i agree with him.
Go for another, better supported router.
I've got a TP-Link WDR4300 that i don't use anymore,
maybe you're interested?
/ German * Deutsch /
Nachdem, was @slh über die Probleme geschrieben hat stimme ich ihm zu.
Besorge dir einen anderen, besser unterstützten Router.
Ich habe hier noch einen TP-Link WDR4300 den ich nicht mehr nutze.
Vielleicht bist du ja interessiert?

Hello,
thank you for your answers.
The first router (Fritzbox 6591 Cable) is only used to access the cable internet 50MBit. There WLAN and DHCP is switched off, only the WDR3600 is connected to it via WAN socket and gets its Internet there.
I used the WDR3600 to keep the network ad-free, my wife has been complaining since the WLAN went down because her mobile games are now ad-infested.
I am aware that the learning curve is steeper. But I find it interesting and fun. The only thing I still lack is the understanding of how to reconfigure the connection. I like the router because it has a screen in front where you can read the status.

@elder_tinkerer If I don't get it right, I'll take you up on your offer. Thanks!
Since the LUCI is not reliable, I did the configuration in the /etc/config/network (see attachment). I want to make the LAN1 socket the WAN socket. Unfortunately the configuration does not work properly, the Fritzbox shows that the Easybox has an IP (10.0.0.3), however I can not ping the Fritzbox, nor can I get to the internet from the Easybox (ping 8.8.8.8 fails). It seems to me that I am close to the goal. Maybe someone look over?

Greetings Icke

Translated with www.DeepL.com/Translator (free version)
----ORIGINAL---------
Hallo,
danke für Eure Antworten.
Der erste Router (Fritzbox 6591 Cable) dient nur als Zugang zum Kabel-Internet 50MBit. Dort ist WLAN und DHCP ausgeschaltet, nur der WDR3600 ist mit ihm per WAN-Buchse verbunden und holt sich dort sein Internet.
Den WDR3600 verwendete ich, um das Netzwerk Werbefrei zu halten, meine Frau schimpft seit das WLAN ausgefallen ist, weil ihre Handyspiele jetzt Werbeverseucht sind.
Das die Lernkurve steiler ist, ist mir bewußt. Ich finde das aber interessant und es macht mir Spaß. Nur fehlt mir noch etwas das Verständnis, wie ich den Anschluss umkonfiguriere. Der Router gefällt mir gut, weil er vorne einen Bildschirm hat, wo man den Status ablesen kann.
@elder_tinkerer Wenn ich es nicht hinkriege, komme ich auf Dein Angebot zurück. Danke!
Da das LUCI nicht zuverlässig ist, habe ich die Konfiguration in der /etc/config/network vorgenommen (siehe Anhang). Die LAN1-Buchse möchte ich zur WAN-Buchse machen. Leider funktioniert die Konfiguration nicht richtig, die Fritzbox zeigt an, dass die Easybox eine IP hat (10.0.0.3), jedoch kann ich die Fritzbox nicht anpingen, und komme auch nicht von der Easybox ins Internet (ping 8.8.8.8 scheitert). Mir scheint es, als wäre ich kurz vor dem Ziel. Vielleicht guck' mal jemand rüber?

Gruß Icke
/etc/config/network:

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'
	option ipv6 '1'

config globals 'globals'
	option packet_steering '1'
	option ula_prefix 'fd7c:8a27:2f31::/48'

config device
	option name 'br-lan'
	option type 'bridge'
	option ports 'eth0.71 eth0.66 eth0.1'
	option ipv6 '1'

config device
	option name 'eth0.1'
	option macaddr '9c:80:df:7c:2f:5e'
	option ipv6 '1'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option ipv6 '1'
	list ifname 'eth0.66 eth0.71 eth0.1'
	list ifname 'eth0.66'

config device
	option name 'dsl0'
	option macaddr '9c:80:df:7c:2f:5f'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '0 6t'

config switch
	option name 'switch1'
	option reset '1'
	option enable_vlan '1'
	option enable_vlan4k '1'
	option max_length '3'

config switch_vlan
	option device 'switch1'
	option vlan '1'
	option ports '0t 1 2 3 6t'
	option vid '3'

config switch_vlan
	option device 'switch1'
	option vlan '2'
	option ports '0 1t 2t 3t 6t'
	option vid '1'

config interface 'wan'
	option ipv6 '0'
	option proto 'static'
	option netmask '255.255.255.0'
	option device 'eth0.1'
	option ipaddr '10.0.0.3'
	option gateway '10.0.0.1'
	option broadcast '10.0.0.0'
	list dns '5.9.164.112'
	list dns '8.8.4.4'

config interface 'wwan'
	option proto 'dhcp'
	option ipv6 '0'
	option auto '1'
	option metric '10'
	option device 'usb0'

config interface 'TUN'
	option proto 'none'
	option delegate '0'
	option auto '1'
	option metric '10'
	option device 'tun0'

config interface 'NCM'
	option proto 'ncm'
	option delegate '0'
	option device '/dev/ttyUSB0'
	option service 'preferlte'
	option pdptype 'IP'
	option apn 'internet'
	option ipv6 '0'
	option auto '0'
	option metric '10'

config device 'inic_dev'
	option name 'eth0.3'
	option macaddr '00:11:22:33:44:33'
	option ipv6 '0'

config interface 'inic'
	option device 'eth0.3'
	option ipv6 '1'
	option macaddr '00:11:22:33:44:33'
	option proto 'static'
	option ipaddr '10.0.0.4'
	option netmask '255.255.255.0'
	option gateway '10.0.0.0'
	option broadcast '10.0.0.0'

config switch_vlan
	option device 'switch0'
	option vlan '3'
	option vid '3'
	option fid '3'
	option ports '5 6t'

config device 'wlan_dev'
	option name 'eth0.66'

config device 'guest_wlan_dev'
	option name 'eth0.71'

config switch_vlan
	option device 'switch0'
	option vlan '4'
	option vid '66'
	option fid '4'
	option ports '5t 6t'

config switch_vlan
	option device 'switch0'
	option vlan '5'
	option vid '71'
	option fid '5'
	option ports '5t 6t'

/etc/config/firewall:


config defaults
	option input 'ACCEPT'
	option output 'ACCEPT'
	option forward 'REJECT'
	option tcp_syncookies '0'
	option tcp_window_scaling '1'
	option accept_redirects '0'
	option accept_source_route '0'
	option flow_offloading '1'
	option disable_ipv6 '0'
	option synflood_protect '1'
	option drop_invalid '1'

config zone
	option name 'lan'
	option input 'ACCEPT'
	option output 'ACCEPT'
	option forward 'ACCEPT'
	option network 'lan'

config zone
	option name 'wan'
	option output 'ACCEPT'
	option forward 'REJECT'
	option mtu_fix '1'
	option conntrack '1'
	list network 'inic'
	list network 'wan'
	option input 'ACCEPT'

config forwarding
	option src 'lan'
	option dest 'wan'

config rule
	option name 'Allow-DHCP-Renew'
	option src 'wan'
	option proto 'udp'
	option dest_port '68'
	option target 'ACCEPT'
	option family 'ipv4'

config rule
	option name 'Allow-Ping'
	option src 'wan'
	option proto 'icmp'
	option icmp_type 'echo-request'
	option family 'ipv4'
	option target 'ACCEPT'

config rule
	option name 'Allow-IGMP'
	option src 'wan'
	option proto 'igmp'
	option family 'ipv4'
	option target 'ACCEPT'

config rule
	option name 'Allow-DHCPv6'
	option src 'wan'
	option proto 'udp'
	option dest_port '546'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-MLD'
	option src 'wan'
	option proto 'icmp'
	option src_ip 'fe80::/10'
	list icmp_type '130/0'
	list icmp_type '131/0'
	list icmp_type '132/0'
	list icmp_type '143/0'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-ICMPv6-Input'
	option src 'wan'
	option proto 'icmp'
	list icmp_type 'echo-request'
	list icmp_type 'echo-reply'
	list icmp_type 'destination-unreachable'
	list icmp_type 'packet-too-big'
	list icmp_type 'time-exceeded'
	list icmp_type 'bad-header'
	list icmp_type 'unknown-header-type'
	list icmp_type 'router-solicitation'
	list icmp_type 'neighbour-solicitation'
	list icmp_type 'router-advertisement'
	list icmp_type 'neighbour-advertisement'
	option limit '1000/sec'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-ICMPv6-Forward'
	option src 'wan'
	option dest '*'
	option proto 'icmp'
	list icmp_type 'echo-request'
	list icmp_type 'echo-reply'
	list icmp_type 'destination-unreachable'
	list icmp_type 'packet-too-big'
	list icmp_type 'time-exceeded'
	list icmp_type 'bad-header'
	list icmp_type 'unknown-header-type'
	option limit '1000/sec'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-IPSec-ESP'
	option src 'wan'
	option dest 'lan'
	option proto 'esp'
	option target 'ACCEPT'

config rule
	option name 'Allow-ISAKMP'
	option src 'wan'
	option dest 'lan'
	option dest_port '500'
	option proto 'udp'
	option target 'ACCEPT'

config rule
	option name 'Support-UDP-Traceroute'
	option src 'wan'
	option dest_port '33434:33689'
	option proto 'udp'
	option family 'ipv4'
	option target 'REJECT'
	option enabled 'false'

config rule
	option enabled '1'
	option target 'ACCEPT'
	option src 'wan'
	option dest_port '5060'
	option name 'Allow VoIP Handling'
	option proto 'udp'
	option family 'ipv4'
	option dest_ip '192.168.1.1'

config rule
	option enabled '1'
	option target 'ACCEPT'
	option src 'wan'
	option proto 'udp'
	option name 'Allow VoIP Stream'
	option dest_ip '192.168.1.1'
	option dest_port '10000-20000'

config include
	option path '/etc/firewall.user'

config include 'timecontrol'
	option type 'script'
	option path '/var/etc/timecontrol.include'
	option reload '1'

config forwarding
	option src 'wan'
	option dest 'lan'

There are issues with this configuration. But before we can fix them, what version of OpenWrt are you running?

ubus call system board 
root@EasyBOX: ~$ ubus call system board
{
	"kernel": "5.4.203",
	"hostname": "EasyBOX",
	"system": "xRX200 rev 1.2",
	"model": "Easybox 904xDSL",
	"board_name": "arcadyan,vgv952cjw33-e-ir-vpe",
	"release": {
		"distribution": "OpenWrt",
		"version": "21.02",
		"revision": "Easybox 904 xDSL",
		"target": "lantiq/xrx200",
		"description": "OpenWrt 21.02 Easybox 904 xDSL"
	}
}

This is a vendor specific build of OpenWrt. This is not the same as the official OpenWrt firmware.

And from what I can tell, this device is not (yet?) officially supported by OpenWrt. It exists in the table of hardware, but it is clear that it is a work in progress and there is no stable (or even official snapshot) release for this device.

I could take a few guesses here about how to fix your issues, but given that this customized version may behave very differently than the official OpenWrt would, it could make things worse and/or waste a lot of time.

You are best off asking the manufacturer of the device and/or their specific support community.

Thank you for taking the time to talk to me. I'll read deeper into the extensive documentation at OpenWRT, maybe I'll get there.
-------ORIGINAL----------
Danke, dass Sie sich Zeit für mich nehmen. Ich lese mich noch tiefer in die umfangreiche Dokumentation bei OpenWRT ein, vielleicht komme ich so zum Ziel.