DSL on a Fritzbox 3370 does not want to come up

Hi Guys,
i wanted to try openwrt on my Fritzbox 3370 and everything worked fine with flashing and all interfaces are running great. Even wifi was working though i removed the antennas (there also could be there for DECT, i have to check again).
The only thing (until now) which is not working is the DSL connection. The DSL led is shining so something of a "signal" does exist. But when i'm entering my username and password it does always get me the error message: Unknown Error. From my experience i know that an unknown error can only occure because of a version difference, or the communication between the two participants does not work properly.

I was looking all over the topics here in the forum but nothing was working for me. Especially i noticed that i don't get this "tag your WAN port as vlan 7" thing: In my lede openwrt (19.07.4) i can only tag the LAN ports as vlan. Nevertheless i tried to tag it in network config file but no effect.

I tried these firmware for the lantiq chip:

  • vr9-B-dsl.bin from a russian website, someone has cutted out many blobs from different routers. I tried the one from Fritzbox 7490 and from Fritzbox 7412
  • vectoring-vdsl.bin from another source (stupid me has forgotten where i was having it from)

Here is what my current Fritzbox (not the 3370) is saying to me about my connection:

I also don't get why i don't have the possibility to choose G.993.5 in my DSL settings?

I think i've tried every single possibility in the DSL settings, nothing has worked yet. By the way my ISP is 1und1, a Telekom reseller. I know there exists something of a description in "ISP configurations" but either i didn't get it right or it does simply not work for me.
Here's my network config file. It's the last setting i have tried. Remember i was trying almost everything.

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr ''
	option netmask ''

config globals 'globals'
	option ula_prefix 'fd44:3e39:6388::/48'

config atm-bridge 'atm'
	option vpi '1'
	option vci '32'
	option encaps 'llc'
	option payload 'bridged'
	option nameprefix 'dsl'

config dsl 'dsl'
	option ds_snr_offset '0'
	option firmware '/lib/firmware/vectoring-vdsl.bin'
	option annex 'b'

config interface 'lan'
	option type 'bridge'
	option ifname 'eth0.1'
	option proto 'static'
	option ipaddr ''
	option netmask ''
	option ip6assign '60'

config device 'lan_eth0_1_dev'
	option name 'eth0.1'
	option macaddr '08:96:D7:43:8F:E6'

config interface 'wan'
	option ifname 'dsl0'
	option proto 'pppoe'
	option password '*password*'
	option ipv6 'auto'
	option username '1und1/9453-617@online.de'

config device 'wan_dsl0_dev'
	option name 'dsl0'
	option macaddr '08:96:D7:43:8f:e9'

config interface 'wan6'
	option ifname '@wan'
	option proto 'dhcpv6'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '7'
	option ports '0 1 2 4 6t'
	option vid '1'

And here all the infos of my openwrt platform:

ID_LIKE="lede openwrt"
PRETTY_NAME="OpenWrt 19.07.4"
OPENWRT_RELEASE="OpenWrt 19.07.4 r11208-ce6496d796"

I really hope someone can help me out. I would had not created this topic if i would not be sure that i have tried everything. I still have the feeling that the actual problem is a really simple one i oversee the whole time.
Thank You.

Please do not rely on the DSL LED alone. Verify the DSL status and post it here:

  • on the command line: /etc/init.d/dsl_control status
  • or using LuCI: on the main page after logging in

To set up VLAN 7 tagging on WAN, replace dsl0 with dsl0.7 in your configuration.
Using LuCI: Network -> Interfaces -> WAN -> Physical settings -> Interface -> custom -> enter dsl0.7

I suggest to restore the switch configuration to the default. The vlan 7 there has no effect on your DSL connection.

Profile 17a means you need a vectoring enabled modem firmware blob (not just 'something' from some 3rd party site), by default OpenWrt is only allowed to ship with non-vectoring blobs.

Hey thanks for your advice. I will try it soon but at first i have to flash my fritzbox one more time because i accidentally erased something in the network config and now its not reachable anymore.

I know and i did not download 'something' from third party site but there was this hint here in the forum and it looks like what its supposed to be.
But even without this vectoring firmware it should at least connect to the DSLAM or not?

Ehm... the EVA boot loader is gone after openwrt installation right?

To fix a bad configuration without reflashing OpenWrt, try Failsafe mode.
You can also use it to restore the OpenWrt default configuration.

That would surprise me (but I don't own this box).

I was now able to reach the fail safe mode and could reset everything. I will try the other things tomorrow. Thank you.

It works! After a few stupid things i did the actual thing it was to leave everything on "auto" and name the wan "dsl0.7". I know problem is solved now but can anyone explain to me how the interface name affects the dsl connection? Or a maybe give me link for further reading?

Many ISPs require tagged packets on WAN, in case of Deutsche Telekom and its resellers the necessary VLAN ID would be 7 --> so dsl0.7.

In the OpenWrt wiki, this is called driver-level VLANs:

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.