DSA, PPOE, VLAN Tagging, and Centurylink Fiber

I've tried flashing the latest 21.02 update to my WRT32x. It's important because I've had wifi stability problems, and supposedly there are fixes in the update. **

Anyway, A long time ago, I followed this guide to set up PPOE with VLAN tagging to get Centurylink Fiber up and running: Bypassing and removing CenturyLink Fiber Modem

This does not work in 21.02, because of some things I only kind of vaguely understand relating to DSA. From an end user's perspective, network/switch isn't there.

I found this guide here: https://openwrt.org/docs/guide-user/network/dsa/converting-to-dsa and attempted to follow it, but I couldn't make it work. Here is the (censored to preserve my privacy) config I came up with while trying to follow this article:

 config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'Dunno what this is so I censored it'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'lan1'
	list ports 'lan2'
	list ports 'lan3'
	list ports 'lan4'

config bridge-vlan 
	option name 'br0'
	option vlan '1'
	list ports 'lan1:u*'
	list ports 'lan2:u*'
	list ports 'lan3:u*'
	list ports 'lan4:u*'

config bridge-vlan
	option device 'bro'
	option vlan '201'
	list ports 'wan:u*'	

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

config device
	option name 'wan'
	option macaddr 'censored'

config interface 'wan'
	option device 'wan'
	option proto 'pppoe'
	option username 'censored'
	option password 'censored'
	option ipv6 'auto'
	option ifname 'eth1.201'

config interface 'wan6'
	option device 'wan'
	option proto 'dhcpv6'
	option ifname 'eth1.201'

The above config shows up correctly in the web interface, so it is accepted, but I didn't have internet access. Also, if I went to the wan settings, it shows that there was a login error. (I can't remember exactly what it said).

I should also say that I am able to ask this question because of the wrt32x's neat dual boot system. My old config works just fine. (except for wifi stability issues) So, in order to make any changes to my 21.02 config, I'll have to shutdown my network, which makes my wife angry, so I'm trying to minimize that. :slight_smile:

I've also read several other things that may or may not have been related, it's hard to tell.

Anyway, can someone who really understands all this help me out?

** There's also a custom image based on 21.02 that is supposed to improve wifi stability even further, but I'd like to get the official image working first, and this is off topic. :slight_smile:

PS: I did all this with vi and SSH, because I couldn't quite unpack the Instructions found in the converting-to-dsa guide. This means that I even entered my centurylink login credentials by directly editing the /etc/config/network file. Not sure if that matters.

One remark is that option ifname is not used in DSA config anymore. So in wan ineterface you should use bro device and not the option ifname 'eth1.201' , although I don't see the reason for creating a bridge for wan interface.
Also it is my understanding that vlan201 must be tagged and you have configured it as untagged.

There are several mistakes in what you have posted. Also you're trying to do it the hard way. To add a tag to the wan packets for the modem does not require going fully to bridge-vlans.

Reset to the default 21.02 configuration and change the wan option device from 'wan' to 'wan.201'. Configure ppp as usual. This should be all that is needed.

3 Likes

@mk24's simple one line fix did it. I really made that hard on myself. Thanks guys! It appears I have a working 21.02 router!

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.