Dreaded "Unknown error (USER_REQUEST)" during PPPoE connection (WAN) [OpenWRT 23.05.0-rc2]

I have been fighting with this problem for a long time. It transcends OpenWRT versions (since at least 18.06, and now in 23.05-rc2) and connection type (aDSL, vDSL), and possibly other parameters (ISP configurations etc.). The problem is:

Once I set the ISP provided modem router to bridged mode, and try to make the PPP connection through my OpenWRT router, I INTERMITTENTLY get this error:

(I have removed the MACs)

It doesn't ALWAYS happen, and it SOMETIMES will go away after countless restarts or reboots of the router (I don't know why).

I see some people are getting the same problem. Suggestions were:

  1. Discover the VLAN the ISP's modem is using, and use a "custom" device like so: eth1.[VLAN ID].
  2. Set LCP echo failure threshold = 2, & LCP echo interval = 5
  3. Discover the PPPoE Host-Uniq tag (hex), and set the appropriate value.

BTW I am using the correct PAP/CHAP username & password even though it doesn't seem to matter (I have had successful connections using dummy credentials in these fields).

I implemented solutions (1), (2), and set a permanent Host-Uniq tag to 'b33f0000' (hehe), because I have NO idea how to get the actual Host-Uniq tag from my ISP's device. My VLAN ID was set to 835, as far as I can tell from the ISP's modem-router settings, so my custom device was: eth1.835

I still couldn't for the life of me get the PPPoE connection to work in OpenWRT. Rebooted everything, waited, restarted interfaces etc, nothing worked. Then I set the device back to "eth1" (which is the interface for OpenWRT's WAN port), and it WORKED! Now I am also getting an IPv6 WAN Virtual dynamic interface (couldn't care less, but whatever).

What on earth is going on? How can I solve this problem once and for all? How can I get the actual Host-Uniq tag from my ISP's router? Now I am afraid to reboot the OpenWRT router again, in order not to face this issue.