Double NAT'ed from ISP. Modem/Router needs to be a simple modem

My parent's ISP provided them with an Arris TG2472G. This is a multifunction device (Voice over IP + WiFi + Routing). Right now I am stuck in a double NAT situation with my OpenWrt firewall/router BEHIND this thing. I want have the Arris function solely as a modem using the OpenWRT device for the WiFi/routing/firewall.

I see two potential options in their web GUI:

  1. Routing Enabled under Basic Settings
  2. NAT mode under LAN settings

I am think I need to switch it to 'bridge' mode to achieve this... any thoughts are welcome.

Here are screenshots of #1 and #2

It seems to be the right choice.

What about 'routing enabled'?

this is not the mode you're looking for

1 Like

Unchecking Routing Enabled on the first page should set up as you want. Most of the other options will disappear. You can always re-check it or use the reset button on the back if necessary.

1 Like

I agree with all the previous comments -- bridge mode / disabling the routing enabled feature is likely the right setting.

That said, the other option to look for (if those don't work) is to see if the combo modem+router device has user settings for 'static routes' -- if so, that will enable you to remove a layer of NAT by doing symmetric routing.

1 Like

Call the ISP and tell them to put it in Bridge mode. Most ISP that issue the Arris TG2472G hide the management console behind their password, sell additional services to manage the Wifi on these systems and the only way one can see these management pages it to do a factory reset.

1 Like

Well, switching to bridge mode also unchecked routing automatically. The OpenWRT device is routing traffic and serving wireless to devices behind it BUT I cannot ssh into a Linux box on that network from outside that network. It is behaving as if the Arris device is not allowing traffic in.

I tried disabling the firewall on the Arris but that did not help. When I pull up a client list, it does not show my OpenWRT device. Any suggestions?

EDIT: the issue was that the ISP assigned an external IP to the modem and a separate external IP to the router behind it.

Do you have a public IP address on your OpenWrt router WAN interface?

The previous sentence indicates that you have exactly what you wanted from OP. The Modem has been configured; and now your equipment (OpenWrt) is in charge of all router tasks.

Your initial request is Self Solved.

You now own the administration rights, privilege's and responsibility to manage, learn and build out the OpenWrt userland.

1 Like

This ISP is doing some really odd stuff. The modem is indeed in gateway mode. It has its own IP external IP address showing up on the WAN Setup page. My OpenWRT device has a different IP address on it's WAN interface which is set to DHCP. Something is assigning it an IP that is different from the modem.

Modem = x.y.59.170
OpenWRT device = x.y.2.30

x and y in my lines above are the same number for both devices, I am just using the variable to keep the public IP out of the forum post.

  1. Is some setting on the Arris modem responsible for this behavior?
  2. If not, is the ISP responsible for this behavior?

If those values are RFC1918 (i.e. 192.168, 10.x, or 172.16 - 172.31), you don't need to redact the info... those are not publicly routable IP addresses.

Sorry, these are not the internal IP addresses, they are external. I have two separate WAN IP addresses.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.