Does WIFI 5 GHz work on TP-Link Archer C7 AC1750 with the latest OpenWrt build?

Hi everyone,

I'd like to share the experience I had last week.

I was a heavy OpenWRT user a couple of years back with the TP Link router. However with moving to a new flat I got a new Internet Service Provider. My new ISP's modem was also a router with with a support for both 2.4 GHz and 5 GHz WIFI, so I started using that instead of my own router. All worked will until more and more devices started connecting to the WIFI (vacuum cleaner, printer, smart light switches, etc.). I practically had to turn off and turn on the modem every other day.

That's when I decided to buy a TP-Link Archer C7 AC1750 and install OpenWRT on it. Bought it and installed the latest OpwnWRT (19.07.1). Unfortunately 5 GHz WIFI was not working. :frowning: as the interface didn't came up. Across forum I've read that it might be related to hostapd being upgraded from 2.7 to 2.9, and the country settings. So I changed my country back to default and rebooted my router, but no luck. :frowning: I tried a couple of other things (downgrading ath10k packages), but nothing helped.

This is when I decided to go back to the original TP-Link firmware. So I downloaded that and tried to upload it via the OpenWRT firmware, but I got a warning: "Image metadata not found". Then I tried it via ssh with the sysupgrade -v command, but the same result. Then I did a mtd -r write firmware.bin linux. So the original TP Link firmware downloaded from TP Link didn't have the boot text in its name, so I did NOT strip the first n bytes before using mtd. That command completed, however it bricked my router. Luckily I was able to salvage it with the TFTP solution.

I'd like to give OpenWRT another go, because I might have used a DFS channel and that's why the 5 GHz WIFI was not coming up. However before I do that I'd like to ask a couple of questions:

  1. Does the latest OpenWRT work on Archer C7 (more specifically does the 5 GHz WIFI work)?
  2. Is it worth installing OpenWRT nowadays (will I get a better WIFI performance than with the stock TP Link firmware)?
  3. If 5 GHz WIFI does work, what settings do I need? E.g.: default country, auto channel selection, channel width, etc?
  4. If something would not go as expected, what's the correct procedure of reinstalling the original TP Link firmware again? I've read on some forums that sysupgrade might be buggy (some memory issues maybe), what's the situation nowadays with the stripped non-stripped firmwares, etc.

Oh, my router is TP-Link Archer C7 AC1750 V5.

I also have an Acrher C7 V5 which is on 19.07.1. It is setup as a WDS-bridge over 5 GHz to my AP (Netgear R7800). This setup works very stable and reliable.
The C7 is link to the 5 Ghz channel of the R7800 (i think it's channel 40) which should be DFS free.
So to answer your questions:

  1. Yes it definetly works
  2. Someone else with more experience on this matter should answer this
  3. Look for a DFS free channel if thats a problem (BTW the country code I used is US, standard width)
  4. see 2.

Hope this helps.

PS: I replaced the -CT wifi drivers with the standard ones.

Good day. Just installed 19.07.1 on my Archer A7 v5 (which is supposed to be the same inside) and had no issues with 5.8GHz. As stated elsewhere if there is no load on the radio it will show no power output but that is normal. Did your 2.4GHz radio seem to work?

Good luck.

Thanks @Jack007.

Can you please list what drivers did you replace exactly so I can follow your pattern?


Just uninstall (luci-system-software):

  • kmod-ath10k-ct
  • ath10k-firmware-qca988x-ct

and install:

  • kmod-ath10k
  • ath10k-firmware-qca988x

followed by a reboot.

I have a similar/correlated problem. So the problem is on the C7 (v5) ?

I can confirm the situation described by OP. My router is an Archer C7 V5 running 19.07.1. No problems with the 2.4GHz radio, but 5GHz is not working. There are no error messages in Luci, but the SSID never shows up and clients cannot connect. I replaced kmod-ath10k-ct and ath10k-firmware-qca988x-ct with kmod-ath10k and ath10k-firmware-qca988x. Didn't help.

Did you try to set the country to default and the channel to auto? If not, can you please try that and let me know whether it works or not?
Also by replacing the drivers I assume you mean deleting the current drivers, installing the non-ct version, and rebooting the router, correct?

Yes, I had set the country to default, the channel to auto, replaced the drivers and rebooted.

In Luci, radio0 "Qualcomm Atheros QCA9880 802.11nac" shows the message "Device is not active".

I've done some testing on a V4. The default install of firmware-ct and ath10k-ct does not work. Replacing with ath10k-ct-smallbuffers will work, as does replacing both the firmware and kmod with non-ct. This is with country set to US and a single AP operating on channel 124 with 20 MHz bandwidth (VHT20). 124 is a DFS channel in the US.

@whyfi could you post the parts of the system log related to wifi failing? Attempt to re-start wifi this should cause the errors to be logged at the end.

This is the error message related to radio0: HOSTAPD_START_FAILED

Sat Feb 15 12:40:19 2020 daemon.notice netifd: radio0 (2298): WARNING (wireless_add_process): executable path /usr/sbin/wpad does not match process 2242 path ()
Sat Feb 15 12:40:19 2020 daemon.notice netifd: radio0 (2298): Device setup failed: HOSTAPD_START_FAILED

19.07.1 doesn't seem very stable based on the above. :frowning:

How about 18.06.7 ar71xx? Did anyone use that? What are the major differences between 18.06.7 and 19.07.1?

Also, does anyone know about a safe way to return to the stock TP-Link firmware from OpenWRT?

Please use the forum search or open a new topic for this question.

I tried with both 19.07.0 and 19.07.1, neither works.

Here is the full syslog extract showing the errors:

Sun Feb 16 19:44:31 2020 daemon.err hostapd: Configuration file: /var/run/hostapd-phy0.conf
Sun Feb 16 19:44:32 2020 kern.warn kernel: [93452.335325] ath10k_pci 0000:00:00.0: pdev param 0 not supported by firmware
Sun Feb 16 19:44:32 2020 daemon.notice hostapd: wlan0: INTERFACE-ENABLED
Sun Feb 16 19:44:32 2020 kernel: [93452.355599] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
Sun Feb 16 19:44:32 2020 daemon.notice hostapd: wlan0: INTERFACE-DISABLED
Sun Feb 16 19:44:32 2020 daemon.err hostapd: nl80211: Could not configure driver mode
Sun Feb 16 19:44:32 2020 daemon.notice hostapd: nl80211: deinit ifname=wlan0 disabled_11b_rates=0
Sun Feb 16 19:44:32 2020 daemon.err hostapd: nl80211 driver initialization failed.
Sun Feb 16 19:44:32 2020 daemon.notice hostapd: wlan0: interface state UNINITIALIZED->DISABLED
Sun Feb 16 19:44:32 2020 daemon.notice hostapd: wlan0: AP-DISABLED
Sun Feb 16 19:44:32 2020 daemon.notice hostapd: wlan0: CTRL-EVENT-TERMINATING
Sun Feb 16 19:44:32 2020 daemon.err hostapd: hostapd_free_hapd_data: Interface wlan0 wasn't started
Sun Feb 16 19:44:32 2020 daemon.notice netifd: radio0 (10812): WARNING (wireless_add_process): executable path /usr/sbin/wpad does not match process 2790 path ()
Sun Feb 16 19:44:32 2020 daemon.notice netifd: radio0 (10812): Device setup failed: HOSTAPD_START_FAILED

My router is TP-Link Archer C7 v4. I tried the 3 ath10k firmwares and modules. I confirm the 5Ghz is not usable despite many attempts. OpenWrt 19.07.1.
I am ready to run some experiments if it may help.
Thank you - Regards

On Archer A7 v5 (should be same as C7 v5) 5GHz works for me after:

opkg update && \
  opkg remove wpad-basic ath10k-firmware-qca988x-ct && \
  opkg install wpad-openssl ath10k-firmware-qca988x-ct-htt

wpad-openssl is to enable fast roaming, 5Ghz works with wpad-basic, see OpenWrt 19.07.0 first stable release

Which version of Archer C7? There are 4 different versions I know of. I runt Archer C7 v2 and 5GHz works fine with 19.07.1.


According to this info wpad-basic contains 802.11r support already? is wpad-openssl really needed for roaming? (802.11r is fast roaming)

It works OK on my C7V4, after swapping kmod-ath10k-ct to kmod-ath10k-ct-smallbuffers. Still running the ath10k-firmware-qca988x-ct.

Mine is a very basic wireless config running a single AP (non-WDS), psk2 encryption, country US and channel 124. If you're having trouble start by cutting the config down to a simple single AP.

I don't know for sure if wpad-basic supports fast roaming.
wpad-openssl comes from 802.11r (Fast-Roaming) in LUCI, but it's for older openwrt and talks about replacing wpad-mini with wpad