Dnsmasq filter_aaaa '1' not working - Still NOT filtering out ipv6 results

I noticed an option in Openwrt 22.03.5 LUCI to filter ipv6 results in dnsmasq option filter_aaaa '1'. It had no effect as ipv6 entries were still showing up. Then I tried to force this option by adding the line filter-AAAA in /etc/dnsmasq.conf which coincides with the dnsmasq option introduced in version 2.86. Doing this results in "bad option at line xxx" error in the log and dnsmasq fails. Has the ipv6 filtering been impletemented in openwrt dnsmasq yet? I've been looking for this capability for years as it would greatly speed up my dns resolutions where devices/apps might try to resolve ipv6 first (which I havent enabled yet).

This is on both of my routers: Netgear R6700 v2 on OpenWrt 22.03.5 and Linksys WRT1900ACS on 22.03.2

This newer feature only exists in master/snapshots and is not available in the 22.03.* releases.


I was not even thinking of the snapshots before asking so thank you. Hopefully we'll seen in stable release soon.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.