Dnsmasq and ddns-scripts

Hello all,
I'm fairly new to Lede. Recently moved from dd-wrt.

I'm having a problem with using dnsmasq as my dns cache and ddns-scripts.
The problem is that in order for ddns-scripts to update my domain it needs to do a dns lookup of the domain but because of dnsmasq caching it gets the old IP address. I don't want to disable caching and I also want internal LAN clients to get the internal private IP address of the server instead of the external public address.

Is it possible to configure ddns-scripts to bypass dnsmasq?

Configure ddns-scripts to use a different DNS-server (option dns_server) i.e. / google-public-dns-a.google.com
To force your local clients to use the local address configure a host entry inside dnsmasq.

Thank you so much @chris5560. That worked beautifully :slight_smile: