DLink DIR-853 A3

HI all,

First of all the big disclaimer

FLASHING YOUR DEVICE WITH UNSUPPORTED FIRMWARE CAN BRICK IT. I AM NOT RESPONSIBLE NOR IS OPENWRT IF THE PROCEDURE BRICKS YOUR DEVICE

Now this is out of the way, I will no longer compile padavan for the Dlink DIR-853 A3. Instead the focus will be on openwrt. This is due to the face that we are in their forum :sweat_smile: plus the padavan source code I used has had only a few updates in the last few months (or even a year) while openwrt has several commits a day.

Also this will let your downlaod any package from the massive openwrt repository. you can use Luci in the software section.

The only issue at the moment is that the wireless file needs to be edited manually. Using luci with dbdc does not work correctly. I am attaching a sample after this post to which you can use from ssh to edit /etc/config/wireless and change it to your needs.
Please make sure you use all the options are the router might hang if not (it should be recoverable with the reset button).

There will be 2 procedures here. One (the easy one) will be for people on the stock firmware. The second one will be for people already on padavan.

STOCK FIRMWARE:
Downlaod the following file and upload from the web interface. Please check before flashing the sha256sum which should be the one below. Users on padavan please do not attempt to flash this on your device (as it is encrypted). It can potentially brick your device although the router should be able to recover.

4a288a97d30ab338ad2d3583e77d5f6b4cafc113ac27347a990e0a4ce44aef16  openwrt-21.02.0-rc2-ramips-mt7621-dlink_dir-853-a3-squashfs-factory-enc.bin

PADAVAN
For padavan please download the unencrypted file below and check the sha256sum. Use scp ro copy the file to the router in the /tmp folder. Another option would be to use a fat32 formatted usb stick and copy the file to it. Then plug the USB into the router and use mount to check where it is mounted.

fa669f0f2ea6b10d8713543a7f02258e4eee7b05bfa455fda90964613e156425  openwrt-21.02.0-rc2-ramips-mt7621-dlink_dir-853-a3-squashfs-factory.bin

You can then copy the file to the /tmp folder. for there use the following commands.

cd /tmp
mtd_write erase Kernel
mtd_write erase Config
mtd_write erase Storage
mtd_write write openwrt-21.02.0-rc2-ramips-mt7621-dlink_dir-853-a3-squashfs-factory.bin Kernel

optionsally you can check that the flash is correct with the following command. in theory you should get the same result (since we are deleting the partition before flashing.

 sha256sum /dev/mtd3
35ae5f899498707c62fcd122a81259936ed05813de16e9d47e54bd2f506d80df  /dev/mtd3
1 Like

This is a sample wireless config. You can adapt it to your needs. you can check the link for more details,

config wifi-device 'radio0'
        option type 'mac80211'
        option phy 'phy0'
        option htmode 'HT40'
        option serialize '1'
        option country 'AE'
        option cell_density '0'
        option hwmode '11g'
        option channel '1'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ssid 'test2'
        option encryption 'wpa2+psk'
        option key 'wifipassword'

config wifi-device 'radio1'
        option type 'mac80211'
        option phy 'phy1'
        option htmode 'VHT80'
        option serialize '1'
        option country 'AE'
        option cell_density '0'
        option hwmode '11a'
        option channel '40'

config wifi-iface 'default_radio1'
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option ssid 'test5'
        option encryption 'wpa2+psk'
        option key 'wifipassword'

If anyone decides to use the firmware please report back. I just need a few confirmations that it is working fine so I can send a new pull request for the official tree.

Hi @kar200,

Thank you for creating Openwrt Image for DIT-853 A3,
I have decided to use it because PADAVAN image doesn't work properly as RADIUS client, however some of challenges I have for new image,
It is required too much efforts to configure wireless in order to work properly, speed tested is lower than factory image (886 for 5G and 144 MB for 2.4G), additional configuration of wireless for RADIUS client doesn't work at all, I have already removed basic wpad and installed full package, I don't know if you can help me to reconfigure Router to enable RADIUS client.
Thank you for your kind cooperation.

Hi @samt,

I don't think I sould be much help with radius as I havent used it myself. I can only point you towards the main config of the openwrt wiki.

As for the performance it is normal that you would get better speed on the MTK drivers since they are the official ones (IMHO with lot less flexibilty). Althouh the 886 is the hardware limit I am impressed that you managed to pull that much. What did you use for testing? Iperf3?

You might get luckier searching the forum for other users using Radius for the wireless and maybe there are some more options to play with to get it working.

Hi Kar200,

I'm using inSSIDerOffice tools to measure Antenna bit rate, and not using speed test tool for upload and download,

By the way your image is working perfect on DIR-853 A3, and strongly recommended staff to use it, and I'll explain why I spent too much time for configure it, what is problem and how to sort it out.

Actually I have installed Freeradius 3.0 on Ubuntu Linux Server as Central Authentication Server , and my plan to integrate Router with such Server as RADIUS client,

In order to do this and as per guideline of Openwrt Forum (https://openwrt.org/docs/guide-user/network/wifi/freeradius), I have to remove preinstalled wpad-basic-wolfssl package and install wpad full package.

Once wpad-basic-wolfssl uninstalled, wireless signal disappeared completely (you can test it yourself), in addition to can't install wpad full package properly, due to getting an error that a dependency file called libubus20210603 is not available in any repository (even you can't reinstall wpad-basic-wolfssl), and I have to do hard reset in order to wireless signal to be available again.

based on your recommendation I have searched in Forum, and found that we can't install many packages due to that file and it is a bug in current 21.02.0-rc2 firmware version as per such link (Can't install dnsmasq-full, missing libubus20210603)

So the only solution is to use Use the 21.02 snapshot firmware builds, or the rc3 builds as per recommendation, and can't use one of those options without getting your help.

So you are the only one can build a custom firmware for DIR-853 router based on one of above options or both.

Thank you for your kind cooperation.

OK I did not even see that RC3 iss out. I will need to compile a new one and test the upgrade first and then I will share it here. Unfortunately I won't have it before tomorrow.

If you want a specific image with specific packages just send me a PM with the details and I will be happy to help you with it.

Hi again,

Here is the link for RC3. Please only update it from the web interface (Luci) from openwrt.

You should also refrain from keeping the config. I have changed one setting for the wireless led lights (nothing major but just in case).

Thank you,

I'm going to test it and update you

Wow it is working flawlessly right now and integrated with RADIUS Server very well
Thank you for your kind support,

Next step I'm going to install Openwrt firmware on another same model router which has original firmware, and then connect them together as mesh,

You will be updated once it is completed.

1 Like

Hi @kar200
Thanks for your efforts
I flashed Openwrt but not able to have wireless working
I believe i should edit the "/etc/config/wireless" with values posted earlier
Can you share please the way to edit through SSH? what command to use?
It sounds stupid question but i am not exper in linux

Hi @amin300,

Yes that's correct. The easiest way for you (if you ware using windows) is to use winscp.
Once you install it just choose ssh as the protocol and 192.168.1.1 as the ip address (unless you changed it).

Last time I used it there was a built in editor so you could right click - edit and just change the values and save.

You then reboot the router and test.

https://winscp.net/eng/download.php

Thanks @kar200 for quick reply and support
I used winscp and edited wireless file but after reboot, old configs are back and new edited ones are not saved
Did this serveral times!!
Any idea why?

Hi @amin300,

Can you try saving the file and then try refreshing the text editor and see if it saves your changes sometimes the text editor takes time to save the file.

1 Like

thank you so much. it wokrks now :slight_smile:

Hi All,
Apologies for the diversion but where is the best place to discuss DIR-853-A1? There was another thread (Support for D-Link DIR-853) but would need to be "revived".

The best way is to create a new thread like this one.

The thread you linked is not for the A1 but the R1 which is already supported (don't use that one though).

I don't this it will be hard to add by the way. Again don't use the A3 or R1 as they are all different and you might brick your device.

1 Like

Hi Kar,

I was previously using your Padavan build on my DIR-853 A3, and I wanted to change it to the new OpenWrt build now that I heard the news.

I flashed the Padavan-to-OpenWrt build according to your instructions. However, I made the really silly mistake of repeating the flashing commands, so I accidentally flashed the Padavan-to-OpenWrt build after the OpenWrt flash. Consequently, I am now unable to connect to my router via SSH.

I understand that you're not responsible for me bricking my device, but is there a possibility I can recover from this mistake?


Edit: I spoke too soon. I rebooted my router, and I'm able to connect to the LuCI interface. But just to be sure, did that second flash affect my router in any bad way?

Hi @marwan,

I believe this won't affect your router in any substantial way as flashing openwrt again is just like flashing from one firmware to another, but is just redundant. (The only possible way I can imagine this could affect the router is just wearing out the NAND, but NANDs have quite the endurance so I don't think it'll be an issue.)

Btw just a note, how were you able to flash openwrt twice? since mtd_write command doesn't work for me on openwrt

Hi @marwan,

As @throwaway pointed out if you did it twice it does not matter. It is just writing the same date over it.

You can now use the rc3 if you want by flashing it from the web interface. It should work better than rc2.

@throwaway the mtd_write and mtd command seems to be the same (although the openwrt one has more options) and they are just named differently. I think what @marwan was reffering to is just flashing twice during the same ssh session.

@tmomas Do I need to open a new thread to have all the important info at the top? I feel this thread is not very efficient for the users and they have to scroll quite a bit to get the information needed.

1 Like