Dlink DIR-853 A2 support

Hi all. I see that there is a topic about this model Dir 853 a2 - For Developers - OpenWrt Forum, but it is closed for new replies and the downloads are expired, and it still doesn't seem to be supported, so I would like to ask if this could be worked on and added to official supported devices. I'm a programmer without much experience in soldering or whatever (neither what is required to make OpenWRT work), but I'm very curious and interested in making this a possible improvement for the project, just let me know how can I help.

@kar200 as you were the one the were able to help op there, can you please share the file or code you had there?


Hi daileon
cant you go into the web interface of the router
and tell me what the model number is shown in there ?

Hi @daileon ,

AFAIK The DIR-853 A1 and A2 are identical (@Lucky1 can confirm maybe?). On the Dlink download page they actually have a single firmware file for both.

If you have the A2 model you should be able to flash the A1 version (maybe not from the web interface) but at least from the recovery mode.

It should be availble on the download for openwrt.

As for adding support have a look at this pull request. It shouldn't be hard to add the A2.


1 Like

this is what I'm thinking "same as the DIR-2060-A1/A2"
but no one has been able to tell me what the firmware thinks it is yet ?
the last person just replied with the external sticker

I would test this via upload the DIR-853-A1 firmware via the normal
update web interface "most protection against invalid firmware"
if that's is successful it's expecting the DIR-853-A1 header
and to use the A1 openwrt files

Good point. I would say maybe A1? Looking at the download page from Dlink the firmware the file name is A1

Also after decrypting the firmware file and looking at the header it shows A1 only

00000000  27 05 19 56 b5 f8 9f 50  5c dd 2f bb 00 d2 5b c6  |'..V...P\./...[.|
00000010  81 00 10 00 81 60 d7 80  57 56 1b 4a 05 05 02 03  |.....`..WV.J....|
00000020  4c 69 6e 75 78 20 4b 65  72 6e 65 6c 20 49 6d 61  |Linux Kernel Ima|
00000030  67 65 00 00 00 00 00 00  00 00 00 00 00 00 00 00  |ge..............|
00000040  44 49 52 2d 38 35 33 00  00 00 00 00 00 00 00 00  |DIR-853.........|
00000050  00 00 00 00 00 00 00 00  00 00 00 00 00 00 00 00  |................|
00000080  56 31 2e 31 30 42 30 34  00 00 00 00 00 00 00 00  |V1.10B04........|
00000090  41 31 00 00 00 00 00 00  00 00 00 00 00 00 00 00  |A1..............|
000000a0  5d 00 00 00 02 c0 99 24  01 00 00 00 00 00 00 6f  |]......$.......o|

I would assume this would make the A1 works on both devices wouldn't?

EDIT: I just realised that the commit contains an encrypted factory for the V1 with a downalod link. Maybe this can be used to upgrade from the web interface


my local dlink has no mentions of a2 or a3 for that matter
but looks like you found what I was expecting :slight_smile:

1 Like

Hi guys! Sorry the delay, it was not intentional. I was just able to check your suggestions and I got a crazy thing here. If I went to my local (Brazil) D-Link site, I would only see FW v1.1 and that matches current installed version on the router.

Checking web UI it displays "DIR-853 HW: A2, FW 1.10"

However, the firmware file says A1, so I took a shot and downloaded A1 FW 1.2 and tried to update via web UI and...

Well, now I can try OpenWRT for A1 and hopefully it will work.


I am assuming it will work. I am assuming the A2 reference on the web interface is read from one of the partitions (cannot recall which one) which holds the device info (Like serial number ...etc).

Did it work?

Hi Victor, it worked indeed. I ended up having other issues not related to the HW version itself, but the FW, however it is very useful to have OpenWRT on the device, way better than DLink, of course.

1 Like