Dlink Dir-2640 cant install openwrt

As per documentation and user guide i switched dir-2640 to recovery mode by pressing reset+power light starts blinking orange.
Changed to static address with 24 mask
Fired up firefox on ubuntu and opened
Chose right openwrt factory bin file which i renamed to dink-factory.bin and hit upload button.
After some time it says connection timed out.

Tried same procedure with private window.
Tried with curl 8.5.0 with attributes v i and F firmware=@dlink-factory.bin it showed that it uploaded.

Waited 5 mins for it to reboot it didnt. Did power on/off changed static address to mask 24.
Tried pinging and opening with browser nothing.
Lights on the router are blue now.

Stock firmware isnt in place the only way i can get anything in browser is via dlink recovery mode.

Any suggestions?

Did you follow these instructions:

Specifically, did you use a browser to do this? I'm curious why you used curl instead of a regular browser.

(this page is linked from the device's toh page)

In the link you just provided which i followed before opening a new thread was written if all methods (with different browsers) failed try curl method which i did.

curl -v -i -F firmware=@dlink-factory.bin

But did the browsers fail first? (you didn't mention if this was the case)

They simply timed out i would call it fail.
Right after hitting upload button in recovery page there is no feedback of whats happening and after some time page refreshes to connection timed out.

ok... sorry, I think I missed that part of your description.

Ok... so what exact file did you download?


And renamed it to dlink-factory.bin

I tried with absolute and relative paths in curl for -F option.

The git commit shows the firmware being sent in quotes:

    curl -v -i -F "firmware=@file.bin"

Did you do that?

1 Like

Quotes in curl are needed only if the string contains spaces or special characters not to cause expansion/globbing. In my case as i renamed the firmware to dlink-factory.bin there is no need for quotes.

Regardless i will try that now and will come with update if that works.

yeah, I'm not sure if it's required, but worth trying.

I think the key thing right now is for the recover page to come up again in general. If that doesn't come up, serial may be required to figure out what is going on.

Recover page is always coming i have no issues with it.

Same issue. I decide to upload images to be very clear of whats going on.

After rebooting (turning power off and on) I can get into webui of dlink official firmware no openwrt nothing.

Will it accept the vendor's factory firmware? Not that it is required, but this could be a useful test to make sure the process is not resulting in a corrupted file upload.


Just restarted router after official dlink firmware upgrade.

So stock firmware works ok.

I wonder if something might be wrong with the 23.05 factory images.

How about 21.02 (the first supported release)... see if it will work with that version's factory image. If it does, you can then use that as a springboard to get to 23.05 via sysupgrade.

I even verified with sha256sum and its not corrupted .

Will try 21.02

I wasn't suggesting that the file itself was corrupted (although it is always a good thing that you verified it)... I was thinking that it could have been a corruption during the upload to the router itself.

fingers crossed.

Same issue. Version 21.02.0

Orange light is blinking and when i restart its going back to stock dlink firmware.

Are you doing the restart yourself or is it automatically restarting? Maybe wait longer if it is a manual restart - say 10 mins.

I left it on didnt touch anything now after trying 21.02.0 second time. It has whole night reboot by itself. In the morning will check and will post here. Thanks for support anyways.

Yes im doing restart by myself but never waited 10mins. May be 5 max.

After few hours it didnt reboot by itself. Reboot manually its still on stock firmware.

Im stuck… followed all troubleshooting available in documentation no luck.