DL-WRX36 version mismatch for libnl-tiny

I installed the latest snapshot on a fresh device, but luci installation fails with a version mismatch for libnl-tiny. I tried opkg update && opkg install luci. How are you guys installing Luci? thanks

This is what I did when I encountered that issue today:

# Upload firmware
scp firmware_image.bin root@openwrt.lan:/tmp
# Flash firmware
sysupgrade -v /tmp/firmware_image.bin

After the reboot, ssh into openwrt router again and install luci

opkg update; opkg install luci


Or just add the package(s) to the image, using the online image builder.

This issue isn't wrx36 specific.


Thanks for the replies.

What specific file is firmware_image.bin? People were talking about a sysupgrade bug earlier in the thread, but this works OK?

I can't find anything in the link above referencing version mismatches attempting to install luci on a snapshot, or solving the problem with an online image builder. This must be a common problem. Are there some simple instructions somebody can point me toward? Shouldn't these instructions be visible?


edit: I booted initramfs from usb, reflashed r22489 ubi same as I did initially, tried installing luci again, and it worked this time. I'm really confused.

It is a temporary problem due to package version bumps.

See e.g. these discussions.

only the latest's easily available, at any point in time.

you didn't post the error message, but this is usually the reason (taken from the link).

true, that could be added to the page.

that's why I wrote it wasn't device specific.

that would be the link you said was irrelevant.
there's also https://openwrt.org/docs/guide-quick-start/developmentinstallation (which points to https://openwrt.org/docs/guide-user/luci/luci.essentials)
and google.

Thank-you hnyman and frollic, your explanation and help is much appreciated.