Diy travel router

I'm trying to set up a travel router. I followed all the guides and I cannot get my Router to broadcast or sign into a wifi network. I'm using a system on chip board that is supported. I found wifi adapters using List provided on open w r t hardware. I can see Wi-Fi networks and I try to connect to them type in my password But it's like something's missing. But i'm completely unable to get it to broadcast a wifi Hotspot everdough my usb adapters are capable of doing it. I can post screenshots and everything if somebody can help me out. This is my first time trying to use openwrt.

Welcome to our forum Sean. Please post screenshots and photos of your setup.

Good luck.


1 Like

The hardware (SBC- and wireless cores) matters, many SBCs ship with brcmfmac wireless, which doesn't support concurrent AP/STA operations.


thank you for the fast replies.
I'm following this guide, at 17:35 in the video he gets it to broadcast wifi. on youtube its Networkchucks
" my SUPER secure Raspberry Pi Router (wifi VPN travel router)"
i don't know what I am doing wrong. i used the same USB commands but I did get some errors I attached a screenshot of the errors. the commands I used are as follows.
opkg install kmod-rt2800-lib kmod-rt2800-usb kmod-rt2x00-lib kmod-rt2xoo-usb kmod-usb-core kmod-usb-uchi kmod-usb-ochi kmod-usb2 usbutils openvpn-openssl luci-app-openvpn

i added photos of the wireless and network configs

i used the list of supported wifi adapters so I'm hoping that this is correct.

Just curious:

What [official] OpenWrt firmware are you running - can you provide the link?

I'm interested in purchasing this board.

i used the link off the table of hardware.

1 Like

Ummmm, odd - this is what I receive from your link:



Also just to be clear, I was asking for the [official] firmware.

sorry no idea why it did that. try this

the Libre computer site does not have a openwrt biuld.

1 Like

you have radio 1 disabled in config. not sure if you are try to make work radio0 or radio1

right now radio0 as an AP, and later use radio1 to connect to the host's wifi. its not showing up in my list of wifi on my phone or PC. i don't know what I'm missing in the wireless config.

Did you set your country code for your radio and put it on a channel compatible with your area?

1 Like

i did not set the country code. but I did set the channel.

You will need to set the country code to rule that out as issue.

1 Like