Divested-WRT: No-nonsense hardened builds for Linksys WRT series

Take a look at https://openwrt.org/docs/guide-user/base-system/uci.

Set up a uci script to update what you need in /etc/config/dhcp to enable internet, opkg update ; opkg install dnscrypt-proxy2, and then revert back to your original /etc/config/dhcp.

dang, that's a bummer.. I keep checking back periodically to see if there has been a fix, but looks like not yet. Still on Davidc502's last build.. tried mainline and divested with no luck as you have experienced. If you stumble on a build or solution that works, please ping me :+1:

New user of Divested-WRT here.

Thanks for Divested -- just what I needed for my WRT1200-AC.

Installation went well. I'm trying to create a dumb access point, following roughly https://openwrt.org/docs/guide-user/network/wifi/dumbap using Luci.

Of course I go off script. On my LAN, I have a DHCP server to allocate IP addresses. So I thought: why allocate a static IP address, just let the WRT1200's WAN port continue to be a DHCP client.

Now: the WRT1200 asks for an IP address (DHCPDISCOVER in the log), my DHCP server gives it one (DHCPOFFER), but the WRT1200 does not accept it and just keeps asking. Every few seconds.

This seems like a bug. Is it expected behaviour?

With no IP address, I cannot get in to reconfigure the WRT1200. I guess that I need to reset it.

The WRT1200 is actually working as an AP.

Thanks for any help/suggestions.

I've been using divested build r17246 on my wrt1900acs for around a month now and it's been rock solid, I had to add openvpn, but apart from that it's the vanilla build from the divested home page.

you should give it a try, it's going to be a lot more secure than an old david build and that's worth the effort IMHO

I'll try out the latest release but having my phone drop connection as adworacz described is pretty baffling and has kept me on an older build.. I haven't gotten around to trying arinc9's workaround though

One thing to note is that @batkung is on a 1900acs, which does use a different WiFi chip than the 3200acm/32x. It seems like the 3200acm/32x are the main units to be effected by dropouts, per this thread: Users needed to test Wi-Fi stability on Linksys WRT3200ACM & WRT32X on OpenWrt 21.02.0-rc4

BUT, there is at least one report of a 1900acs having the same issue, so it's a roll of the dice at this point - Users needed to test Wi-Fi stability on Linksys WRT3200ACM & WRT32X on OpenWrt 21.02.0-rc4 - #90 by petersmith

might have to eventually pick up another router (use a wrt32x myself).. wish mwlwifi had some active development

Agreed - I picked up a r7800 off ebay for pretty cheap ($40-60 USD range), which runs on ath10k, thus better driver development. I've been holding off on switching because I want to keep testing fixes for the WRT3200ACM, but it should be a nice replacement.

yeah.. I mean if it's fine on the older builds it should be fixable. Could be wrong but didn't the last davidc502 builds use the newer firmware (might have been the older one)? Either way if it doesn't work with the downgraded firmware must be something else in the newer builds, then again I'm a dummy with how it all works.

Yea I've thought about that but not interesting in an 8 year old router like the R7800 with issues of its own (NSS stability, some wifi issues, etc.). My WRT32X is working awesome right now on Master snapshots (no wifi 5GHz stalling issues like 21.02-rc has, everything works like SQM cake at 500Mbit, Adblock, USB 3.0, Samba4 at 120 MB/s, 2TB exfat kodi share, etc.).

Going to wait until a high performance WiFi 6 device works on OpenWrt and buy whatever that is. Hopefully once Ath11k is sorted out. (That might be the RAX120 since it's the only one I know of with the IPQ8074 even though it looks sort of ridiculous.)

1 Like

Hello community,
Has anyone run into build errors when using your own config file and the 'make -j16' command lately? I use my own config file and the build would fail with 'make -j16' but succeed with 'make -j1 V=s' which is much slower.


post the errors maybe?

I compiled the master branch last night with -j2. I do remember reading somewhere a note that issues may be encountered when using parallel compilation. I think it may have been about dependencies but don't remember.

I have, but it's mostly because certain config changes require asking interactive questions during the beginning of the build process.

If you just as V=s to your make -jXX command, and then hit enter a few times at the beginning when it asks questions, you'll be fine and able to compile at almost full speeds (some speed is lost just printing logs to the terminal).

In short, if you run into issues with make -j16, just type make -j16 V=s and hit enter a few times when prompted.

I always clean compile with -j24 with no issues, takes 13 minutes.

What unset Kconfig are you running into, I'm not seeing any.

Thanks for the prompt response.
I got these when I ran 'make nconfig'

nn@m142 openwrt]$ make nconfig
tmp/.config-package.in:127845:error: recursive dependency detected!
tmp/.config-package.in:127845:	symbol PACKAGE_ethtool-full depends on PACKAGE_ethtool
tmp/.config-package.in:127832:	symbol PACKAGE_ethtool is selected by PACKAGE_ethtool-full
For a resolution refer to Documentation/kbuild/kconfig-language.rst
subsection "Kconfig recursive dependency limitations"

I ignore this and run 'make -j9' then I get

[nn@m142 openwrt]$ make -j9
make[2]: Entering directory '/home/nn/openwrt/scripts/config'
make[2]: 'conf' is up to date.
make[2]: Leaving directory '/home/nn/openwrt/scripts/config'
time: target/linux/prereq#0.29#0.07#0.37
 make[1] world
 make[2] package/cleanup
 make[2] target/compile
 make[3] -C target/linux compile
    ERROR: target/linux failed to build.
make -r world: build failed. Please re-run make with -j1 V=s or V=sc for a higher verbosity level to see what's going on
make: *** [/home/nn/openwrt/include/toplevel.mk:230: world] Error 1
[nn@m142 openwrt]$ 

I think i has something to do with interactive questions that @adworacz mentioned in his post, because when I run make with -j1 and V=s and press ENTER a few times and the build went OK.

press ENTER a few times and the build went OK.

If you are using an old copy of my patches, you should update them.

Likely this: https://github.com/divestedcg/Divested-WRT/blame/master/patches/0003-kernel-generic-5.10-config-hardening.patch#L37

Also relevant: PureFusion - wrt3200acm, wrt32x, wrt1200ac, wrt1900acs, wrt1900acV1, wrt1900acV2 Builds - #80 by RaZi3L

If you pick my patches, do check them for updates :wink:

1 Like

Thanks! I will try 'make -j9 V=s'

That must be it. I just followed the instructions to update the build and did not re-apply the patches. I will try it now.

Thanks again!