Discovering OpenWrt and MT7688AN with module HLK-7688A

I buy this kit:
Kit HLK-7688A
from:
https://www.aliexpress.com/item/32919001355.html?spm=a2g0o.detail.1000023.13.25b44befli5v3C
MT7688 has: Ram DDR2 128 MB, Flash 32 MB, Cpu frequency 580 MHz
It comes preloaded with OpenWrt 14.07 or plain Linux.
As I don't see anybody using this kit in the forum, I would like to share my very little experience.

The first step was to update the firmware.
According to:
https://docs.labs.mediatek.com/resource/linkit-smart-7688/en/faq
MT7688AN and MT7628AN chips are similar.They said:

The MT7628 series are pin-to-pin compatible with the MT7688 series. However, MT7628 comes with a 2T2R antenna, while MT7688 only supports 1T1R antenna.

So I download this image:
openwrt-19.07.0-ramips-mt76x8-hilink_hlk-7628n-squashfs-sysupgrade.bin

The serial port near the power jack give access to the bootloader at 57600 bauds, using a TTL-USB dongle. Under Windows 7 I use Teraterm. Setup for serial is 8 bit, no parity, 1 bit stop and no flow control.

Then it is easy to upload the new firmware through tftp: I use Tfpd64 under Windows 7 as a Tftp server. I connect one of the Lan port (not the Wan port) of the MT7688AN to the box. It is necessary to annotate the IP that the Dhcp server of the box assign to that port.

When the MT7688AN is booting, press 2 to load the firmware and flash it.

Now, after the reboot I am able to access OpenWrt 19.07.02 on the same serial port.

Next step will be to configure OpenWrt according to my network.

3 Likes

I would now describe how I configure the router network in order to connect it to my existing network.

My network is quite simple: it is connected to the internet through a 'box', as we call in France an adsl modem combined with a router.
An old pc tower, a Raspberry Pi running Libreelec/Kody and an home automation base are physically attached to the box.
Phones, laptops, a printer and some devices based on microcontrollers are connected through wifi.

So I have to connect my new OpenWrt router behind the box as there is still a free port on the lan side.

The box don't allow to easily modify the dhcp parameters, so I modify the configuration of OpenWrt /etc/config/network. As I have access to OpenWrt throught the serial port, I use vi to modify this file:

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fdb0:c1c7:3423::/48'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option ports '6t 4 3 2 1'
	option vlan '1'

config switch_vlan
	option device 'switch0'
	option ports '6t 0'
	option vlan '2'

config interface 'wan'
	option ifname 'eth0.2'
	option proto 'dhcp'
	option macaddr '40:xx:xx:xx:xx:xx'
	option stp '1'

config interface 'lan'
	option type 'bridge'
	option stp '1'
	option proto 'static'
	option ipaddr '192.168.0.1'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option ifname 'eth0.1'
	list dns '8.8.8.8'
	list dns '8.8.4.4'

Now I :

  • connect the wan port of the MT7688AN to the free lan port of box,
  • connect a laptop to a lan port of the MT7688AN ,
  • restart the MT7688A.

Now I have access to LuCI at 192.168.0.1 and I can:

  • set the administrator password,
  • make the first backup of configurations files

Here is a capture of LuCI / Network / Switch:

Note: I made this configuration copying from different sources and honestly do not understand them all, particularly the ones referring to IPv6.
So any comment or correction would be welcome.

1 Like