Disabling DHCP IPv6 server

Hi guys

my ISP does not offer IPv6. Sometimes on my Rapsberry Pi i have issues as it is trying to connect via IPv6 for some reason. How can i completely disable DHCP IPv6 server?

Here is how i tried to disable it:

Howevery somehow, my devices are still getting IPv6. There is no other router/DHCP server in my network.

Any clues guys?

You already disabled it. Your devices have link-local addresses, that can't be "disabled".

Also if you don't get an IPv6 address on WAN, then devices on LAN get nothing except ULA address.

There's no easy way to completely disable IPv6 on OpenWrt:

All the modern OS should prefer to utilize IPv6:

Try to investigate.
Make sure the services listen on both IPv4 and IPv6 and the firewall is configured for the dual-stack mode.

[quote="vgaetera, post:3, topic:42428"]
There's no easy way co completely disable IPv6 on OpenWrt:

There is no need to disable it "completely".
Most likely there is no need to disable it at all.

1 Like

Thanks a lot for you help guys. Especially poiting at "link-local addresses".