Disable IPv6 in OpenWrt - LAN and WAN

Hello OpenWrt community!

I'm looking for some assistance or pointing in the right direction on how I can look to turn off IPv6 on my OpenWrt install, which is essentially an out-of-the-box setup on a Banana Pi R3.

Aside from the many reasons that this support should be on and the direction everyone should be moving which I agree with, I'm looking to understand how I can flip the switch to assist with troubleshooting in some cases where I've come across some issues (Microsoft Teams, long loads on Facebook, etc) and just want to know how I can turn it off and simplify things and gather more information for troubleshooting.

Appreciate it - thank you much!

To disable IPv6:

  • remove the wan6 network interface
  • remove the IPv6 related DHCP server directives (in a default install, it will be all the lines below the IPv4 server line in that particular stanza).
1 Like

Dusable ipv6 sla addresses on neteork devices

Is there a way to remove IPv6 from DHCP server directives through the GUI or something close to it?

Also, is there anything I should be aware of prior to "removing" this - I was hoping more to go along the lines with "tick these off" and re-enabling would just be as simple as "re-ticking" ... if that makes sense! But it sounds like there isn't necessarily something like that with how this is implemented.

I guess I would just like to be aware of how to re-add should I need to or what I should take note of :slight_smile: I suppose it's not a big deal to start over, but for my own knowledge :slight_smile:

Thanks much!

Yes.

Network > Interfaces > Edit lan interface > DHCP Server > IPv6 Settings

Disable RA-Service, DHCPv6-Service, NDP-Proxy, and make sure Designated Master is unchecked.

Network > Interfaces > Edit lan interface > Advanced Settings > 

IPv6 assignment length disabled.

you can basically undo these things fairly easily, and re-add the wan6 interface.

Make a backup before you disable the features and then you can look at the deltas, too.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.