Disable DHCPv6 in Access Point

I have a dd-wrt router (archer C7v4). I also have an Archer A7v5 that I converted to openwrt 22.03.3 today. I use the OpenWRT as an access point.

I have enabled wifi with the similar settings to the dd-wrt router.

I configured the lan interface with a good static ip and I can reach luci at that address.

I first checked the ignore interface on the dhcp tab in the lan interface config. (dhcp.lan.ignore). That seems to work, but the overview status page had several entries in the "Active DCHPv6 Leases" section. That seems wrong (but there is so much about ipv6 I do not know).

I then disabled dnsmasq from the software startup screen and rebooted. I still see one device in that DHCPv6 Leases section (a Chromecast).

Do I need to take any other actions to disable the dhcpv6? Can I leave it on?

Thanks for taking the time to read and respond. I want to learn more and I will. I just am a bit burned out tonight by the long session getting tftpd working to revert the ddwrt firmware.

Don't use the startup to disable this (as it will get re-enabled on the next sysupgrade that way), disable it on the DHCP configuration (file).


I was loosely following the wrong documentation. I was looking at the instructions for disabling dhcp from the bridged AP instructions:

Step 3: Disable dnsmasq
/etc/init.d/dnsmasq disable

I should have been following the dumb AP instructions (these vids are great too):

  1. Use the main router for DHCP (and disable DHCP for the Wireless AP). Same page again, now the DHCP Server tab. Should be at the General Setup sub-tab. (In version 18.06 and earlier of LuCI, no tabs: just scroll down.) Ensure the Ignore interface checkbox is checked.
  2. Disable IPv6 DHCP. Same page, DHCP Server tab again, but click on the IPv6 Settings sub-tab. Set the RA-Service, DHCPv6-Service, and NDP-Proxy dropdowns to disabled.


  1. To save resources on the wireless AP router, disable some now unneeded services. Navigate to System → Startup. Disable the services labeled firewall, dnsmasq and odhcpd. (Perhaps ironically, click Enable to toggle.) Note even though these services are now disabled, after you flash a new image to the device they will be re-enabled. For a more permanent fix see Disable Daemons Persistently.

Spot on advice. Thank you. One of these docs said the same thing. The main piece I was missing is step 9 disabling the ipv6 stuff and that odhcpd is doing ipv6 stuff. I will put disabling the daemon on my todo list.

Take a look:

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.