DIR-860L,B1: Additional storage, USB

Years ago I ran something on this DIR-860LB1 were root was on the USB, some kind of pivotroot. Today I was failing to get a USB3 storage device to add itself to the device tree in /sys. I had installed ohci/uhci and even xhci drivers along with usb2 and usb3, nothing. I'm never concerned with me describing what I've tried and what's happend, I'm obviously never in a position to even understand half of what I've done let alone could try and explain. I always want to know what I should be doing and I usually never get ppl to even attempt to describe that. So I usually think what I'm doing is so advanced so cutting edge that it's beyond whomever is flailing around trying to help me, and knowing that something is beyond one's understanding leads them to take their anger with themselves out on me... not wanting to try and describe something I know next to nothing about.

I've seen that using the USB port will mess with the WiFi, that's scary but otherwise uninteresting until after I start using the WiFi... This did work for at least a few months in that configuration, I think I was using LEDE then.

If I'm not mistaken any device should populate /sys even if these is no associated driver, though I have installed two storage drivers the usual storage and another one that's specific to USB3 devices. I don't believe I needed to do any of this B4 so I'm unsure if this device needed anything special.

Power cycling and re-plugging things hasn't helped.

A while back I was unable to log-into this system then swapped cable modems, removing it at the same time.

Now I've an Espressobin and two internet connections. I wanted to use the Espressobin to mediate internet access, with it's 3 1GB ports. Thus I can no-longer use the Cable Modem as a WiFi AP, being only behind one ISP. I purchased an Atheros AR93xx for the Espressobin, but discovered I couldn't use 5Ghz in AP mode... only Managed. Now I was wanting to resurrect this old AP to bridge things together.

This is requiring a lot of development on the 860L and I quickly ran out of storage.

Aside from using a USB3 storage device for installing applications(root) on this 860L, being able to use this ath9k for the purpose I intended would also work. As would purchasing an AP or full-height mini-PCIe that may better fit my needs.