DIR-645 not bringing up wifi

Hi all
after reading about this: D-Link DIR-645 WiFi interface not maintaining connection I was looking to incorporate my old device into my mesh cloud. But it turns out that with my setup the router fails to bring up its wifi. here is some off the logging:

Sat Dec 25 22:10:17 2021 daemon.err hostapd: Failed to add BSS (BSSID=xxx)
Sat Dec 25 22:10:17 2021 daemon.err hostapd: Interface initialization failed
Sat Dec 25 22:10:17 2021 daemon.notice hostapd: if-lan: interface state COUNTRY_UPDATE->DISABLED
Sat Dec 25 22:10:17 2021 daemon.notice hostapd: if-lan: AP-DISABLED
Sat Dec 25 22:10:17 2021 daemon.err hostapd: if-lan: Unable to setup interface.
Sat Dec 25 22:10:17 2021 daemon.notice hostapd: nl80211: deinit ifname=if-lan disabled_11b_rates=0
Sat Dec 25 22:10:17 2021 kern.info kernel: [   64.653451] device if-lan left promiscuous mode
Sat Dec 25 22:10:17 2021 kern.info kernel: [   64.662814] br-lan: port 3(if-lan) entered disabled state
Sat Dec 25 22:10:17 2021 daemon.notice hostapd: if-lan: CTRL-EVENT-TERMINATING
Sat Dec 25 22:10:17 2021 daemon.err hostapd: hostapd_free_hapd_data: Interface if-lan wasn't started
Sat Dec 25 22:10:17 2021 daemon.notice hostapd: if-guest: CTRL-EVENT-TERMINATING
Sat Dec 25 22:10:17 2021 daemon.err hostapd: hostapd_free_hapd_data: Interface if-guest wasn't started
Sat Dec 25 22:10:17 2021 daemon.notice netifd: radio0 (1761): Command failed: Invalid argument
Sat Dec 25 22:10:17 2021 daemon.notice netifd: radio0 (1761): Device setup failed: HOSTAPD_START_FAILED

those lines are printed when the router boots up. if I simply restart the wifi interface afterwards it usually comes up and behaves as expected. this is mostly reproducible.

I am using openwrt 21.02.1 and have removed wpad-basic-wolfssl in favor of wpad-mesh-wolfssl and I have a somewhat expensive wifi config:

config wifi-device 'radio0'
	option type 'mac80211'
	option channel '2'
	option hwmode '11g'
	option path 'platform/10180000.wmac'
	option htmode 'HT20'
	option cell_density '0'
	option country 'DE'

config wifi-iface 'lan'
	option device 'radio0'
	option mode 'ap'
	option ssid 'FeWo'
	option network 'lan'
	option ifname 'if-lan'
	option key 'xxx'
	option encryption 'psk2+ccmp'
	option disabled '0'

config wifi-iface 'batman'
	option device 'radio0'
	option mode 'mesh'
	option ifname 'if-bat'
	option mesh_id 'mesh-bridge'
	option mesh_fwding '0'
	option network 'if_mesh'
	option encryption 'sae'
	option key 'xxx'
	option hidden '1'

config wifi-iface 'guest'
	option device 'radio0'
	option mode 'ap'
	option key 'xxx'
	option ssid 'Gast'
	option ifname 'if-guest'
	option network 'guest'
	option isolate '1'
	option encryption 'psk2+ccmp'
	option disabled '0'

does anyone experience the same? basically i only need the wifi to come up successfully when booting

best regards