Dir 600 b5e installing openwrt / lede

dir 600 b5e
installing using lede/openwrt i stumble no so many way to flash this one...but still no luck..can someone who knows how to flash this one..pls enlighten..me
thanks god bless

Not supported in LEDE.

This device isn't officially supported by LEDE.
The OpenWrt wiki however states: DIR-600 B5E uses DIR-610 A1 image, see


Please mind the note saying

NOTE: Suggested firmware openwrt-ramips-rt305x-dir-610-a1-*.bin leads to a kernel panic.

-> You should be prepared to build your own image with the patch mentioned in the link above.

it's working but it has the following problem https://bugs.lede-project.org/index.php?do=details&task_id=1199 so it can't be used if you reboot it


i already done all of that still no luck....i will just stick to tplink

I just installed LEDE on Dir 600 B5E and it's working fine.

I installed first
from the recovery interface:
Set the static IP to and mask to the PC.
To get to recovery interface, disconnect the power from the router, and reconnect it keeping the reset button for another 5 seconds.
Connect the cable from the PC to one of the lan ports.
go to in the browser.
Flash the firmware above.
Wait 90 seconds.
Change the PC network adapter setting to DHCP.
SSH to using putty (root with no password). At this point, there is no UI.
Set root password.
Install Luci:
opkg update
opkg install luci
Enable and start Luci
/etc/init.d/uhttpd enable
/etc/init.d/uhttpd start
Open luci in your browser at
Go to firmware update

It worked for me.
I tried other OpenWrt builds and I had all kind of problems. The router locked up with the older build or loosed all settings after reboot with newer builds. With this build, it worked well.

1 Like

@cristidb Many thanks !
seems that sysupgrade after factory flash is working


The flash file you link to at the top of your post is the same as the one on the bottom of your post. Is this by accident?

I just flashed that file into the DIR-600 and then enabled and started Luci over SSH (without updating/installing it first).

That means I didn't do the last step (firmware update with the same firmware?). Not sure if I have the correct firmware installed now, but it seems to work...

The first one is a factory image.
The second one is a sysupgrade image.
There is no need to install the sysupgrade right after the factory image.

They are different.

Download and do a compare in a hex editor.

One is going from stock to OpenWrt/LEDE (squashfs-factory.bin)

The other upgrades a previous version of OpenWrt/LEDE. (squashfs-sysupgrade.bin)

Ah right, thanks for the quick replies! Sorry I missed that.

I did notice that when only installing the factory image according to the instructions in this thread and then not flashing it with the upgrade image, it seems the router "forgets" (boot?) settings upon a cold start. Could also be just me messing up network settings though.

I tried it again with the final sysupgrade flash and all seems to be fine now. Good stuff :slight_smile:

Yes, without the sysupgrade firmware, the router forgets the settings on reset.
Unfortunately, the performance with the LEDE firmware is bad. I wanted to use it as a wireless repeater, but I only get 10-12Mbps which is way to low. I expected 25-30. Even wired, the speed is lower than with the original firmware. I went back to the original firmware on which it has decent speeds. No limitation for wired connections and 50-60Mbps for wireless.

I can confirm that you need to flash the sysupgrade image before reboot, after the factory image, if not, it will not boot anymore !
don't know why!


I'll make a test with my own, right not I don't have access to it.

OK, then that's specific for this device and different to the general procedure.

so I tested mine with a 4.14 kernel snapshot and I get like
30/35 up/down near the router with an x230 thinkpad

[    0.000000] Linux version 4.14.23 (build@build) (gcc version 7.3.0 (OpenWrt GCC 7.3.0 r6395-6c194078db)) #0 Wed Mar 7 16:01:07 2018
[    0.000000] SoC Type: Ralink RT5350 id:1 rev:3
[    0.000000] bootconsole [early0] enabled
[    0.000000] CPU0 revision is: 0001964c (MIPS 24KEc)
[    0.000000] MIPS: machine is D-Link DIR-610 A1